libpq-dev_9.4.15-0+deb8u1_i386.deb


Advertisement

Description

libpq-dev - header files for libpq5 (PostgreSQL library)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libpq-dev
Package version 9.4.15
Package release 0+deb8u1
Package architecture i386
Package type deb
Installed size 652 B
Download size 171.54 KB
Official Mirror ftp.br.debian.org
Header files and static library for compiling C programs to link
with the libpq library in order to communicate with a PostgreSQL
database backend.
PostgreSQL is an object-relational SQL database management system.

Alternatives

Package Version Architecture Repository
libpq-dev_9.4.15-0+deb8u1_amd64.deb 9.4.15 amd64 Debian Main
libpq-dev - - -

Requires

Name Value
comerr-dev -
krb5-multidev -
libc6 >= 2.4
libpq5 = 9.4.15-0+deb8u1
libssl-dev -

Download

Type URL
Binary Package libpq-dev_9.4.15-0+deb8u1_i386.deb
Source Package postgresql-9.4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpq-dev deb package:
    # sudo apt-get install libpq-dev

Files

Path
/usr/bin/pg_config
/usr/include/postgresql/libpq-events.h
/usr/include/postgresql/libpq-fe.h
/usr/include/postgresql/pg_config.h
/usr/include/postgresql/pg_config_ext.h
/usr/include/postgresql/pg_config_manual.h
/usr/include/postgresql/pg_config_os.h
/usr/include/postgresql/postgres_ext.h
/usr/include/postgresql/internal/c.h
/usr/include/postgresql/internal/libpq-int.h
/usr/include/postgresql/internal/port.h
/usr/include/postgresql/internal/postgres_fe.h
/usr/include/postgresql/internal/pqexpbuffer.h
/usr/include/postgresql/internal/libpq/pqcomm.h
/usr/include/postgresql/libpq/libpq-fs.h
/usr/lib/i386-linux-gnu/libpgcommon.a
/usr/lib/i386-linux-gnu/libpgport.a
/usr/lib/i386-linux-gnu/libpq.a
/usr/lib/i386-linux-gnu/libpq.so
/usr/lib/i386-linux-gnu/pkgconfig/libpq.pc
/usr/share/doc/libpq-dev/changelog.Debian.gz
/usr/share/doc/libpq-dev/changelog.gz
/usr/share/doc/libpq-dev/copyright
/usr/share/locale/cs/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/de/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/es/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/fr/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/it/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/ja/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/ko/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/nb/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/pl/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/pt_BR/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/ro/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/ru/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/sv/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/ta/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/tr/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/zh_CN/LC_MESSAGES/pg_config-9.4.mo
/usr/share/locale/zh_TW/LC_MESSAGES/pg_config-9.4.mo
/usr/share/man/man1/pg_config.1.gz

Changelog

See postgresql-9.4_9.4.15-0+deb8u1_i386.deb changelog.

See Also

Package Description
libpq5_9.4.15-0+deb8u1_i386.deb PostgreSQL C client library
libpqtypes-dev_1.5.1-2_i386.deb parameterized queries libpq extension - development
libpqtypes0_1.5.1-2_i386.deb parameterized queries libpq extension - shared library
libpqxx-4.0_4.0.1+dfsg-3_i386.deb C++ library to connect to PostgreSQL
libpqxx-dev_4.0.1+dfsg-3_i386.deb C++ library to connect to PostgreSQL (development files)
libpqxx-doc_4.0.1+dfsg-3_all.deb C++ library to connect to PostgreSQL (documentation)
libpqxx3-dev_4.0.1+dfsg-3_all.deb Transitional dummy package for libpqxx-dev
libpracticalxml-java_1.1.17-1_all.deb practical XML handling routines
libpragmatic-perl_1.7-2_all.deb Adds pragmata to Exporter
libpreferencepanes-dev_1.2.0-2_i386.deb GNUstep preferences library - development files
libpreferencepanes1_1.2.0-2_i386.deb GNUstep preferences library - runtime library
libprefork-perl_1.04-2_all.deb Module loading for forking or non-forking processes in Perl
libprelude-dev_1.0.0-11.4_i386.deb Security Information Management System [ Development files ]
libprelude-perl_1.0.0-11.4_i386.deb Security Information Management System [ Base library ]
libprelude2_1.0.0-11.4_i386.deb Security Information Management System [ Base library ]
Advertisement
Advertisement