libpopt0_1.16-10_i386.deb


Advertisement

Description

libpopt0 - lib for parsing cmdline parameters

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libpopt0
Package version 1.16
Package release 10
Package architecture i386
Package type deb
Installed size 129 B
Download size 49.87 KB
Official Mirror ftp.br.debian.org
Popt was heavily influenced by the getopt() and getopt_long() functions,
but it allows more powerful argument expansion. It can parse arbitrary
argv[] style arrays and automatically set variables based on command
line arguments. It also allows command line arguments to be aliased via
configuration files and includes utility functions for parsing arbitrary
strings into argv[] arrays using shell-like rules.
This package contains the runtime library and locale data.

Alternatives

Package Version Architecture Repository
libpopt0_1.16-10_amd64.deb 1.16 amd64 Debian Main
libpopt0 - - -

Requires

Name Value
libc6 >= 2.17
multiarch-support -

Conflicts

Name Value
libpopt-dev <= 1.4-1
popt -
rpm <= 4.0.2-3

Replaces

Name Value
popt -

Download

Type URL
Binary Package libpopt0_1.16-10_i386.deb
Source Package popt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpopt0 deb package:
    # sudo apt-get install libpopt0

Files

Path
/lib/i386-linux-gnu/libpopt.so.0
/lib/i386-linux-gnu/libpopt.so.0.0.0
/usr/share/doc/libpopt0/README
/usr/share/doc/libpopt0/changelog.Debian.gz
/usr/share/doc/libpopt0/changelog.gz
/usr/share/doc/libpopt0/copyright
/usr/share/locale/cs/LC_MESSAGES/popt.mo
/usr/share/locale/da/LC_MESSAGES/popt.mo
/usr/share/locale/de/LC_MESSAGES/popt.mo
/usr/share/locale/eo/LC_MESSAGES/popt.mo
/usr/share/locale/es/LC_MESSAGES/popt.mo
/usr/share/locale/fi/LC_MESSAGES/popt.mo
/usr/share/locale/fr/LC_MESSAGES/popt.mo
/usr/share/locale/ga/LC_MESSAGES/popt.mo
/usr/share/locale/gl/LC_MESSAGES/popt.mo
/usr/share/locale/hu/LC_MESSAGES/popt.mo
/usr/share/locale/id/LC_MESSAGES/popt.mo
/usr/share/locale/is/LC_MESSAGES/popt.mo
/usr/share/locale/it/LC_MESSAGES/popt.mo
/usr/share/locale/ja/LC_MESSAGES/popt.mo
/usr/share/locale/ko/LC_MESSAGES/popt.mo
/usr/share/locale/lv/LC_MESSAGES/popt.mo
/usr/share/locale/nb/LC_MESSAGES/popt.mo
/usr/share/locale/nl/LC_MESSAGES/popt.mo
/usr/share/locale/pl/LC_MESSAGES/popt.mo
/usr/share/locale/pt/LC_MESSAGES/popt.mo
/usr/share/locale/ro/LC_MESSAGES/popt.mo
/usr/share/locale/ru/LC_MESSAGES/popt.mo
/usr/share/locale/sk/LC_MESSAGES/popt.mo
/usr/share/locale/sl/LC_MESSAGES/popt.mo
/usr/share/locale/sv/LC_MESSAGES/popt.mo
/usr/share/locale/th/LC_MESSAGES/popt.mo
/usr/share/locale/tr/LC_MESSAGES/popt.mo
/usr/share/locale/uk/LC_MESSAGES/popt.mo
/usr/share/locale/vi/LC_MESSAGES/popt.mo
/usr/share/locale/wa/LC_MESSAGES/popt.mo
/usr/share/locale/zh_CN/LC_MESSAGES/popt.mo
/usr/share/locale/zh_TW/LC_MESSAGES/popt.mo

Changelog

2014-08-25 - Paul Martin <pm@debian.org>
popt (1.16-10) unstable; urgency=low
* debian/rules: move dependency on target autoreconf-stamp from 
configure (which isn't called) to configure-deb-stamp and 
configure-udeb-stamp.
* Patches: 757935-autoreconf.patch: add change to Makefile.am of 
testit.sh path.
* That'll teach me to try to be too clever! (Closes: #757935)
2014-08-25 - Paul Martin <pm@debian.org>
popt (1.16-9) unstable; urgency=low
* Patches:
+ 728596-secure-getenv.patch: update to change #elseif (not recognised
by gcc) to #elif.
+ 757935-autoreconf.patch: remove AM_C_PROTOTYPES from configure.ac
* Add dependency on dh-autoreconf, and use that in debian/rules instead
of directly using the rules from autotools-dev. (Closes: #757935)
* Update to standards version 3.9.5 (no changes)
2013-11-03 - Paul Martin <pm@debian.org>
popt (1.16-8) unstable; urgency=low
* Remove build dependency on quilt. (Closes: #709541)
* Fix renamed __secure_getenv() function for building with glibc 2.17
and later. (Closes: #728596)
* Use dh_autotools-dev_updateconfig and dh_autotools-dev_restoreconfig
to keep config.sub and config.guess up to date.
Build-depend on autotools-dev.
2012-05-30 - Paul Martin <pm@debian.org>
popt (1.16-7) unstable; urgency=low
* Fix install directory for the pkgconfig file. (Closes: #658663)
Thanks to Christoph Biedl for spotting the oddity.
dh_install strikes again!
2012-05-29 - Paul Martin <pm@debian.org>
popt (1.16-6) unstable; urgency=low
* Change dependency on gettext to a version that has a msgfmt that
always builds little endian .mo files. (Closes: #670023)
2012-05-14 - Paul Martin <pm@debian.org>
popt (1.16-5) unstable; urgency=low
* Enabled hardened build flags. (Closes: #672835)
2012-05-02 - Paul Martin <pm@debian.org>
popt (1.16-4) unstable; urgency=low
* Multiarch build cleanup take 2. (Closes: #670022)
* Ignoring localizations binary endianness versus multiarch problem.
That's something for gettext to fix. Thanks for the advice, vorlon.
(Ignoring: #670023)
* Update to debhelper 9.
* Update to standards version 3.9.2
* Updated copyright file and converted to machine readable format.
2011-12-20 - Paul Martin <pm@debian.org>
popt (1.16-3) unstable; urgency=low
* Multiarch build cleanup. Thanks to Jakub Wilk. (Closes: #638447)
2011-12-19 - Paul Martin <pm@debian.org>
popt (1.16-2) unstable; urgency=low
* Update to standards version 3.9.2
+ Comply with new build-arch/build-indep requirements.
+ Note that libtool .la files are deprecated under Debian policy 3.9.1,
but continute to include libpopt.la under the "historical" exception.
* Package upstream's libpopt.pc (Closes: #421575)
* Add multiarch support. Thanks to Steve Langasek for patch.
(Closes: #638447)
* Update debian/compat to 8.
* Add a debian/symbols file. (Closes: #551437)
2010-05-13 - Paul Martin <pm@debian.org>
popt (1.16-1) unstable; urgency=low
* New upstream release (Closes: #581439)
* Switch to dpkg-source 3.0 (quilt) format
* Add a watch file.
* Update to standards version 3.8.4 (no changes)

See Also

Package Description
libportaudio-ocaml-dev_0.2.0-1+b2_i386.deb OCaml bindings for the portaudio library
libportaudio-ocaml_0.2.0-1+b2_i386.deb OCaml bindings for the portaudio library
libportaudio2_19+svn20140130-1_i386.deb Portable audio I/O - shared library
libportaudiocpp0_19+svn20140130-1_i386.deb Portable audio I/O C++ bindings - shared library
libportlet-api-2.0-spec-java-doc_1.0-2_all.deb Java Portlet Specification V2.0 - documentation
libportlet-api-2.0-spec-java_1.0-2_all.deb Java Portlet Specification V2.0
libportmidi-dev_184-2.2_i386.deb library for real-time MIDI input/output
libportmidi0_184-2.2_i386.deb library for real-time MIDI input/output
libportsmf-dev_0.1~svn20101010-4_i386.deb Portable Standard Midi File Library (development files)
libportsmf0_0.1~svn20101010-4_i386.deb Portable Standard Midi File Library
libposix-atfork-perl_0.02-1+b2_i386.deb hook registrations at fork(2)
libposix-strftime-compiler-perl_0.40-1_all.deb GNU C library compatible strftime for loggers and servers
libposix-strptime-perl_0.10-4_i386.deb Perl extension to the POSIX date parsing strptime(3) function
libpostfix-parse-mailq-perl_1.004-1_all.deb module to parse the postfix mail queue
libpostgis-java-doc_2.1.4+dfsg-3_all.deb Geographic objects support for PostgreSQL -- JDBC documentation
Advertisement
Advertisement