libpolarssl-dev_1.3.9-2.1+deb8u2_i386.deb


Advertisement

Description

libpolarssl-dev - lightweight crypto and SSL/TLS library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libpolarssl-dev
Package version 1.3.9
Package release 2.1+deb8u2
Package architecture i386
Package type deb
Installed size 1.37 KB
Download size 325.79 KB
Official Mirror ftp.br.debian.org
PolarSSL is a lean open source crypto library for providing SSL and TLS
support in your programs. It offers an intuitive API and documented header
files, so you can actually understand what the code does. It features:
- Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, Camellia
and XTEA
- Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5
- Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG
- Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, ECDSA
and ECDH
- SSL v3 and TLS 1.0, 1.1 and 1.2
- Abstraction layers for ciphers, hashes, public key operations, platform
abstraction and threading
This package contains the static library and the header files.

Alternatives

Package Version Architecture Repository
libpolarssl-dev_1.3.9-2.1+deb8u2_amd64.deb 1.3.9 amd64 Debian Main
libpolarssl-dev - - -

Requires

Name Value
libc6-dev -
libpolarssl7 = 1.3.9-2.1+deb8u2

Download

Type URL
Binary Package libpolarssl-dev_1.3.9-2.1+deb8u2_i386.deb
Source Package polarssl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpolarssl-dev deb package:
    # sudo apt-get install libpolarssl-dev

Files

Path
/usr/include/polarssl/aes.h
/usr/include/polarssl/aesni.h
/usr/include/polarssl/arc4.h
/usr/include/polarssl/asn1.h
/usr/include/polarssl/asn1write.h
/usr/include/polarssl/base64.h
/usr/include/polarssl/bignum.h
/usr/include/polarssl/blowfish.h
/usr/include/polarssl/bn_mul.h
/usr/include/polarssl/camellia.h
/usr/include/polarssl/ccm.h
/usr/include/polarssl/certs.h
/usr/include/polarssl/check_config.h
/usr/include/polarssl/cipher.h
/usr/include/polarssl/cipher_wrap.h
/usr/include/polarssl/compat-1.2.h
/usr/include/polarssl/config.h
/usr/include/polarssl/ctr_drbg.h
/usr/include/polarssl/debug.h
/usr/include/polarssl/des.h
/usr/include/polarssl/dhm.h
/usr/include/polarssl/ecdh.h
/usr/include/polarssl/ecdsa.h
/usr/include/polarssl/ecp.h
/usr/include/polarssl/entropy.h
/usr/include/polarssl/entropy_poll.h
/usr/include/polarssl/error.h
/usr/include/polarssl/gcm.h
/usr/include/polarssl/havege.h
/usr/include/polarssl/hmac_drbg.h
/usr/include/polarssl/md.h
/usr/include/polarssl/md2.h
/usr/include/polarssl/md4.h
/usr/include/polarssl/md5.h
/usr/include/polarssl/md_wrap.h
/usr/include/polarssl/memory.h
/usr/include/polarssl/memory_buffer_alloc.h
/usr/include/polarssl/net.h
/usr/include/polarssl/oid.h
/usr/include/polarssl/openssl.h
/usr/include/polarssl/padlock.h
/usr/include/polarssl/pbkdf2.h
/usr/include/polarssl/pem.h
/usr/include/polarssl/pk.h
/usr/include/polarssl/pk_wrap.h
/usr/include/polarssl/pkcs11.h
/usr/include/polarssl/pkcs12.h
/usr/include/polarssl/pkcs5.h
/usr/include/polarssl/platform.h
/usr/include/polarssl/ripemd160.h
/usr/include/polarssl/rsa.h
/usr/include/polarssl/sha1.h
/usr/include/polarssl/sha256.h
/usr/include/polarssl/sha512.h
/usr/include/polarssl/ssl.h
/usr/include/polarssl/ssl_cache.h
/usr/include/polarssl/ssl_ciphersuites.h
/usr/include/polarssl/threading.h
/usr/include/polarssl/timing.h
/usr/include/polarssl/version.h
/usr/include/polarssl/x509.h
/usr/include/polarssl/x509_crl.h
/usr/include/polarssl/x509_crt.h
/usr/include/polarssl/x509_csr.h
/usr/include/polarssl/xtea.h
/usr/lib/libpolarssl.a
/usr/lib/libpolarssl.so
/usr/share/doc/libpolarssl-dev/changelog.Debian.gz
/usr/share/doc/libpolarssl-dev/changelog.gz
/usr/share/doc/libpolarssl-dev/copyright

Changelog

2017-05-09 - James Cowgill <jcowgill@debian.org>
polarssl (1.3.9-2.1+deb8u2) jessie; urgency=high
* Fix CVE-2017-2784: Freeing of memory allocated on stack when
validating a public key with a secp224k1 curve. (Closes: #857561)
2016-02-05 - Guido G√ľnther <agx@sigxcpu.org>
polarssl (1.3.9-2.1+deb8u1) jessie-security; urgency=high
* Non-maintainer upload.
* Backport patches for CVE-2015-5291 and CVE-2015-8036
(Closes: #801413)
* Add simple smoke test
2015-01-21 - Salvatore Bonaccorso <carnil@debian.org>
polarssl (1.3.9-2.1) unstable; urgency=high
* Non-maintainer upload.
* Add CVE-2015-1182.patch patch.
CVE-2015-1182: Denial of service and possible remote code execution
using crafted certificates. (Closes: #775776)
2014-11-07 - Roland Stigge <stigge@antcom.de>
polarssl (1.3.9-2) unstable; urgency=medium
* Disabled POLARSSL_SSL_PROTO_SSL3 at compile time to prevent potential
attacks, TLS considered standard for clients now, and consistency w/
OpenSSL in Debian
2014-11-05 - Roland Stigge <stigge@antcom.de>
polarssl (1.3.9-1) unstable; urgency=medium
* New upstream release
2014-08-31 - Roland Stigge <stigge@antcom.de>
polarssl (1.3.8-1) unstable; urgency=medium
* New upstream release
* debian/control: Adjust package description, thanks to Paul Bakker
(upstream)
* Removed CVE-2014-4911.patch (integrated upstream)
2014-07-15 - Salvatore Bonaccorso <carnil@debian.org>
polarssl (1.3.7-2.1) unstable; urgency=high
* Non-maintainer upload with maintainers approval.
* Add CVE-2014-4911.patch patch.
CVE-2014-4911: Fix Denial of Service against GCM enabled servers (and
clients). (Closes: #754655)
2014-05-05 - Roland Stigge <stigge@antcom.de>
polarssl (1.3.7-2) unstable; urgency=medium
* Enabled POLARSSL_THREADING_C and POLARSSL_THREADING_PTHREAD in config,
recommended for Debian by upstream
2014-05-02 - Roland Stigge <stigge@antcom.de>
polarssl (1.3.7-1) unstable; urgency=medium
* New upstream release (Closes: #745720)
* Fixed .so link in libpolarssl-dev.links (Closes: #745716)
2014-04-12 - Roland Stigge <stigge@antcom.de>
polarssl (1.3.6-1) unstable; urgency=medium
* New upstream release, SONAME version 6

See Also

Package Description
libpolarssl-runtime_1.3.9-2.1+deb8u2_i386.deb lightweight crypto and SSL/TLS library
libpolarssl7_1.3.9-2.1+deb8u2_i386.deb lightweight crypto and SSL/TLS library
libpoldiff-dev_3.3.8-3.1_i386.deb Security Enhanced Linux semantic policy differences development
libpoldiff1_3.3.8-3.1_i386.deb Security Enhanced Linux semantic policy differences library
libpolkit-agent-1-0_0.105-15~deb8u2_i386.deb PolicyKit Authentication Agent API
libpolkit-agent-1-dev_0.105-15~deb8u2_i386.deb PolicyKit Authentication Agent API - development files
libpolkit-backend-1-0_0.105-15~deb8u2_i386.deb PolicyKit backend API
libpolkit-backend-1-dev_0.105-15~deb8u2_i386.deb PolicyKit backend API - development files
libpolkit-gobject-1-0_0.105-15~deb8u2_i386.deb PolicyKit Authorization API
libpolkit-gobject-1-dev_0.105-15~deb8u2_i386.deb PolicyKit Authorization API - development files
libpolkit-gtk-mate-1-0_1.8.0+dfsg1-4_i386.deb MATE authentication agent for PolicyKit-1 (library)
libpolkit-qt-1-1_0.103.0-1_i386.deb PolicyKit-qt-1 library
libpolkit-qt-1-dev_0.103.0-1_i386.deb PolicyKit-qt-1 development files
libpolybori-0.8-3_0.8.3-3+b2_i386.deb polynomials over Boolean Rings, shared library
libpolybori-dev_0.8.3-3+b2_i386.deb polynomials over Boolean Rings, core development files
Advertisement
Advertisement