libpod-constants-perl_0.16-2_all.deb


Advertisement

Description

libpod-constants-perl - module for including constants from POD

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libpod-constants-perl
Package version 0.16
Package release 2
Package architecture all
Package type deb
Installed size 71 B
Download size 17.79 KB
Official Mirror ftp.br.debian.org
This module allows you to specify those constants that should be
documented in your POD, and pull them out a run time in a fairly
arbitrary fashion.
Pod::Constants uses Pod::Parser to do the parsing of the source file.
It has to open the source file it is called from, and does so directly
either by lookup in %INC or by assuming it is $0 if the caller is
"main" (or it can't find %INC{caller()})

Alternatives

Package Version Architecture Repository
libpod-constants-perl_0.16-2_all.deb 0.16 all Debian Main
libpod-constants-perl - - -

Requires

Name Value
base-files >= 4.0.1
perl -

Download

Type URL
Binary Package libpod-constants-perl_0.16-2_all.deb
Source Package libpod-constants-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpod-constants-perl deb package:
    # sudo apt-get install libpod-constants-perl

Files

Path
/usr/share/doc/libpod-constants-perl/changelog.Debian.gz
/usr/share/doc/libpod-constants-perl/changelog.gz
/usr/share/doc/libpod-constants-perl/copyright
/usr/share/man/man3/Pod::Constants.3pm.gz
/usr/share/perl5/Pod/Constants.pm

Changelog

2011-11-15 - gregor herrmann <gregoa@debian.org>
libpod-constants-perl (0.16-2) unstable; urgency=medium
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ gregor herrmann ]
* Switch to source format 3.0 (quilt).
* Add patch EUMM_AUTHOR.patch: adjust AUTHOR in Makefile.PL to older and
newer versions of ExtUtils::MakeMaker. (Closes: #629284)
* Switch to debhelper 8 and tiny debian/rules; don't install README
anymore; add some files to debian/clean.
* Convert debian/copyright to DEP5 format.
* Set Standards-Version to 3.9.2, drop version from perl build
dependency.
* Add /me to Uploaders.
* Make short description a noun phrase.
* Add a patch to fix 2 spelling mistakes.
* Set urgency to medium (RC bug, perl 5.14 transition).
2009-01-06 - David Paleino <d.paleino@gmail.com>
libpod-constants-perl (0.16-1.1) unstable; urgency=low
* NMU: removing myself from Uploaders (Closes: #509511)
[ David Paleino ]
* debian/control: Standards-Version 3.8.0 (no changes needed)
* debian/copyright: using the "Copyright" word for debian
packaging
* debian/control: removed libtest-simple-perl from Build-Depends,
since a suitable version is provided by the perl version (by
pulling perl-modules) we're already Build-Depending on.
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* debian/control: Added: ${misc:Depends} to Depends: field.
2007-10-25 - Damyan Ivanov <dmn@debian.org>
libpod-constants-perl (0.16-1) unstable; urgency=low
* Initial Release. Dependency of libwww-mechanize-shell-perl 0.46

See Also

Package Description
libpod-coverage-perl_0.23-1_all.deb checker for comprehensiveness of perl module documentation
libpod-coverage-trustpod-perl_0.100003-1_all.deb module to support hints for Pod::Coverage
libpod-elemental-perl_0.103001-1_all.deb module for manipulating POD elements
libpod-elemental-perlmunger-perl_0.200002-1_all.deb Perl module that rewrites Perl documentation
libpod-eventual-perl_0.094001-1_all.deb module to read a POD as a series of trivial events
libpod-index-perl_0.14-2_all.deb index and search PODs using X<> entries
libpod-latex-perl_0.61-1_all.deb module to convert Pod data to formatted LaTeX
libpod-markdown-perl_2.002000-1_all.deb module to convert POD to the Markdown file format
libpod-plainer-perl_1.04-1_all.deb Perl extension for converting Pod to old-style Pod
libpod-pom-perl_0.29-1_all.deb module providing a Pod Object Model
libpod-pseudopod-perl_0.18-1_all.deb framework for parsing PseudoPod
libpod-readme-perl_0.11-1_all.deb Perl module to convert POD to README file
libpod-sax-perl_0.14-5_all.deb Perl module for generating SAX events from POD
libpod-simple-perl_3.28-1_all.deb framework for parsing files in the Pod markup language
libpod-simple-wiki-perl_0.16-1_all.deb Perl class for creating Pod to Wiki filters
Advertisement
Advertisement