libplexus-compiler-javac-java_1.9.2-2_all.deb


Advertisement

Description

libplexus-compiler-javac-java - javac plugin for the Plexus compiler system (dummy package)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libplexus-compiler-javac-java
Package version 1.9.2
Package release 2
Package architecture all
Package type deb
Installed size 28 B
Download size 3.56 KB
Official Mirror ftp.br.debian.org
The Plexus project provides a full software stack for creating and executing
software projects. Based on the Plexus container, the applications can
utilise component-oriented programming to build modular, reusable components
that can easily be assembled and reused.
This is a dummy package to help upgrading the old
libplexus-compiler-javac-java.

Alternatives

Package Version Architecture Repository
libplexus-compiler-javac-java_1.9.2-2_all.deb 1.9.2 all Debian Main
libplexus-compiler-javac-java - - -

Requires

Name Value
libplexus-compiler-java = 1.9.2-2

Download

Type URL
Binary Package libplexus-compiler-javac-java_1.9.2-2_all.deb
Source Package plexus-compiler

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libplexus-compiler-javac-java deb package:
    # sudo apt-get install libplexus-compiler-javac-java

Files

Path
/usr/share/doc/libplexus-compiler-javac-java/changelog.Debian.gz
/usr/share/doc/libplexus-compiler-javac-java/copyright

Changelog

2014-01-21 - Emmanuel Bourg <ebourg@apache.org>
plexus-compiler (1.9.2-2) unstable; urgency=medium
* Team upload.
* Added a patch to set the missing versions of the dependencies in the poms
2013-11-06 - Emmanuel Bourg <ebourg@apache.org>
plexus-compiler (1.9.2-1) unstable; urgency=low
* Team upload
[ Ludovic Claude ]
* New upstream version, add myself to Uploaders
* d/control: Remove Build-Depends on libplexus-component-metadata-java
* Add Build-Depends on default-jdk-doc, libmaven2-core-java-doc,
libplexus-container-default-java-doc, libplexus-utils-java-doc
* Add dependency on libecj-java,
* Remove dependency on libaspectj-java, as plexus-aspectj-compiler
cannot compile with AspectJ 1.6
* Update description
* Create again the libplexus-compiler-java-doc package.
* d/watch: update to new location on Github
* d/orig-tar.sh: remove as it's not needed anymore
* d/patches: remove old patches, not needed anymore as the parent POM
is now packaged and contains the same information,
add a patch to fix the failing unit tests
[ Emmanuel Bourg ]
* Added a patch to compile with the Eclipse compiler available in Debian
* Added a patch to preserve the compatibility with maven-stapler-plugin
* debian/control:
- Updated Standards-Version to 3.9.5 (no changes)
- Marked junit as a suggested dependency
* Build depend on debhelper >= 9
* debian/copyright: Updated the Format URI to 1.0
2011-12-08 - Damien Raude-Morvan <drazzib@debian.org>
plexus-compiler (1.6-2) unstable; urgency=low
* Team upload.
* d/maven.rules: Force usage of default plexus-utils 1.x.
* d/patches/0002-add-version-3.8.2-to-dependency-junit.patch: Rework patch
to use dependencyManagment to set junit version.
* Bump Standards-Version to 3.9.2:
- Add missing missing misc:Depends
- Set other packages as dummy in synopsis
* d/copyright: Small fix to DEP-5 format.
2011-08-26 - Torsten Werner <twerner@debian.org>
plexus-compiler (1.6-1) unstable; urgency=low
* Merge 3 plexus-compiler-* source package into 1 source package
plexus-compiler.
* New (but not newest) upstream version. Ignore test failures.
* Remove Paul from Uploaders list.
* Add myself to Uploaders.
* Update Standards-Version: 3.9.1.
* Switch to debhelper level 7.
* Switch to source version 3.0.
2009-08-09 - Torsten Werner <twerner@debian.org>
plexus-compiler-api (1.5.3-3) unstable; urgency=low
* Upload to unstable.
2009-03-23 - Ludovic Claude <ludovic.claude@laposte.net>
plexus-compiler-api (1.5.3-2) experimental; urgency=low
* Change section to java
* Add the Maven POM to the package
* Add a Build-Depends-Indep dependency on maven-repo-helper
* Use mh_installpom and mh_installjar to install the POM and the jar to the
Maven repository
* Update watch file and orig-tar.sh to keep working. Use SVN to download sources
* Change debian/build.xml: use Java source version 1.4 for compatibility,
don't include META-INF/ folder from the sources
* Fix Lintian warning: remove full Apache licence text from the copyright file
* Change the dependency on libplexus-container-default-java to 
libplexus-containers-java
2008-04-06 - Paul Cager <paul-debian@home.paulcager.org>
plexus-compiler-api (1.5.3-1) unstable; urgency=low
* Initial release.
(Closes: 474610).

See Also

Package Description
libplexus-compiler-manager-java_1.9.2-2_all.deb manager for the Plexus compiler system (dummy package)
libplexus-component-api-java-doc_1.0.0~alpha22-3_all.deb API Documentation for plexus-component-api
libplexus-component-api-java_1.0.0~alpha22-3_all.deb utilities for the Plexus framework
libplexus-component-metadata-java_1.0~beta3.0.7-5_all.deb Component Metadata Maven plugin for Plexus
libplexus-container-default-java-doc_1.0-alpha-9-stable-1-7_all.deb API Documentation for plexus-container-default
libplexus-container-default-java_1.0-alpha-9-stable-1-7_all.deb utilities for the Plexus framework
libplexus-containers-java-doc_1.0~beta3.0.7-7_all.deb API Documentation for plexus-container-default
libplexus-containers-java_1.0~beta3.0.7-7_all.deb utilities for the Plexus framework
libplexus-containers1.5-java-doc_1.5.5-6_all.deb Plexus' inversion-of-control (IoC) container - documentation
libplexus-containers1.5-java_1.5.5-6_all.deb Plexus' inversion-of-control (IoC) container
libplexus-digest-java-doc_1.1-3_all.deb Documentation for Digest utilities for the Plexus system
libplexus-digest-java_1.1-3_all.deb Digest utilities for the Plexus system
libplexus-i18n-java-doc_1.0-beta-10-3_all.deb API Documentation for plexus-i18n
libplexus-i18n-java_1.0-beta-10-3_all.deb a component to support internationalization of applications using Plexus
libplexus-interactivity-api-java-doc_1.0-alpha-6-7_all.deb API Documentation for plexus-interactivity-api
Advertisement
Advertisement