libphp-snoopy_2.0.0-1_all.deb


Advertisement

Description

libphp-snoopy - Snoopy is a PHP class that simulates a web browser

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libphp-snoopy
Package version 2.0.0
Package release 1
Package architecture all
Package type deb
Installed size 78 B
Download size 15.81 KB
Official Mirror ftp.br.debian.org
It automates the task of retrieving web page content and posting forms,
for example.
Some of Snoopy's features:
* easily fetch the contents of a web page
* easily fetch the text from a web page (strip html tags)
* easily fetch the links from a web page
* supports proxy hosts
* supports basic user/pass authentication
* supports setting user_agent, referer, cookies and header content
* supports browser redirects, and controlled depth of redirects
* expands fetched links to fully qualified URLs (default)
* easily submit form data and retrieve the results
* supports following html frames (added v0.92)
* supports passing cookies on redirects (added v0.92)

Alternatives

Package Version Architecture Repository
libphp-snoopy_2.0.0-1_all.deb 2.0.0 all Debian Main
libphp-snoopy - - -

Requires

Name Value
php5 -
php5-cli -

Download

Type URL
Binary Package libphp-snoopy_2.0.0-1_all.deb
Source Package libphp-snoopy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libphp-snoopy deb package:
    # sudo apt-get install libphp-snoopy

Files

Path
/usr/share/doc/libphp-snoopy/FAQ
/usr/share/doc/libphp-snoopy/NEWS.gz
/usr/share/doc/libphp-snoopy/README.gz
/usr/share/doc/libphp-snoopy/TODO
/usr/share/doc/libphp-snoopy/changelog.Debian.gz
/usr/share/doc/libphp-snoopy/changelog.gz
/usr/share/doc/libphp-snoopy/copyright
/usr/share/php/libphp-snoopy/Snoopy.class.php

Changelog

2015-02-24 - Marcelo Jorge Vieira <metal@debian.org>
libphp-snoopy (2.0.0-1) unstable; urgency=high
* New upstream release:
+ Fixes: CVE-2008-7313 and CVE-2014-5008 (Closes: #778634)
+ Remove curl dependency
* Control:
+ Remove trailing spaces
+ Use canonical Vcs-fields
+ Updated Standards-Version to 3.9.6 (no changes)
* Switch to dpkg-source 3.0 (quilt) format
2010-03-20 - Marcelo Jorge Vieira (metal) <metal@debian.org>
libphp-snoopy (1.2.4-2) unstable; urgency=low
* Fixed debian-watch-file-should-use-sf-redirector
* Removing cdbs references and bumping package to debhelper 7
* Updated Standards-Version to 3.8.4 (no changes)
* Changing my email for Debian address
* Changed VCS fields to my new account in Alioth
* Changed package section from 'web' to 'php'
2008-10-28 - Marcelo Jorge Vieira (metal) <metal@alucinados.com>
libphp-snoopy (1.2.4-1) unstable; urgency=high
* New Upstream Version
- fixes CVE-2008-4796 (Closes: #504168)
2008-01-31 - Marcelo Jorge Vieira (metal) <metal@alucinados.com>
libphp-snoopy (1.2.3-2) unstable; urgency=low
* Added watch file
* Updated Standards-Version to 3.7.3
2007-09-14 - Marcelo Jorge Vieira (metal) <metal@alucinados.com>
libphp-snoopy (1.2.3-1) unstable; urgency=low
* Initial release (Closes: #442303)

See Also

Package Description
libphp-swiftmailer_5.2.2-1+deb8u1_all.deb transitional dummy package
libphp5-embed_5.6.33+dfsg-0+deb8u1_i386.deb HTML-embedded scripting language (Embedded SAPI library)
libphtools2-dev_20061220+dfsg3-3_i386.deb [Physics] General purpose Monte Carlo routines (development files)
libphtools2-gfortran_20061220+dfsg3-3_i386.deb [Physics] General purpose Monte Carlo routines
libphysfs-dev_2.0.3-2_i386.deb filesystem abstraction library for game programmers (development headers)
libphysfs1_2.0.3-2_i386.deb filesystem abstraction library for game programmers
libpiano-dev_2014.06.08-1+b1_i386.deb library to interface with Pandora radio -- development
libpiano0_2014.06.08-1+b1_i386.deb library to interface with Pandora radio -- runtime files
libpiccolo-java_1.2-1_all.deb toolkit for development of 2D structured graphics
libpigment0.3-11_0.3.17-1_i386.deb User interfaces with embedded multimedia - shared library
libpigment0.3-dev_0.3.17-1_i386.deb User interfaces with embedded multimedia - development files
libpils2-dev_1.0.12~rc1+hg2777-1.2_i386.deb Reusable cluster development files -- libpils2
libpils2_1.0.12~rc1+hg2777-1.2_i386.deb Reusable cluster libraries -- libpils2
libpimcommon4_4.14.1-1+deb8u1_i386.deb library for common bits of KDEPIM
libpinyin-utils_1.0.0+repack2-1_i386.deb library to deal with PinYin - utilities
Advertisement
Advertisement