libperl-minimumversion-perl_1.38-1_all.deb


Advertisement

Description

libperl-minimumversion-perl - module to determine minimum required version of perl required

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libperl-minimumversion-perl
Package version: 1.38
Package release: 1
Package architecture: all
Package type: deb
Installed size: 115 B
Download size: 26.49 KB
Official Mirror: ftp.br.debian.org
Perl::MinimumVersion is a module that inspects arbitrary Perl source code and determines the minimum version of perl required to be able to run it. Because it is based on PPI, it can do this without having to actually load the code. Currently it tests both the syntax of your code, and the use of explicit version dependencies such as "require 5.005". Future plans are to also add support for tracing module dependencies.

    Download

    Source package: libperl-minimumversion-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libperl-minimumversion-perl deb package:
      # sudo apt-get install libperl-minimumversion-perl

    Files

    • /usr/bin/perlver
    • /usr/share/doc/libperl-minimumversion-perl/changelog.Debian.gz
    • /usr/share/doc/libperl-minimumversion-perl/changelog.gz
    • /usr/share/doc/libperl-minimumversion-perl/copyright
    • /usr/share/man/man1/perlver.1p.gz
    • /usr/share/man/man3/Perl::MinimumVersion.3pm.gz
    • /usr/share/perl5/Perl/MinimumVersion.pm
    • /usr/share/perl5/Perl/MinimumVersion/Reason.pm

    Changelog

    2014-08-23 - Salvatore Bonaccorso <carnil@debian.org> libperl-minimumversion-perl (1.38-1) unstable; urgency=medium * Update Vcs-Browser URL to cgit web frontend * Imported Upstream version 1.38

    2014-05-13 - gregor herrmann <gregoa@debian.org> libperl-minimumversion-perl (1.37-1) unstable; urgency=medium * New upstream release.

    2014-05-10 - gregor herrmann <gregoa@debian.org> libperl-minimumversion-perl (1.36-1) unstable; urgency=medium * New upstream release.

    2014-05-03 - gregor herrmann <gregoa@debian.org> libperl-minimumversion-perl (1.35-1) unstable; urgency=medium * New upstream release. * Strip trailing slash from metacpan URLs. * debian/copyright: update copyright years and drop stanza about removed files. * Bump required version of libppix-regexp-perl (build) dependency. * Declare compliance with Debian Policy 3.9.5.

    2013-06-28 - gregor herrmann <gregoa@debian.org> libperl-minimumversion-perl (1.32-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Imported Upstream version 1.30, 1.31 and 1.32 * Remove explicit perl Depends covered by ${perl:Depends} * Add versioned (build-)dependency for libppix-regexp-perl. Add versioned (Build-)Depends(-Indep) on libppix-regexp-perl (>= 0.029) * Update debian/copyright file information. Update format to copyright-format 1.0 as released together with Debian policy 3.9.3. Update copyright years for upstream files, bundled copy of Module::Install and debian/* packaging files. * Bump Standards-Version to 3.9.4 * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * Update years of packaging copyright.

    2011-03-04 - Salvatore Bonaccorso <carnil@debian.org> libperl-minimumversion-perl (1.28-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Bump debhelper compat to 8 * Refresh copyright information * Standards-Version 3.9.1 * Drop version dependencies satisfied in oldstable [ Ansgar Burchardt ] * Email change: Ansgar Burchardt -> ansgar@debian.org [ Salvatore Bonaccorso ] * Email change: Salvatore Bonaccorso -> carnil@debian.org * debian/control: - Make versioned (Build-)Depends(-Indep) on libparams-util-perl unversioned as version already satisfied in oldstable. - Make verisoned (Build-)Depends(-Indep) on libtest-script-perl and libfile-find-rule-perl-perl unversioned as both not in oldstable and already satisfied in squeeze. - Make (Build-)Depends(-Indep) on perl versioned to perl (>= 5.10.1). * debian/copyright: Update copyright years for debian/* packaging.

    2010-07-22 - Ansgar Burchardt <ansgar@43-1.org> libperl-minimumversion-perl (1.26-1) unstable; urgency=low * New upstream release. * debian/copyright: Update years of copyright for inc/*.

    2010-07-15 - Ansgar Burchardt <ansgar@43-1.org> libperl-minimumversion-perl (1.25-2) unstable; urgency=low [ Ansgar Burchardt ] * No longer run author tests. Remove build-dep on libtest-pod-perl, libtest-cpan-meta-perl, libpod-simple-perl, libtest-minimumversion-perl. (Closes: #589051) * Bump Standards-Version to 3.9.0 (no changes). [ gregor herrmann ] * Lower debhelper build dependency to 7, since there are no more overrides in debian/rules.

    2010-05-24 - gregor herrmann <gregoa@debian.org> libperl-minimumversion-perl (1.25-1) unstable; urgency=low [ Salvatore Bonaccorso ] * New upstream release * Drop patches: fix_578485_breaks_with_perl_5.12.patch applied upstream. [ gregor herrmann ] * Add /me to Uploaders.

    Advertisement
    Advertisement