libperl-destruct-level-perl_0.02-2+b1_i386.deb


Advertisement

Description

libperl-destruct-level-perl - Perl module to change Perl's destruction level

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libperl-destruct-level-perl
Package version: 0.02
Package release: 2+b1
Package architecture: i386
Package type: deb
Installed size: 13 B
Download size: 8.84 KB
Official Mirror: ftp.br.debian.org
Perl::Destruct::Level is an interface allowing one to change Perl's internal destruction level. While this functionality is available through the PERL_DESTRUCT_LEVEL environment variable when perl is compiled with debug support, this module provides it for perls without -DDEBUGGING. The default value of the destruct level is 0; it means that perl won't bother destroying all its internal data structures, but let the OS do the cleanup for it at exit. Relevant values recognized by perl are 1 and 2. Consult your source code to know exactly what they mean. Note that some embedded environments might extend the meaning of the destruction level for their own purposes: mod_perl does that, for example.

    Download

    Source package: libperl-destruct-level-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libperl-destruct-level-perl deb package:
      # sudo apt-get install libperl-destruct-level-perl

    Files

    • /usr/lib/i386-linux-gnu/perl5/5.20/Perl/Destruct/Level.pm
    • /usr/lib/i386-linux-gnu/perl5/5.20/auto/Perl/Destruct/Level/Level.so
    • /usr/share/doc/libperl-destruct-level-perl/changelog.Debian.gz
    • /usr/share/doc/libperl-destruct-level-perl/changelog.Debian.i386.gz
    • /usr/share/doc/libperl-destruct-level-perl/copyright
    • /usr/share/man/man3/Perl::Destruct::Level.3pm.gz

    Changelog

    2014-02-22 - gregor herrmann <gregoa@debian.org> libperl-destruct-level-perl (0.02-2) unstable; urgency=low * Team upload. [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ Ryan Niebur ] * Update jawnsy's email address [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ Axel Beckert ] * debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg- copyright" [ gregor herrmann ] * Switch to "3.0 (quilt)" source format. * debian/rules: three lines are enough with dh(1). * Refresh license stanzas in debian/copyright. * Use debhelper 9.20120312 to get all hardening flags. * Add patch to fix grammar problem discovered by lintian. * Declare compliance with Debian Policy 3.9.5.

    2009-04-30 - Jonathan Yu <frequency@cpan.org> libperl-destruct-level-perl (0.02-1) unstable; urgency=low * Initial Release. (Closes: #526385)

    Advertisement
    Advertisement