libparse-debian-packages-perl_0.03-2_all.deb


Advertisement

Description

libparse-debian-packages-perl - module for parsing the data from a Debian Packages.gz

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libparse-debian-packages-perl
Package version: 0.03
Package release: 2
Package architecture: all
Package type: deb
Installed size: 51 B
Download size: 6.49 KB
Official Mirror: ftp.br.debian.org
Parse::Debian::Packages parses the Packages files used by the Debian package management tools. It presents itself as an iterator. Each call of the ->next method will return the next package found in the file.

Requires

    Download

    Source package: libparse-debian-packages-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libparse-debian-packages-perl deb package:
      # sudo apt-get install libparse-debian-packages-perl

    Files

    • /usr/share/doc/libparse-debian-packages-perl/changelog.Debian.gz
    • /usr/share/doc/libparse-debian-packages-perl/changelog.gz
    • /usr/share/doc/libparse-debian-packages-perl/copyright
    • /usr/share/man/man3/Parse::Debian::Packages.3pm.gz
    • /usr/share/perl5/Parse/Debian/Packages.pm

    Changelog

    2014-03-03 - gregor herrmann <gregoa@debian.org> libparse-debian-packages-perl (0.03-2) unstable; urgency=low [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * Strip trailing slash from metacpan URLs. * Add patch to fix handling of multiline fields. Thanks to Simon Kainz for the bug report and the initial patch. (Closes: #695274) * Update years of packaging copyright. * Declare compliance with Debian Policy 3.9.5.

    2012-03-19 - gregor herrmann <gregoa@debian.org> libparse-debian-packages-perl (0.03-1) unstable; urgency=low [ Ansgar Burchardt ] * Email change: Ansgar Burchardt -> ansgar@debian.org * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * Remove alternative (build) dependencies that are already satisfied in oldstable. [ gregor herrmann ] * New upstream release. * debian/rules: drop buildsystem, Build.PL is gone. * Drop bug-579063.patch, fixed upstream. * debian/copyright: update to Copyright-Format 1.0, refresh license stanzas. * Set debhelper compatibility level to 8. * Bump Standards-Version to 3.9.3 (no changes). * Add /me to Uploaders. * Make short description a noun phrase.

    2010-04-29 - Ansgar Burchardt <ansgar@43-1.org> libparse-debian-packages-perl (0.01-2) unstable; urgency=low [ Frank Lichtenheld ] * s/debian/Debian/ in Description [ gregor herrmann ] * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); Homepage field (source stanza). Removed: XS- Vcs-Svn fields. * debian/watch: use dist-based URL. * Set Standards-Version to 3.8.0 (no changes). * Move libmodule-build-perl to Build-Depends and add "perl (>= 5.10)" as an alternative. [ Joachim Breitner ] * Removed myself from uploaders. [ Ansgar Burchardt ] * Fix error when description contains lines with colons. (Closes: #579063) + new patch: bug-579063.patch * Refresh rules for debhelper 7. * No longer install README. * Use source format 3.0 (quilt). * Convert debian/copyright to proposed machine-readable format. * debian/watch: Use extended regular expression to match upstream releases. * Bump Standards-Version to 3.8.4. * Add myself to Uploaders.

    2004-01-05 - Joachim Breitner <nomeata@debian.org> libparse-debian-packages-perl (0.01-1) unstable; urgency=low * Initial Release.

    Advertisement
    Advertisement