libpam-duo_1.9.11-1_i386.deb


Advertisement

Description

libpam-duo - PAM module for Duo Security two-factor authentication

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libpam-duo
Package version 1.9.11
Package release 1
Package architecture i386
Package type deb
Installed size 97 B
Download size 15.92 KB
Official Mirror ftp.br.debian.org
This provides the PAM module needed to interact with the Duo Security
API for handling out-of-band two-factor authentication. Also includes
manpage.

Alternatives

Package Version Architecture Repository
libpam-duo_1.9.11-1_amd64.deb 1.9.11 amd64 Debian Main
libpam-duo - - -

Requires

Name Value
libc6 >= 2.4
libduo3 = 1.9.11-1
libpam-runtime >= 1.1.1-3~
libpam0g >= 0.99.7.1
libssl1.0.0 >= 1.0.0
multiarch-support -

Download

Type URL
Binary Package libpam-duo_1.9.11-1_i386.deb
Source Package duo-unix

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpam-duo deb package:
    # sudo apt-get install libpam-duo

Files

Path
/etc/security/pam_duo.conf
/lib/i386-linux-gnu/security/pam_duo.so
/usr/share/doc/libpam-duo/README.Debian
/usr/share/doc/libpam-duo/README.gz
/usr/share/doc/libpam-duo/changelog.Debian.gz
/usr/share/doc/libpam-duo/changelog.gz
/usr/share/doc/libpam-duo/copyright
/usr/share/lintian/overrides/libpam-duo
/usr/share/man/man8/pam_duo.8.gz
/usr/share/pam-configs/duo-unix

Changelog

2014-05-29 - Kees Cook <kees@debian.org>
duo-unix (1.9.11-1) unstable; urgency=medium
* New upstream release
* control: explicitly add libssl-dev to Build-Depends (Closes: 747805).
* patches: drop patches taken upstream:
- fix-manpage-dashes.patch
- fix-test-preload.patch
- fix-configure-privsep-user.patch
2013-12-16 - Kees Cook <kees@debian.org>
duo-unix (1.9.6-1) unstable; urgency=low
* New upstream release.
* watch: updated for new upstream location.
* control, rules: enable autoreconf (Closes: 727363).
* control: bump standards version, no changes needed.
2012-06-16 - Kees Cook <kees@debian.org>
duo-unix (1.8-1) unstable; urgency=low
* New upstream release.
* debian/watch: fix uupdate typo.
* debian/pam_duo.conf: remove minuid (Closes: 670302).
* debian/control: bump standards version to 3.9.3, no changes needed.
2011-11-23 - Kees Cook <kees@debian.org>
duo-unix (1.7-3) unstable; urgency=low
* debian/copyright: fix lintian-detected format problems.
* debian/patches/fix-configure-privsep-user.patch: do not require that
privsep user exist in the build environment (Closes: 642421).
2011-09-07 - Kees Cook <kees@debian.org>
duo-unix (1.7-2) unstable; urgency=low
* debian/rules: disable testsuite; currently very broken on buildds
(Closes: 640740).
2011-09-02 - Kees Cook <kees@debian.org>
duo-unix (1.7-1) unstable; urgency=low
* New upstream release.
- drop fix-pam-destdir.patch, taken upstream.
- drop openssl-license-exception.patch, taken upstream.
* debian/watch: fix up new expected download location, add uupdate option.
* Build for multi-arch.
* debian/libpam-duo.lintian-overrides: explicitly allow mode 0600 config.
* debian/control: add python as build-dep for tests.
* debian/clean: remove .pyc files during clean-up.
* debian/patches/fix-test-preload.patch: fix testsuite to not scare /bin/sh.
2011-04-15 - Kees Cook <kees@debian.org>
duo-unix (1.5-2) unstable; urgency=low
* debian/copyright: add missed entries, thanks to Charles Plessy.
2011-04-12 - Kees Cook <kees@debian.org>
duo-unix (1.5-1) unstable; urgency=low
* Initial release (Closes: 622404).

See Also

Package Description
libpam-dynalogin_1.0.0-3+b1_i386.deb two-factor HOTP/TOTP authentication - implementation libs
libpam-encfs_0.1.4.4-7_i386.deb PAM module to automatically mount encfs filesystems on login
libpam-foreground_0.7_all.deb transitional dummy package which can be safely removed
libpam-fprintd_0.5.1-1_i386.deb PAM module for fingerprint authentication trough fprintd
libpam-geoip_1.1-1_i386.deb PAM module checking access of source IPs with a GeoIP database
libpam-gnome-keyring_3.14.0-1+b1_i386.deb PAM module to unlock the GNOME keyring upon login
libpam-google-authenticator_20130529-2_i386.deb Two-step verification
libpam-heimdal_4.6-3+b1_i386.deb PAM module for Heimdal Kerberos
libpam-krb5-migrate-heimdal_0.0.11-2_i386.deb PAM module for migrating to Kerberos
libpam-krb5_4.6-3+b1_i386.deb PAM module for MIT Kerberos
libpam-ldap_184-8.7+b1_i386.deb Pluggable Authentication Module for LDAP
libpam-ldapd_0.9.4-3+deb8u2_i386.deb PAM module for using LDAP as an authentication service
libpam-mklocaluser_0.10_all.deb Configure PAM to create a local user if it do not exist already
libpam-modules-bin_1.1.8-3.1+deb8u2+b1_i386.deb Pluggable Authentication Modules for PAM - helper binaries
libpam-modules_1.1.8-3.1+deb8u2+b1_i386.deb Pluggable Authentication Modules for PAM
Advertisement
Advertisement