libpadre-plugin-snippet-perl_0.01-2_all.deb


Advertisement

Description

libpadre-plugin-snippet-perl - Padre plugin to provide TextMate-like snippets

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libpadre-plugin-snippet-perl
Package version: 0.01
Package release: 2
Package architecture: all
Package type: deb
Installed size: 122 B
Download size: 16.11 KB
Official Mirror: ftp.br.debian.org
Once you enable this Plugin under Padre (the Perl IDE), you'll get TextMate-style TAB triggered snippets for Perl, Moose, Mouse and MooseX::Declare.

    Download

    Source package: libpadre-plugin-snippet-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libpadre-plugin-snippet-perl deb package:
      # sudo apt-get install libpadre-plugin-snippet-perl

    Files

    • /usr/share/doc/libpadre-plugin-snippet-perl/changelog.Debian.gz
    • /usr/share/doc/libpadre-plugin-snippet-perl/changelog.gz
    • /usr/share/doc/libpadre-plugin-snippet-perl/copyright
    • /usr/share/doc/libpadre-plugin-snippet-perl/examples/testcase.pl
    • /usr/share/man/man3/Padre::Plugin::Snippet.3pm.gz
    • /usr/share/man/man3/Padre::Plugin::Snippet::Document.3pm.gz
    • /usr/share/perl5/Padre/Plugin/Snippet.pm
    • /usr/share/perl5/Padre/Plugin/Snippet/Document.pm
    • /usr/share/perl5/Padre/Plugin/Snippet/Preferences.pm
    • /usr/share/perl5/Padre/Plugin/Snippet/FBP/Preferences.pm
    • /usr/share/perl5/Padre/Plugin/Snippet/Role/NeedsPluginEvent.pm
    • /usr/share/perl5/auto/share/dist/Padre-Plugin-Snippet/locale/Padre__Plugin__Moose-ar.mo
    • /usr/share/perl5/auto/share/dist/Padre-Plugin-Snippet/snippets/moose.yml
    • /usr/share/perl5/auto/share/dist/Padre-Plugin-Snippet/snippets/moosex_declare.yml
    • /usr/share/perl5/auto/share/dist/Padre-Plugin-Snippet/snippets/mouse.yml
    • /usr/share/perl5/auto/share/dist/Padre-Plugin-Snippet/snippets/perl.yml

    Changelog

    2013-09-23 - gregor herrmann <gregoa@debian.org> libpadre-plugin-snippet-perl (0.01-2) unstable; urgency=low * Team upload. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * Add build dependency on libtest-yaml-valid-perl to allow AUTOMATED_TESTING. (Closes: #724244) * debian/copyright: add year and info about third-party files. * Don't install README anymore. * Declare compliance with Debian Policy 3.9.4.

    2012-03-27 - Dominique Dumont <dod@debian.org> libpadre-plugin-snippet-perl (0.01-1) unstable; urgency=low * Initial Release. (Closes: #665811)

    Advertisement
    Advertisement