libpacklib1-gfortran_20061220+dfsg3-4.1_i386.deb


Advertisement

Description

libpacklib1-gfortran - CERNLIB data analysis suite - core library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libpacklib1-gfortran
Package version 20061220+dfsg3
Package release 4.1
Package architecture i386
Package type deb
Installed size 3.54 KB
Download size 1.24 MB
Official Mirror ftp.br.debian.org
CERNLIB is a suite of data analysis tools and libraries created for
use in physics experiments, but also with applications to other
fields such as the biological sciences.
The packlib library includes a great deal of CERNLIB core functionality.
Best-known are probably the MINUIT function minimization routines, the
HBOOK histogramming routines, and KUIP (Kit for a User Interface Package).
Other subsystems include CSPACK, a set of client-server routines; FFREAD,
a format-free input processing system for FORTRAN; and ZEBRA, a data
structure management package.
This package also includes kuesvr, the KUIP edit server program that permits
calling an editor asynchronously from within a KUIP-based program.
Please note that the graphical functionality of KUIP has been split out into
the separate libpacklib-lesstif1-gfortran package so that this package need
not depend upon the X libraries. In order to compile and link programs
against libpacklib, you must also install the libpacklib1-dev (and
maybe also the libpacklib-lesstif1-dev) package(s).

Alternatives

Package Version Architecture Repository
libpacklib1-gfortran_20061220+dfsg3-4.1_amd64.deb 20061220+dfsg3 amd64 Debian Main
libpacklib1-gfortran - - -

Requires

Name Value
libc6 >= 2.12
libgcc1 >= 1:4.1.1
libgfortran3 >= 4.6
libkernlib1-gfortran -
libquadmath0 >= 4.6
multiarch-support -

Replaces

Name Value
paw++-static <= 2005.05.09-1
paw-static <= 2005.05.09-1

Download

Type URL
Binary Package libpacklib1-gfortran_20061220+dfsg3-4.1_i386.deb
Source Package cernlib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpacklib1-gfortran deb package:
    # sudo apt-get install libpacklib1-gfortran

Files

Path
/usr/lib/i386-linux-gnu/libpacklib.so.1_gfortran
/usr/lib/i386-linux-gnu/libpacklib.so.1_gfortran.2006
/usr/lib/i386-linux-gnu/libpacklib1-gfortran/kuesvr
/usr/share/doc/libpacklib1-gfortran/NEWS.Debian.gz
/usr/share/doc/libpacklib1-gfortran/README.Debian
/usr/share/doc/libpacklib1-gfortran/changelog.Debian.gz
/usr/share/doc/libpacklib1-gfortran/copyright
/usr/share/man/man7/kuesvr.7.gz

Changelog

2014-08-28 - Aurelien Jarno <aurel32@debian.org>
cernlib (20061220+dfsg3-4.1) unstable; urgency=medium
[ Aurelien Jarno ]
* Non-maintainer upload.
[ Mauricio Faria de Oliveira ]
* Fix 'debian/control.new' for GNU make 3.82+ (Closes: #720689)
Thanks Michael Tautschnig. New versions of GNU make don't 'sort' the output
of 'wildcard' anymore. This is reported in the following GNU make announce:
https://lists.gnu.org/archive/html/info-gnu/2010-07/msg00023.html
2013-08-24 - Lifeng Sun <lifongsun@gmail.com>
cernlib (20061220+dfsg3-4) unstable; urgency=low
* cernlib-base-dev: depends on dpkg-dev to fix Multiarch support.
2013-08-23 - Lifeng Sun <lifongsun@gmail.com>
cernlib (20061220+dfsg3-3) unstable; urgency=low
* Support multiarch.
* Set source format to 3.0 (quilt).
* Temporarily disable test-suite. (Closes: #701254, #713535)
* {cernlib-base-dev,libmathlib2,pawserv}: set priority to optional.
* Apply patchset manually rather than using obsolete dpatch.
* debian/control:
- bump Standards-Version to 3.9.4.
- remove obsolete dpatch from build-dep.
- remove obsolete DM-Upload-Allowed field.
- transition from lesstif2 to motif, we will rename packages in next
upload. (Closes: #717639)
- canonical VCS-* fields.
2011-08-04 - Lifeng Sun <lifongsun@gmail.com>
cernlib (20061220+dfsg3-2) unstable; urgency=low
* Add patch 138: Remove invalid declaration of the REPEAT function.
(Closes: #636565).
* Add Danish translation of the debconf templates.
Thanks to Joe Dalton <joedalton2@yahoo.dk>. (Closes: #621357)
* debian/debhelper: rename to debian/dh to make lintian happy.
* Bump Standards-Version to 3.9.2. No change needed.

See Also

Package Description
libpacparser-dev_1.3.0-2_i386.deb library to parse proxy auto-config files (development files)
libpacparser1_1.3.0-2_i386.deb library to parse proxy auto-config files
libpadre-plugin-autoformat-perl_1.22-5_all.deb plugin to reformat your text within Padre
libpadre-plugin-datawalker-perl_0.04-2_all.deb simple Perl data structure browser Padre
libpadre-plugin-git-perl_0.12-1_all.deb simple Git interface for Padre
libpadre-plugin-moose-perl_0.21-2_all.deb Moose, Mouse and MooseX::Declare support for Padre
libpadre-plugin-parsertool-perl_0.01-1_all.deb realtime interactive parser test tool for Padre
libpadre-plugin-pdl-perl_0.05-2_all.deb PDL support for Padre IDE
libpadre-plugin-perlcritic-perl_0.12-2_all.deb Padre plugin to analyze perl files with Perl::Critic
libpadre-plugin-perltidy-perl_0.21-1_all.deb Perl::Tidy Plugin for Padre
libpadre-plugin-snippet-perl_0.01-2_all.deb Padre plugin to provide TextMate-like snippets
libpadre-plugin-spellcheck-perl_1.32-1_all.deb Padre plugin to check spelling
libpadre-plugin-svn-perl_0.05-1_all.deb simple SVN interface for Padre
libpadre-plugin-yaml-perl_0.10-1_all.deb YAML support for Padre The Perl IDE
libpadwalker-perl_1.98-1+b1_i386.deb module to inspect and manipulate lexical variables
Advertisement
Advertisement