libopkele-dev_2.0.4-8_i386.deb


Advertisement

Description

libopkele-dev - OpenID support library in C++ (development)

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libopkele-dev
Package version: 2.0.4
Package release: 8
Package architecture: i386
Package type: deb
Installed size: 612 B
Download size: 123.47 KB
Official Mirror: ftp.br.debian.org
libopkele is a C++ implementation of an OpenID decentralized identity system. It provides OpenID protocol handling, leaving authentication and user interaction to the implementor.

Alternatives

    Download

    Source package: libopkele

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libopkele-dev deb package:
      # sudo apt-get install libopkele-dev

    Files

    • /usr/include/opkele/acconfig.h
    • /usr/include/opkele/association.h
    • /usr/include/opkele/ax.h
    • /usr/include/opkele/basic_op.h
    • /usr/include/opkele/basic_rp.h
    • /usr/include/opkele/exception.h
    • /usr/include/opkele/extension.h
    • /usr/include/opkele/extension_chain.h
    • /usr/include/opkele/iterator.h
    • /usr/include/opkele/oauth_ext.h
    • /usr/include/opkele/opkele-config.h
    • /usr/include/opkele/prequeue_rp.h
    • /usr/include/opkele/sreg.h
    • /usr/include/opkele/tr1-mem.h
    • /usr/include/opkele/types.h
    • /usr/include/opkele/uris.h
    • /usr/include/opkele/util.h
    • /usr/include/opkele/verify_op.h
    • /usr/lib/i386-linux-gnu/libopkele.a
    • /usr/lib/i386-linux-gnu/libopkele.so
    • /usr/lib/i386-linux-gnu/pkgconfig/libopkele.pc
    • /usr/share/doc/libopkele-dev/NEWS.gz
    • /usr/share/doc/libopkele-dev/changelog.Debian.gz
    • /usr/share/doc/libopkele-dev/copyright

    Changelog

    2014-06-02 - NIIBE Yutaka <gniibe@fsij.org> libopkele (2.0.4-8) unstable; urgency=medium * debian/rules: Add autoreconf option. Thanks to Matthias Klose and Logan Rosen (Closes: #727428). * debian/control (Build-Depends): Remove autotools-dev. Add dh-autoreconf. * debian/patches/fix-ftbfs-gcc4.9.diff: New. Thanks to Matthias Klose (Closes: #746872).

    2014-05-27 - NIIBE Yutaka <gniibe@fsij.org> libopkele (2.0.4-7) unstable; urgency=medium * debian/config (Build-Depends): Add pkg-config (Closes: #747783). Thanks to Hideki and David Suárez.

    2013-07-08 - NIIBE Yutaka <gniibe@fsij.org> libopkele (2.0.4-6) unstable; urgency=low * Incorporate NMU (Closes: #629324). * debian/compat: Require 9. * debian/control (Build-Depends): Require debhelper >= 9. (Standards-Version): Conforms to 3.9.4. [libopkele3] (Multi-Arch, Pre-Depends): Add. * debian/{libopkele-dev.install,libopkele3.install): Multi-arch support. * debian/patches/fix-ftbfs-gcc4.7.diff: New in 2.0.4-5.3.

    2012-04-17 - Matthias Klose <doko@debian.org> libopkele (2.0.4-5.3) unstable; urgency=low * Non maintainer upload. * Fix build failure with GCC 4.7. Closes: #667253.

    2011-06-10 - Luk Claes <luk@debian.org> libopkele (2.0.4-5.2) unstable; urgency=low * Non-maintainer upload. * Don't ship symbol files (Closes: #618243). * Don't depend on a specific libstdc++.

    2011-06-05 - Luk Claes <luk@debian.org> libopkele (2.0.4-5.1) unstable; urgency=low * Non-maintainer upload. * Fix symbols for sparc64 (Closes: #617711). * Don't ship .la file (Closes: #620931). * Add missing symbols (Closes: #618243).

    2011-03-01 - NIIBE Yutaka <gniibe@fsij.org> libopkele (2.0.4-5) unstable; urgency=low * debian/libopkele3.symbols: Updated. Fix FTBFS for sparc64. * debian/rules (override_dh_auto_configure): Added to avoid linking -lssl.

    2011-02-21 - NIIBE Yutaka <gniibe@fsij.org> libopkele (2.0.4-4) unstable; urgency=low * debian/libopkele3.symbols: Updated. Fix FTBFS for alpha, amd64, ia64, kfreebsd-amd64, s390 and hppa.

    2011-02-16 - NIIBE Yutaka <gniibe@fsij.org> libopkele (2.0.4-3) unstable; urgency=low * debian/libopkele3.symbols: New.

    2011-02-15 - NIIBE Yutaka <gniibe@fsij.org> libopkele (2.0.4-2) unstable; urgency=low * debian/control (Build-Depends): Add autotools-dev and quilt. Replace libstdc++6-4.3-dev to libstdc++6-4.4-dev (Closes: #594290). Thanks to Matthias Klose. (Standards-Version): Updated to 3.9.1 * debian/compat: Updated to 7. * debian/source/format: Now use 3.0 (quilt) format.

    Advertisement
    Advertisement