libopendbx1-pgsql_1.4.6-8_i386.deb


Advertisement

Description

libopendbx1-pgsql - PostgreSQL backend for OpenDBX

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libopendbx1-pgsql
Package version 1.4.6
Package release 8
Package architecture i386
Package type deb
Installed size 42 B
Download size 5.36 KB
Official Mirror ftp.br.debian.org
OpenDBX provides a simple and lightweight API for interfacing native
relational database APIs in a consistent way. By using the OpenDBX API you
don't have to adapt your program to the different database APIs by yourself.
This package contains the PostgreSQL backend.

Alternatives

Package Version Architecture Repository
libopendbx1-pgsql_1.4.6-8_amd64.deb 1.4.6 amd64 Debian Main
libopendbx1-pgsql - - -

Requires

Name Value
libc6 >= 2.15
libopendbx1 = 1.4.6-8
libpq5 -

Provides

Name Value
libopendbx1-backend -

Download

Type URL
Binary Package libopendbx1-pgsql_1.4.6-8_i386.deb
Source Package libopendbx

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libopendbx1-pgsql deb package:
    # sudo apt-get install libopendbx1-pgsql

Files

Path
/usr/lib/opendbx/libpgsqlbackend.so
/usr/lib/opendbx/libpgsqlbackend.so.1
/usr/lib/opendbx/libpgsqlbackend.so.1.2.0
/usr/share/doc/libopendbx1-pgsql

Changelog

2014-09-05 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-8) unstable; urgency=medium
* Switch to source format 3.0 (quilt) since patches stopped being applied on
the buildds for some reason
- Update debian/rules
- Remove quilt portions of debian/README.Source
- Update build-depends
2014-09-05 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-7) unstable; urgency=medium
* Fix FTBFS due to incompatible change in doxygen 1.8.8 (Closes: #759951)
- Add symlink from lib/opendbx/api to lib/opendbx/api.dox in debian/rules
so the correct FileParser is used without having to rewrite the opendbx
makefiles to work with a new filename.
- Remove the symlink in clean
- Add debian/patches/inputname.diff to change the INPUT file name in doc/
Doxyfile.in to use api.dox and upgrade using doxygen -u
2014-06-14 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-6) unstable; urgency=medium
[ Xilin Sun ]
* Update libopenbx1.symbols to fix ftbfs with GCC-4.9 (Closes: #746868)
[ Scott Kitterman ]
* Add mips64 mips64el specific symbols changes (Closes: #746267)
2014-03-19 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-5) unstable; urgency=medium
* Confirm symbols on all archs
* Capture unforwarded change from Ubuntu to use dh-autoreconf
* Update for symbols on Debian and Ubuntu ports (alpha, arm64, ppc64,
ppc64el, and sparc64)
* Update standards version to 3.9.5 without further change
2013-07-22 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-4) unstable; urgency=low
* Switch maintainer address to alioth list (pkg-libopendbx-maintainers) now
that it is set up
* Update Vcs-* now that it's set up on alioth (Closes: #702244)
* Update debian/libopendbx1.symbols to match GCC 4.8 (Closes: #701306)
* Adjust debian/rules to use pkgkde-gensymbols for more consistent C++
symbols
2012-11-19 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-3) unstable; urgency=low
* Reorganize rules to avoid build-stamp in binary
* Update symbols files again based on logs from amd64, ia64, kfreebsd-amd64,
mips, mipsel, powerpc, s390, s390x, and sparc
* Change libopendbx1 Depends on libopendbx1-sqlite3 | libopendbx1-backend to
Recommends to break dependency loop (Closes: #693713)
* Add debian/patches/odbxtest_exit_1_on_error.diff so that test failures
will also cause the build to fail
* Fix debian/odbxtest.site path so tests run correctly
* Update clean rule to correctly remove the test database
2012-11-18 - Scott Kitterman <scott@kitterman.com>
libopendbx (1.4.6-2) unstable; urgency=low
* Upload to unstable
* Set opendbx@kitterman.com as maintainer address
* Move myself to Uploaders
* Add Marc Haber to Uploaders
* Add Vcs-* fields to debian/control
* Fix install locations for opendbx-utils test scripts
* Update symbols files from build logs on amd64, ia64, kfreebsd-amd64, mips,
powerpc, s390, s390x, and sparc
* Use modified gensymbols from pkg-kde-tools for better management of C++
symbols (added to build-depends and updated symbols file)

See Also

Package Description
libopendbx1-sqlite3_1.4.6-8_i386.deb SQLite3 backend for OpenDBX
libopendbx1-sqlite_1.4.6-8_i386.deb SQLite backend for OpenDBX
libopendbx1-sybase_1.4.6-8_i386.deb Sybase ctlib backend for OpenDBX
libopendbx1_1.4.6-8_i386.deb Lightweight database access abstraction layer
libopendkim-dev_2.9.2-2+deb8u1_i386.deb Headers and development libraries for the OpenDKIM library
libopendkim9_2.9.2-2+deb8u1_i386.deb Library for signing and verifying DomainKeys Identified Mail signatures
libopendmarc-dev_1.3.0+dfsg-1_i386.deb Headers and development libraries for the OpenDMARC library
libopendmarc2_1.3.0+dfsg-1_i386.deb Library for DMARC validation and reporting
libopenexr-dev_1.6.1-8_i386.deb development files for the OpenEXR image library
libopenexr6_1.6.1-8_i386.deb runtime files for the OpenEXR image library
libopengl-image-perl_1.03-1_all.deb Image loader for OpenGL
libopengl-perl_0.6703+dfsg-1+b1_i386.deb Perl interface providing graphics display using OpenGL
libopengl-xscreensaver-perl_0.05-1+b1_i386.deb Perl module for writing OpenGL-based XScreenSaver hacks
libopenhpi-dev_2.14.1-1.4_i386.deb OpenHPI libraries (development files)
libopenhpi2_2.14.1-1.4_i386.deb OpenHPI libraries (runtime and support files)
Advertisement
Advertisement