liboobs-1-5_3.0.0-2_i386.deb


Advertisement

Description

liboobs-1-5 - GObject based interface to system-tools-backends - shared library

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: liboobs-1-5
Package version: 3.0.0
Package release: 2
Package architecture: i386
Package type: deb
Installed size: 233 B
Download size: 73.93 KB
Official Mirror: ftp.br.debian.org
Liboobs is a lightweight library that provides a GObject based interface to system-tools-backends. It's completely abstracted of the communication and authentication details, making it easy for applications to integrate with the system details. This package contains the shared library.

Alternatives

    Download

    Source package: liboobs

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install liboobs-1-5 deb package:
      # sudo apt-get install liboobs-1-5

    Files

    • /usr/lib/liboobs-1.so.5
    • /usr/lib/liboobs-1.so.5.0.1
    • /usr/share/doc/liboobs-1-5/AUTHORS
    • /usr/share/doc/liboobs-1-5/NEWS.gz
    • /usr/share/doc/liboobs-1-5/README
    • /usr/share/doc/liboobs-1-5/changelog.Debian.gz
    • /usr/share/doc/liboobs-1-5/changelog.gz
    • /usr/share/doc/liboobs-1-5/copyright

    Changelog

    2014-10-10 - Andriy Grytsenko <andrej@rep.kiev.ua> liboobs (3.0.0-2) unstable; urgency=low * New maintainer (Closes: #764265). [ Josselin Mouette ] * Update repository URL. [ jbicha-guest ] * use canonical Vcs-* fields [ Vlad Orlov ] * 01-return-error-code.patch: new patch. Correctly return error code on unknown dbus errors. * 02-proper-warning.patch: new patch. Emit the "unknown error" warning only when dbus error is really unknown (Closes: #761964). [ Andriy Grytsenko ] * debian/control: - Bump Standards-Version to 3.9.6 (Fix lintian warning). - Remove Vcs-* fields due to package adoption, new ones will be added later. - Add Homepage: link (Fix lintian wishlist message). - Fix dependency version on system-tools-backends to (>= 2.10.1). * debian/rules: - Add --disable-silent-rules into confugure options (Fix buildd warning dpkg-buildflags-missing). * debian/copyright: - Change to a machine-readable format (for lintian) and fix errors.

    2011-10-22 - Michael Biebl <biebl@debian.org> liboobs (3.0.0-1) unstable; urgency=low * New upstream release. * debian/control.in: - Add Vcs-* fields. - Bump Build-Depends on system-tools-backends-dev to (>= 2.10.1). * debian/patches/01-gtk-doc-scanner-libs.patch: - Removed, merged upstream. * debian/patches/02-pkg-config-requires-dbus.patch: - Removed, merged upstream. * Update library package names for the SONAME bump 4 → 5. * Bump shlibs version to (>= 3.0.0).

    2011-07-31 - Michael Biebl <biebl@debian.org> liboobs (2.30.1-2) unstable; urgency=low * debian/rules: Remove simple-patchsys.mk include. * 01-gtk-doc-scanner-libs.patch: Link gtk-doc scanner against all necessary libraries. Closes: #604795 * Use dh-autoreconf to update the build system. Closes: #558521 * Bump debhelper compatibility level to 8. - Update Build-Depends on debhelper. - Strip debian/tmp/ from .install files. * Bump Standards-Version to 3.9.2. No further changes. * 02-pkg-config-requires-dbus.patch: Add missing dbus-1 dependency to the pkg-config file. Closes: #629891 * debian/watch: Track .bz2 tarballs.

    2010-05-31 - Sebastian Dröge <slomo@debian.org> liboobs (2.30.1-1) unstable; urgency=low * New upstream bugfix release

    2010-04-13 - Josselin Mouette <joss@debian.org> liboobs (2.30.0-2) unstable; urgency=low * Disable HAL support, it’s not used at all in the code. * Add Breaks for g-s-t < 2.30 since the ABI changed without bumping SONAME. Please give me a cluebat.

    2010-04-09 - Luca Bruno <lethalman88@gmail.com> liboobs (2.30.0-1) unstable; urgency=low * New upstream release. * debian/control.in: - Bump Standards-Version to 3.8.4, no changes needed. - Bump system-tools-backends-dev build-depend and system-tools-backends depend to 2.9.2. * debian/rules: - Add --with-hal to configure options, now disabled by default upstream. - Add shlibs dependency for liboobs-1-4 >= 2.30.0 due to API changes. * debian/copyright: - Add new copyright notice. * Switch to source format 3.0 (quilt). - Add debian/source/format. - Remove /usr/share/cdbs/1/rules/simple-patchsys.mk include.

    2009-10-13 - Luca Falavigna <dktrkranz@debian.org> liboobs (2.22.2-1) unstable; urgency=low * New upstream release. * debian/control.in: - Bump gtk-doc-tools build-depends to >= 1.9. - Bump Standards-Version to 3.8.3, no changes needed. * debian/rules: - Build with --enable-gtk-docs.

    2009-08-17 - Josselin Mouette <joss@debian.org> liboobs (2.22.1-1) unstable; urgency=low [ Josselin Mouette ] * Build-depend on libglib2.0-doc to ensure proper xrefs. [ Emilio Pozuelo Monfort ] * New upstream release. * debian/patches/01_smb_crash.patch: removed, fixed upstream. * Let every package depend on ${misc:Depends}. * liboobs-1-4-dbg is section debug. * Inherit the section from the source stanza where it's the same. * Standards-Version is 3.8.2, no changes needed.

    Advertisement
    Advertisement