libobject-pluggable-perl_1.29-1_all.deb


Advertisement

Description

libobject-pluggable-perl - base class for creating plugin enabled objects

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libobject-pluggable-perl
Package version 1.29
Package release 1
Package architecture all
Package type deb
Installed size 80 B
Download size 27.86 KB
Official Mirror ftp.br.debian.org
Object::Pluggable is a base class for creating plugin enabled objects.
It is a generic port of POE::Component::IRC's plugin system. If your
component dispatches events to listeners, then Object::Pluggable may
be a good fit for you.

Alternatives

Package Version Architecture Repository
libobject-pluggable-perl_1.29-1_all.deb 1.29 all Debian Main
libobject-pluggable-perl - - -

Requires

Name Value
libtask-weaken-perl -
perl -

Download

Type URL
Binary Package libobject-pluggable-perl_1.29-1_all.deb
Source Package libobject-pluggable-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libobject-pluggable-perl deb package:
    # sudo apt-get install libobject-pluggable-perl

Files

Path
/usr/share/doc/libobject-pluggable-perl/changelog.Debian.gz
/usr/share/doc/libobject-pluggable-perl/changelog.gz
/usr/share/doc/libobject-pluggable-perl/copyright
/usr/share/doc/libobject-pluggable-perl/examples/synopsis.pl.gz
/usr/share/man/man3/Object::Pluggable.3pm.gz
/usr/share/man/man3/Object::Pluggable::Constants.3pm.gz
/usr/share/man/man3/Object::Pluggable::Pipeline.3pm.gz
/usr/share/perl5/Object/Pluggable.pm
/usr/share/perl5/Object/Pluggable/Constants.pm
/usr/share/perl5/Object/Pluggable/Pipeline.pm

Changelog

2010-10-21 - Ansgar Burchardt <ansgar@debian.org>
libobject-pluggable-perl (1.29-1) unstable; urgency=low
* New upstream release. Renamed to Object::Pluggable upstream.
* Rename Debian package to libobject-pluggable-perl.
* No longer (build-)depends on libpoe-perl.
* Build-dep on perl >= 5.10.1 for Pod::Parser 1.36.
* debian/copyright: Remove information on inc/*; refer to "Debian systems"
instead of "Debian GNU/Linux systems"; refer to
/usr/share/common-licenses/GPL-1.
* Bump Standards-Version to 3.9.1.
* Add myself to Uploaders.
2010-06-28 - gregor herrmann <gregoa@debian.org>
libpoe-component-pluggable-perl (1.26-1) unstable; urgency=low
[ Ryan Niebur ]
* Update jawnsy's email address
* Update ryan52's email address
[ gregor herrmann ]
* New upstream release.
* Convert to source format 3.0 (quilt).
* debian/copyright: update formatting and copyright info (upstream +
packaging).
* Set Standards-Version to 3.9.0 (no changes).
* Add /me to Uploaders.
2009-08-21 - Jonathan Yu <frequency@cpan.org>
libpoe-component-pluggable-perl (1.24-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
+ Fix memory leaks (RT#48788)
* Standards-Version 3.8.3 (no changes)
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
2009-07-26 - Jonathan Yu <frequency@cpan.org>
libpoe-component-pluggable-perl (1.22-1) unstable; urgency=low
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Jonathan Yu ]
* New upstream release
* Updated copyright
+ Upstream copyright years now 2009
+ Updated the Module::Install copyright info
* Use new shorter rules format
* Standards-Version 3.8.2 (no changes)
* Updated control file description
* Depend on perl (>= 5.6.0-16), per Perl Policy
2009-04-29 - Ryan Niebur <ryanryan52@gmail.com>
libpoe-component-pluggable-perl (1.20-1) unstable; urgency=low
* New upstream release
* update dependencies
2009-04-11 - Ryan Niebur <ryanryan52@gmail.com>
libpoe-component-pluggable-perl (1.18-1) unstable; urgency=low
[ Ryan Niebur ]
* New upstream release
* Debian Policy 3.8.1
[ gregor herrmann ]
* Bump versioned (build) dependency on libpoe-perl as per new upstream
requirements.
2009-03-05 - Ryan Niebur <ryanryan52@gmail.com>
libpoe-component-pluggable-perl (1.16-1) unstable; urgency=low
* New upstream release
* add myself to uploaders
2009-01-26 - Rene Mayorga <rmayorga@debian.org>
libpoe-component-pluggable-perl (1.14-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
[ Rene Mayorga ]
* New upstream release
* debian/control
+ set debhelper version to 7
+ add myself to uploaders
* debian/rules, debian/compat; updated to dh7 using dh-make-perl
* debian/copyright:
+ update proposal format
+ add individual copyright stanza for debian/* based
on debian/changelog
+ mention 3 more people holding copyright on *, according to upstream
+ add copyright stanza for inc/*
2008-07-02 - Martín Ferrari <tincho@debian.org>
libpoe-component-pluggable-perl (1.10-1) unstable; urgency=low
* New upstream release.
2008-06-12 - Martín Ferrari <tincho@debian.org>
libpoe-component-pluggable-perl (1.06-2) unstable; urgency=low
* Re-uploading due to a few errors in debian/control.

See Also

Package Description
libobject-realize-later-perl_0.19-1_all.deb Perl module providing delayed creation of objects
libobject-remote-perl_0.003004-1_all.deb Call methods on objects in other processes or on other hosts
libobject-signature-perl_1.07-1_all.deb module perl for generate cryptographic signatures for objects
libobject-tiny-perl_1.06-1_all.deb module for building classes, simply
libobjenesis-java-doc_1.2+full-3_all.deb Documentation for Objenesis
libobjenesis-java_1.2+full-3_all.deb Java library to instantiate a new object of a particular class
libobrender29_3.5.2-8+deb8u1_i386.deb rendering library for openbox themes
libobt2_3.5.2-8+deb8u1_i386.deb parsing library for openbox
libobus-ocaml-bin_1.1.5-3+b2_i386.deb pure OCaml implementation of D-Bus (command-line tools)
libobus-ocaml-dev_1.1.5-3+b2_i386.deb pure OCaml implementation of D-Bus (development files)
libobus-ocaml_1.1.5-3+b2_i386.deb pure OCaml implementation of D-Bus (runtime)
libocamlbricks-ocaml-dev_0.90+bzr400-1_i386.deb Miscellaneous utility functions in OCaml for Marionnet
libocamlgraph-ocaml-dev_1.8.5-1_i386.deb graph library for OCaml
libocamlgraph-ocaml-doc_1.8.5-1_all.deb documentation for the OCamlgraph library
libocamlgraph-viewer-ocaml-dev_1.8.5-1_i386.deb graph library for OCaml
Advertisement
Advertisement