liboauth-dev_1.0.1-1_i386.deb


Advertisement

Description

liboauth-dev - C library for implementing OAuth 1.0 (development files)

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: liboauth-dev
Package version: 1.0.1
Package release: 1
Package architecture: i386
Package type: deb
Installed size: 78 B
Download size: 36.20 KB
Official Mirror: ftp.br.debian.org
liboauth is a collection of C functions implementing the OAuth Core 1.0 standard API. liboauth provides basic functions to escape and encode parameters according to OAuth specs and offers high-level functions to sign requests or verify signatures. This package contains the development files.

Alternatives

    Download

    Source package: liboauth

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install liboauth-dev deb package:
      # sudo apt-get install liboauth-dev

    Files

    • /usr/include/oauth.h
    • /usr/lib/i386-linux-gnu/liboauth.a
    • /usr/lib/i386-linux-gnu/liboauth.so
    • /usr/lib/i386-linux-gnu/pkgconfig/oauth.pc
    • /usr/share/doc/liboauth-dev/changelog.Debian.gz
    • /usr/share/doc/liboauth-dev/changelog.gz
    • /usr/share/doc/liboauth-dev/copyright
    • /usr/share/doc/liboauth-dev/examples/oauthexample.c.gz
    • /usr/share/doc/liboauth-dev/examples/oauthtest.c.gz
    • /usr/share/man/man3/oauth.3.gz

    Changelog

    2013-06-19 - Bilal Akhtar <bilalakhtar@ubuntu.com> liboauth (1.0.1-1) unstable; urgency=low * New upstream release. * Update Standards-Version to 3.9.4 (No changes needed) * Build with dh_autoreconf (Closes: #700686) - Thanks Daniel Schepler <dschepler@gmail.com> for the patch! - debian/patches/01_ltmain_as-needed.patch is obsolete now, dropped. * debian/control: - Add dh-autoreconf build-dep. - Bump debhelper versioned build-dep to 9 to match compat. - Properly truncate sentence at end of package description for English language compliance. - Update Git URLs * debian/patches/01_fix_manpage_spelling_errors.patch: Fix manpage spelling errors to satisfy lintian.

    2012-09-21 - gregor herrmann <gregoa@debian.org> liboauth (0.9.4-3.1) unstable; urgency=low * Non-maintainer upload. * Fix "please make loose libcurl dependency": change liboauth-dev's Depends to "libcurl4-gnutls-dev | libcurl4-dev, libnss3-dev" (instead of "libcurl4-nss-dev") (Closes: #639565) * Fix "liboauth0: doesn't work with NSS libcurl flavour": build-depend on "libcurl4-gnutls-dev | libcurl4-dev" (instead of "libcurl4-nss-dev") (Closes: #650138) * Thanks to HAMANO Tsukasa and Alessandro Ghedini for accompanying me through this maze, and to Satoru KURASHIKI for additional tests.

    2011-11-05 - Sjoerd Simons <sjoerd@debian.org> liboauth (0.9.4-3) unstable; urgency=low * Sync from Ubuntu: [ Mathieu Trudel-Lapierre ] * debian/control: liboauth-dev really needs libcurl4-nss-dev, not libcurl4-gnutls-dev (nss is required in the .pc file) (closes: #646485, #639565) [ Sjoerd Simons ] * collab-main team update * debian/control: Swith build-depend to libcurl4-nss-dev from libcurl4-gnutls-dev. oauth itself uses nss for SSL

    2011-08-10 - Bilal Akhtar <bilalakhtar@ubuntu.com> liboauth (0.9.4-2) unstable; urgency=low * Make package multiarch-aware. - Bump compat to 9. * debian/control: - Add libcurl4-gnutls-dev to liboauth-dev dependencies, thanks Mathieu! - Bump Standards-Version to 3.9.2 (no changes needed). * debian/patches/02_xmalloc_dont_exit.patch: Return NULL in case malloc fails.

    2011-02-07 - Bilal Akhtar <bilalakhtar@ubuntu.com> liboauth (0.9.4-1) unstable; urgency=low * New upstream release. * Upload to unstable. * debian/copyright: Re-write in DEP-5 format.

    2011-01-25 - Bilal Akhtar <bilalakhtar@ubuntu.com> liboauth (0.9.3-1) experimental; urgency=low * New upstream release. * debian/rules: - Remove the unnecessary change made to the LDFLAGS env var. * debian/watch: Change URL to that of the SF file hosting system which is now being used by upstream.

    2011-01-14 - Bilal Akhtar <bilalakhtar@ubuntu.com> liboauth (0.9.1-2) experimental; urgency=low * debian/control: - Add Vcs-Git and Vcs-Browser fields. * debian/rules: - Install upstream changelog. * debian/patches/02_xmalloc_dont_exit.patch: Don't exit in case of a failure of memory allocation. This fixes a lintian X: tag, and doesn't cause any breakage. * debian/liboauth0.symbols: Add symbols control file. (Closes: #609963) * Run wrap-and-sort.

    2010-10-21 - Bilal Akhtar <bilalakhtar@ubuntu.com> liboauth (0.9.1-1) unstable; urgency=low * Initial Release (Closes: #581601)

    Advertisement
    Advertisement