libnfsidmap-dev_0.25-5_i386.deb


Advertisement

Description

libnfsidmap-dev - header files and docs for libnfsidmap

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libnfsidmap-dev
Package version: 0.25
Package release: 5
Package architecture: i386
Package type: deb
Installed size: 85 B
Download size: 24.65 KB
Official Mirror: ftp.br.debian.org
Contains the header files and documentation for libnfsidmap for use in developing applications that use the libnfsidmap library. libnfsidmap provides functions to map between NFSv4 names (which are of the form user@domain) and local uid's and gid's.

Alternatives

    Download

    Source package: libnfsidmap

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libnfsidmap-dev deb package:
      # sudo apt-get install libnfsidmap-dev

    Files

    • /usr/include/nfsidmap.h
    • /usr/lib/i386-linux-gnu/libnfsidmap.a
    • /usr/lib/i386-linux-gnu/libnfsidmap.so
    • /usr/lib/i386-linux-gnu/pkgconfig/libnfsidmap.pc
    • /usr/share/doc/libnfsidmap-dev/NEWS.gz
    • /usr/share/doc/libnfsidmap-dev/README.gz
    • /usr/share/doc/libnfsidmap-dev/changelog.Debian.gz
    • /usr/share/doc/libnfsidmap-dev/changelog.gz
    • /usr/share/doc/libnfsidmap-dev/copyright

    Changelog

    2013-05-25 - Anibal Monsalve Salazar <anibal@debian.org> libnfsidmap (0.25-5) unstable; urgency=low * Standards Version is 3.9.4 * Fix various warnings in idmapd.conf.5 Add 02-idmapd.conf.5.patch [ Colin Watson ] * Replace incorrect Conflicts on nfs-common with Breaks/Replaces. Closes: #654714

    2012-06-09 - Anibal Monsalve Salazar <anibal@debian.org> libnfsidmap (0.25-4) unstable; urgency=low * Set pluginpath to /lib/$(DEB_HOST_MULTIARCH)/libnfsidmap Closes: #676719

    2012-06-08 - Anibal Monsalve Salazar <anibal@debian.org> libnfsidmap (0.25-3) unstable; urgency=low * Add multiarch support * Use hardening options * DH compatibility level is 9 * Fix wrong-section-according-to-package-name

    2012-02-27 - Anibal Monsalve Salazar <anibal@debian.org> libnfsidmap (0.25-2) unstable; urgency=low * Conflicts with nfs-common (= 1:1.1.2-6lenny2) Closes: 654714 * Build-depends on autoconf (>= 2.68) Closes: 660914 * Fix "umich_ldap.so is an empty module" Add 01-661215-wrong-double-ldap-check.patch Patch by Steve Langasek Closes: 661215 LP: #939232

    2011-12-07 - Anibal Monsalve Salazar <anibal@debian.org> libnfsidmap (0.25-1) unstable; urgency=low * New upstream version 0.25 Changes since libnfsidmap-0.24 nss_getpwnam: ignore case when comparing domain names rpc.idmapd fails to load plugings Cleaned up some warnings Ignoring more git files Improve debugging during lib initialization Added new --with-pluginpath configuration flag Delete 02-add--with-pluginpath-configuration-flag.patch 03-improve-debugging-during-lib-initialization.patch 04-clean-up-some-warnings.patch 05-dont-fail-to-load-plugings.patch 06-ignore-case-when-comparing-domain-names.patch

    2011-12-06 - Anibal Monsalve Salazar <anibal@debian.org> libnfsidmap (0.24-4) unstable; urgency=low * Add --with-pluginpath configuration flag Add 02-add--with-pluginpath-configuration-flag.patch * Improve debugging during lib initialization Add 03-improve-debugging-during-lib-initialization.patch * Clean up some warnings Add 04-clean-up-some-warnings.patch * Don't fail to load plugings Add 05-dont-fail-to-load-plugings.patch * Ignore case when comparing domain names Add 06-ignore-case-when-comparing-domain-names.patch * Set configure flag --with-pluginpath to /lib/libnfsidmap Delete 01-649491-move-library.patch

    2011-12-05 - Anibal Monsalve Salazar <anibal@debian.org> libnfsidmap (0.24-3) unstable; urgency=low * Point PATH_PLUGINS to /lib/libnfsidmap Add 01-649491-move-library.patch Closes: 650904, 650948

    2011-12-03 - Anibal Monsalve Salazar <anibal@debian.org> libnfsidmap (0.24-2) unstable; urgency=low * Move .so files from /usr/lib to /lib Closes: 649491 * Ship manpage idmapd.conf.5 Closes: 585083, 594933, 619996, 625826 * Standars-Version is 3.9.2 * Fix debian-rules-missing-recommended-target * Fix description-synopsis-starts-with-article

    2011-03-09 - Anibal Monsalve Salazar <anibal@debian.org> libnfsidmap (0.24-1) unstable; urgency=low * New upstream release * Debian source format is 3.0 (quilt) * Fix debhelper-but-no-misc-depends * Fix out-of-date-standards-version

    2009-12-19 - Anibal Monsalve Salazar <anibal@debian.org> libnfsidmap (0.23-2) unstable; urgency=low * Ship /usr/lib/libnfsidmap/{nsswitch,umich_ldap,static}.so Closes: 561617, 561656

    Advertisement
    Advertisement