libnews-article-perl_1.27-8_all.deb


Advertisement

Description

libnews-article-perl - Perl modules for manipulating Usenet articles

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libnews-article-perl
Package version: 1.27
Package release: 8
Package architecture: all
Package type: deb
Installed size: 114 B
Download size: 33.46 KB
Official Mirror: ftp.br.debian.org
Provides Perl modules for manipulating Usenet articles and/or mail messages, including modifying headers, signing articles with either the PGPMoose or pgpverify algorithms, posting and mailing articles, and instantiating them from templates. It was primarily written for use by gateways and/or moderation programs.

Alternatives

    Download

    Source package: libnews-article-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libnews-article-perl deb package:
      # sudo apt-get install libnews-article-perl

    Files

    • /usr/share/doc/libnews-article-perl/changelog.Debian.gz
    • /usr/share/doc/libnews-article-perl/copyright
    • /usr/share/man/man3/News::Article.3pm.gz
    • /usr/share/man/man3/News::AutoReply.3pm.gz
    • /usr/share/man/man3/News::FormArticle.3pm.gz
    • /usr/share/man/man3/News::FormReply.3pm.gz
    • /usr/share/perl5/News/Article.pm
    • /usr/share/perl5/News/AutoReply.pm
    • /usr/share/perl5/News/FormArticle.pm
    • /usr/share/perl5/News/FormReply.pm

    Changelog

    2013-09-14 - Russ Allbery <rra@debian.org> libnews-article-perl (1.27-8) unstable; urgency=low * Avoid calling defined on an array in News::FormArticle. This now produces a warning with Perl 5.18. * Move single-debian-patch and patch-header to local-options. Continue to generate a single Debian patch for maintainer changes, but do this via local options not included in the source package so that NMUs and other changes get versioned patches. * Suggest default-mta instead of a specific exim4 package default-mta is now the preferred virtual package to use as the first dependency to indicate whatever the current default MTA in Debian is. * Merge Build-Depends and Build-Depends-Indep. This distinction is not meaningful when only architecture-independent binary packages are built. * Use xz compression for the debian.tar file. * Update debhelper compatibility level to V9. * Update to standards version 3.9.4. - Rewrite debian/changelog in copyright-format 1.0.

    2010-04-02 - Russ Allbery <rra@debian.org> libnews-article-perl (1.27-7) unstable; urgency=low * Add missing =back commands in POD documentation. * Drop dependency on libnet-perl. This has been part of Perl core for forever and doesn't exist even in oldstable. * Drop version from versioned build-dependency on perl since the version was older than oldstable. * Update debhelper compatibility level to V7. - Use debhelper rule minimization. * Add Vcs-Git and Vcs-Browser control fields. * Switch to 3.0 (quilt) source format. * Update standards version to 3.8.4.

    2007-12-29 - Russ Allbery <rra@debian.org> libnews-article-perl (1.27-6) unstable; urgency=low * Tell Makefile.PL not to create /usr/lib/perl5 and remove the rmdir, which fails with Perl 5.10. * Suggest an MTA for article mailing support. * Use the recommended watch format and search.cpan.org in copyright. * Change Homepage to search.cpan.org and move it to a real header. * Update standards version to 3.7.3 (no changes required).

    2007-04-28 - Russ Allbery <rra@debian.org> libnews-article-perl (1.27-5) unstable; urgency=low * Move debhelper to Build-Depends since it's required for the clean target. * Update copyright and watch file to point to CPAN since the original upstream source page appears to be gone. * Use a better method of optionally running make distclean. * Add build-arch and build-indep targets, just in case. * Update standards version to 3.7.2 (no changes required). * Update debhelper compatibility level to V5.

    2005-12-03 - Russ Allbery <rra@debian.org> libnews-article-perl (1.27-4) unstable; urgency=low * Providing binary-arch in debian/rules is required by Policy even if there are no arch-dependent packages. Whoops.

    2005-11-16 - Russ Allbery <rra@debian.org> libnews-article-perl (1.27-3) unstable; urgency=low * Simplify debian/rules. * Update copyright to my current format and add an explicit packaging copyright and license statement. * Update standards version to 3.6.2 (no changes required). * Update maintainer address.

    2005-06-10 - Russ Allbery <rra@stanford.edu> libnews-article-perl (1.27-2) unstable; urgency=low * Uploaded to Debian. (Closes: #308431) * Add a watch file. * Use the recommend format for the Homepage link in the description.

    2004-08-04 - Russ Allbery <rra@stanford.edu> libnews-article-perl (1.27-1) unstable; urgency=low * Initial release.

    Advertisement
    Advertisement