libnet-subnets-perl_1.0-1_all.deb


Advertisement

Description

libnet-subnets-perl - module for IPv4 subnet calculations

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libnet-subnets-perl
Package version: 1.0
Package release: 1
Package architecture: all
Package type: deb
Installed size: 80 B
Download size: 11.00 KB
Official Mirror: ftp.br.debian.org
Net::Subnets is a Perl module that provides a quick and simple method to perform miscellaneous operations with IP version 4 (IPv4) addresses. It can match a list of IP addresses against one or more CIDR (Classless Inter-Domain Routing) subnets. It also calculates ranges of IP addresses based on a subnet size, specified as a CIDR.

Alternatives

Requires

    Download

    Source package: libnet-subnets-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libnet-subnets-perl deb package:
      # sudo apt-get install libnet-subnets-perl

    Files

    • /usr/share/doc/libnet-subnets-perl/changelog.Debian.gz
    • /usr/share/doc/libnet-subnets-perl/changelog.gz
    • /usr/share/doc/libnet-subnets-perl/copyright
    • /usr/share/doc/libnet-subnets-perl/examples/matching.pl
    • /usr/share/man/man3/Net::Subnets.3pm.gz
    • /usr/share/perl5/Net/Subnets.pm

    Changelog

    2009-12-18 - Jonathan Yu <jawnsy@cpan.org> libnet-subnets-perl (1.0-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Add myself to Uploaders and Copyright * Standards-Version 3.8.3 (drop perl version dep) * Rewrote control description * Install examples now provided upstream * Refresh copyright file; notably, the copyright says only Sebastian Riedel, not the other author * Use new short debhelper rules format [ gregor herrmann ] * debian/watch: use dist-based URL. * debian/control: Changed: Switched Vcs-Browser field to ViewSVN (source stanza). [ Nathan Handler ] * debian/watch: Update to ignore development releases.

    2008-01-14 - Ernesto Hernández-Novich (USB) <emhn@usb.ve> libnet-subnets-perl (0.21-3) unstable; urgency=low [ Stephen Gran ] * Lowered debhelper compatibility level to 5 (Be kind to backporters day) [ Gunnar Wolf ] * Fixed homepage in debian/control (was refering to a specific version) [ gregor herrmann ] * debian/rules: delete /usr/lib/perl5 only if it exists (Closes: #467871). * debian/control: Changed: Maintainer set to Debian Perl Group <pkg- perl-maintainers@lists.alioth.debian.org> (was: Debian Perl Project <pkg-perl-maintainers@lists.alioth.debian.org>). [ Ernesto Hernández-Novich (USB) ] * Upgraded to debhelper 6

    2007-12-23 - Gunnar Wolf <gwolf@debian.org> libnet-subnets-perl (0.21-2) unstable; urgency=low [ Ernesto Hernández-Novich (USB) ] * Moved package into Pkg Perl Project SVN. * Update Standards Version. * Cleanup debian/rules. * Fixed watch file. * Fixed copyright and control file with a better URL. * Fixed Maintainer field in control file. [ Gunnar Wolf ] * Translated debian/copyright into UTF-8 * Bumped up standards-version to 3.7.3 (no changes needed)

    2006-09-06 - Ernesto Hernández-Novich <emhn@telcel.net.ve> libnet-subnets-perl (0.21-1) unstable; urgency=low * Initial Release.

    Advertisement
    Advertisement