libmpfr4_3.1.2-2_i386.deb


Advertisement

Description

libmpfr4 - multiple precision floating-point computation

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libmpfr4
Package version 3.1.2
Package release 2
Package architecture i386
Package type deb
Installed size 780 B
Download size 517.02 KB
Official Mirror ftp.br.debian.org
MPFR provides a library for multiple-precision floating-point computation
with correct rounding.  The computation is both efficient and has a
well-defined semantics. It copies the good ideas from the
ANSI/IEEE-754 standard for double-precision floating-point arithmetic
(53-bit mantissa).

Alternatives

Package Version Architecture Repository
libmpfr4_3.1.2-2_amd64.deb 3.1.2 amd64 Debian Main
libmpfr4 - - -

Requires

Name Value
libc6 >= 2.4
libgmp10 -
multiarch-support -

Conflicts

Name Value
libgmp3 << 4.1.4-3

Download

Type URL
Binary Package libmpfr4_3.1.2-2_i386.deb
Source Package mpfr4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmpfr4 deb package:
    # sudo apt-get install libmpfr4

Files

Path
/usr/lib/i386-linux-gnu/libmpfr.so.4
/usr/lib/i386-linux-gnu/libmpfr.so.4.1.2
/usr/share/doc/libmpfr4/AUTHORS
/usr/share/doc/libmpfr4/BUGS
/usr/share/doc/libmpfr4/NEWS.gz
/usr/share/doc/libmpfr4/README
/usr/share/doc/libmpfr4/README.Debian
/usr/share/doc/libmpfr4/TODO.gz
/usr/share/doc/libmpfr4/changelog.Debian.gz
/usr/share/doc/libmpfr4/changelog.gz
/usr/share/doc/libmpfr4/copyright

Changelog

2014-12-11 - Matthias Klose <doko@debian.org>
mpfr4 (3.1.2-2) unstable; urgency=medium
* QA upload, properly orphan the package. See #771884.
* Bump standards version to 3.9.6, fix lintian warnings.
* Build using dpkg-buildflags.
* Fix buffer overflow in mpfr_strtofr. Closes: #772008.
2013-10-20 - Laurent Fousse <lfousse@debian.org>
mpfr4 (3.1.2-1) unstable; urgency=low
* New upstream release.
* Apply upstream's patches 01 through 03 (closes: #726268).
* Use -O1 for sh4 (closes: #726602).
2013-08-18 - Steve M. Robbins <smr@debian.org>
mpfr4 (3.1.1-2) unstable; urgency=low
* Remove lib32mpfr{4,-dev} packages.  Closes: #718094.
2013-02-18 - Laurent Fousse <lfousse@debian.org>
mpfr4 (3.1.1-1) unstable; urgency=low
* New upstream release.
* Use dh-autoreconf, as suggested by Colin Watson (closes: #700065).
2012-05-08 - Laurent Fousse <lfousse@debian.org>
mpfr4 (3.1.0-5) unstable; urgency=low
* Apply upstream patch 04 through 10, fixing various
miscomputation, freezes, and compatibility issues with
newer GMP version.
2012-03-03 - Laurent Fousse <lfousse@debian.org>
mpfr4 (3.1.0-4) unstable; urgency=low
* Re-enable TLS on sparc now that we have binutils >= 2.22
(closes: #645587).
2011-11-09 - Laurent Fousse <lfousse@debian.org>
mpfr4 (3.1.0-3) unstable; urgency=low
* Apply upstream patch01, fixing bug in MPFR_UNLIKELY.
* Apply upstream patch03, fixing bug in the mpfr_*printf functions
(closes: #648213).
2011-10-08 - Laurent Fousse <lfousse@debian.org>
mpfr4 (3.1.0-2) unstable; urgency=low
* Disable TLS support on sparc (closes: #644552).
This is an ugly workaround for what is quite likely a compiler
optimization bug.
2011-10-03 - Laurent Fousse <lfousse@debian.org>
mpfr4 (3.1.0-1) unstable; urgency=low
* New upstream release.
2011-09-22 - Laurent Fousse <lfousse@debian.org>
mpfr4 (3.1.0~rc2-1) experimental; urgency=low
* New upstream release candidate.

See Also

Package Description
libmpfrc++-dev_3.6.1+ds-1_all.deb C++ wrapper for the GNU MPFR C library
libmpg123-0_1.20.1-2+deb8u1_i386.deb MPEG layer 1/2/3 audio decoder (shared library)
libmpg123-dev_1.20.1-2+deb8u1_i386.deb MPEG layer 1/2/3 audio decoder (development files)
libmpich-dev_3.1-5+b2_i386.deb Development files for MPICH
libmpich12_3.1-5+b2_i386.deb Shared libraries for MPICH
libmpich2-dev_3.1-5+b2_i386.deb Transitional dummy package for MPICH development files
libmpikmeans-dev_1.5+dfsg-3_i386.deb Development libraries and header files for MPIKmeans
libmpikmeans1_1.5+dfsg-3_i386.deb Fast Library for k-means Clustering
libmpj-java_0.42+dfsg-1_all.deb Java library for parallel applications for multicore processors and clusters
libmpl-dev_3.1-5+b2_i386.deb Development files for mpl part of MPICH
libmpl1_3.1-5+b2_i386.deb Shared libraries for mpl part of MPICH
libmplex2-2.1-0_2.1.0+debian-3_i386.deb MJPEG capture/editing/replay and MPEG encoding toolset (library)
libmpv-dev_0.6.2-2_i386.deb video player based on MPlayer/mplayer2 (client library dev files)
libmpv1_0.6.2-2_i386.deb video player based on MPlayer/mplayer2 (client library)
libmqdb-perl_0.954-1_all.deb MappedQueryDB toolkit for federated databases
Advertisement
Advertisement