libmowgli-2-dev_2.0.0-3_i386.deb


Advertisement

Description

libmowgli-2-dev - high performance development framework for C (development)

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libmowgli-2-dev
Package version 2.0.0
Package release 3
Package architecture i386
Package type deb
Installed size 362 B
Download size 37.36 KB
Official Mirror ftp.br.debian.org
Mowgli is a development framework for C (like GLib), which provides high
performance and highly flexible algorithms. It can be used as a supplement
to GLib (to add additional functions (dictionaries, hashes), or replace some
of the slow GLib list manipulation functions), or stand alone. It also
provides a powerful hook system and convenient logging for your code, as well
as high performance block allocator.
This package contains files needed for development with this library and code
examples.

Alternatives

Package Version Architecture Repository
libmowgli-2-dev_2.0.0-3_amd64.deb 2.0.0 amd64 Debian Main
libmowgli-2-dev_2.0.0-dmo1+deb8u1_i386.deb 2.0.0 i386 Multimedia Main
libmowgli-2-dev_2.0.0-dmo1+deb8u1_amd64.deb 2.0.0 amd64 Multimedia Main
libmowgli-2-dev - - -

Requires

Name Value
libmowgli-2-0 = 2.0.0-3
pkg-config -
pkgconf -

Download

Type URL
Binary Package libmowgli-2-dev_2.0.0-3_i386.deb
Source Package libmowgli-2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmowgli-2-dev deb package:
    # sudo apt-get install libmowgli-2-dev

Files

Path
/usr/include/libmowgli-2/mowgli.h
/usr/include/libmowgli-2/base/argstack.h
/usr/include/libmowgli-2/base/bitvector.h
/usr/include/libmowgli-2/base/formatter.h
/usr/include/libmowgli-2/base/hash.h
/usr/include/libmowgli-2/base/hook.h
/usr/include/libmowgli-2/base/memslice.h
/usr/include/libmowgli-2/base/mowgli_signal.h
/usr/include/libmowgli-2/base/random.h
/usr/include/libmowgli-2/container/dictionary.h
/usr/include/libmowgli-2/container/index.h
/usr/include/libmowgli-2/container/list.h
/usr/include/libmowgli-2/container/patricia.h
/usr/include/libmowgli-2/container/queue.h
/usr/include/libmowgli-2/core/alloc.h
/usr/include/libmowgli-2/core/allocation_policy.h
/usr/include/libmowgli-2/core/allocator.h
/usr/include/libmowgli-2/core/assert.h
/usr/include/libmowgli-2/core/bootstrap.h
/usr/include/libmowgli-2/core/exception.h
/usr/include/libmowgli-2/core/heap.h
/usr/include/libmowgli-2/core/iterator.h
/usr/include/libmowgli-2/core/logger.h
/usr/include/libmowgli-2/core/mowgli_string.h
/usr/include/libmowgli-2/core/process.h
/usr/include/libmowgli-2/core/stdinc.h
/usr/include/libmowgli-2/dns/dns.h
/usr/include/libmowgli-2/dns/dns_evloop_res.h
/usr/include/libmowgli-2/dns/dns_evloop_reslib.h
/usr/include/libmowgli-2/eventloop/eventloop.h
/usr/include/libmowgli-2/ext/confparse.h
/usr/include/libmowgli-2/ext/error_backtrace.h
/usr/include/libmowgli-2/ext/getopt_long.h
/usr/include/libmowgli-2/ext/global_storage.h
/usr/include/libmowgli-2/ext/proctitle.h
/usr/include/libmowgli-2/ext/program_opts.h
/usr/include/libmowgli-2/linebuf/linebuf.h
/usr/include/libmowgli-2/module/module.h
/usr/include/libmowgli-2/object/class.h
/usr/include/libmowgli-2/object/message.h
/usr/include/libmowgli-2/object/metadata.h
/usr/include/libmowgli-2/object/object.h
/usr/include/libmowgli-2/platform/constructor.h
/usr/include/libmowgli-2/platform/machine.h
/usr/include/libmowgli-2/platform/win32/win32_stdinc.h
/usr/include/libmowgli-2/thread/mutex.h
/usr/include/libmowgli-2/thread/thread.h
/usr/include/libmowgli-2/vio/vio.h
/usr/lib/i386-linux-gnu/libmowgli-2.so
/usr/lib/i386-linux-gnu/pkgconfig/libmowgli-2.pc
/usr/share/doc/libmowgli-2-dev/BOOST
/usr/share/doc/libmowgli-2-dev/README
/usr/share/doc/libmowgli-2-dev/changelog.Debian.gz
/usr/share/doc/libmowgli-2-dev/copyright
/usr/share/doc/libmowgli-2-dev/examples/Makefile
/usr/share/doc/libmowgli-2-dev/examples/buildsys.mk
/usr/share/doc/libmowgli-2-dev/examples/async_resolver/Makefile
/usr/share/doc/libmowgli-2-dev/examples/async_resolver/async_resolver.c
/usr/share/doc/libmowgli-2-dev/examples/echoserver/Makefile
/usr/share/doc/libmowgli-2-dev/examples/echoserver/echoserver.c
/usr/share/doc/libmowgli-2-dev/examples/formattertest/Makefile
/usr/share/doc/libmowgli-2-dev/examples/formattertest/formattertest.c
/usr/share/doc/libmowgli-2-dev/examples/futuretest/Makefile
/usr/share/doc/libmowgli-2-dev/examples/futuretest/futuretest.c
/usr/share/doc/libmowgli-2-dev/examples/helpertest/Makefile
/usr/share/doc/libmowgli-2-dev/examples/helpertest/helpertest.c
/usr/share/doc/libmowgli-2-dev/examples/libevent-bench/Makefile
/usr/share/doc/libmowgli-2-dev/examples/libevent-bench/bench.c
/usr/share/doc/libmowgli-2-dev/examples/linetest/Makefile
/usr/share/doc/libmowgli-2-dev/examples/linetest/linetest.c
/usr/share/doc/libmowgli-2-dev/examples/listsort/Makefile
/usr/share/doc/libmowgli-2-dev/examples/listsort/listsort.c
/usr/share/doc/libmowgli-2-dev/examples/memslice-bench/Makefile
/usr/share/doc/libmowgli-2-dev/examples/memslice-bench/memslice-bench.c
/usr/share/doc/libmowgli-2-dev/examples/patriciatest/Makefile
/usr/share/doc/libmowgli-2-dev/examples/patriciatest/patriciatest.c
/usr/share/doc/libmowgli-2-dev/examples/patriciatest2/Makefile
/usr/share/doc/libmowgli-2-dev/examples/patriciatest2/patriciatest2.c
/usr/share/doc/libmowgli-2-dev/examples/randomtest/Makefile
/usr/share/doc/libmowgli-2-dev/examples/randomtest/randomtest.c
/usr/share/doc/libmowgli-2-dev/examples/timertest/Makefile
/usr/share/doc/libmowgli-2-dev/examples/timertest/timertest.c
/usr/share/doc/libmowgli-2-dev/examples/vio-udplistener/Makefile
/usr/share/doc/libmowgli-2-dev/examples/vio-udplistener/vio-udplistener.c

Changelog

2014-06-18 - Andrew Shadura <andrewsh@debian.org>
libmowgli-2 (2.0.0-3) unstable; urgency=medium
* Fix symbols, unbreak build on kFreeBSD.
* Update the home page URL (Closes: #747383).
* Add pkg-config dependency (Closes: #747336).
2014-06-17 - Andrew Shadura <andrewsh@debian.org>
libmowgli-2 (2.0.0-2) unstable; urgency=medium
* Add missing licenses to debian/copyright (Closes: #741436).
* Fix build on unsupported architectures and Hurd (Closes: #745608).
2014-01-28 - Andrew Shadura <andrewsh@debian.org>
libmowgli-2 (2.0.0-1) unstable; urgency=low
* New major upstream release (Closes: #676964).
* Update copyright file.
2014-01-27 - Andrew Shadura <andrewsh@debian.org>
libmowgli (1.0.0-4) unstable; urgency=low
* Update config.sub and config.guess on build (Closes: #727414).
* Build-depend on autotools-dev to have fresh config.* files.
2013-10-23 - Andrew Shadura <andrewsh@debian.org>
libmowgli (1.0.0-3) unstable; urgency=low
* Fix arch-dependent files in -dev package (Closes: #670014).
2013-10-22 - Andrew Shadura <andrewsh@debian.org>
libmowgli (1.0.0-2) unstable; urgency=low
* Update Standards-Version to 3.9.4 (no changes).
* Fix FTBFS with latest debhelper (Closes: #724183).
* Fix arch-dependent files in -dev package (Closes: #670014).
2012-04-02 - Andrew O. Shadura <bugzilla@tut.by>
libmowgli (1.0.0-1) unstable; urgency=low
* New maintainer
* New upstream release (Closes: #647748, #559181, #590064)
* Switch to 3.0 (quilt) format, drop README.source
* Bump Standards-Version to 3.9.3
* Don't compress examples source code
* Use dpkg-buildflags
* Update Homepage field
* Update copyright file
* Update package descriptions
* Update symbols file
* Update watch file
* Run autoreconf during build, stop using autotools-dev
* Use debian/clean to clean up after build
* Remove duplicate Section fields in debian/control
* Update Vcs-* fields
* Add lintian override for exception handling code calling exit(3)
* Don't try to install make dependency bits along with examples
* Add multiarch support:
- raise debhelper compatibility level to 9
- raise debhelper build-dependency to 9
- add Pre-Depends to the binary package
- change install files to use multiarch paths
- use Multi-Arch: same for binary packages
- strip multiarch paths from buildsys.mk installed
along with examples
2011-02-22 - Patrick Schoenfeld <schoenfeld@debian.org>
libmowgli (0.7.1-1) unstable; urgency=low
* New upstream version
* Update patch 001-Disable_Makefile_silent_output.diff
Update 001-Disable_Makefile_silent_output.diff for
current makefile
* Remove 'a' from package description
(Closes: #500944)
2011-02-22 - Patrick Schoenfeld <schoenfeld@debian.org>
libmowgli (0.7.0-3) unstable; urgency=low
* Upload to sid (Closes: #559181, #590064)
* Update watch file
* Update the Vcs-uris to reflection the migration git
* Switch to debhelper 7
* Switch to quilt as patch management system
* Update Standards-Version, changes needed:
+ Update section of libmowgli2-dbg to 'debug'
* Add missing misc:Depends in libmowgli-dev and libmowgli2-dbg control
information
* Remove Adam Cécile from uploaders
* Fix watch file (again)
(Closes: #486575)
2008-09-17 - Patrick Schoenfeld <schoenfeld@debian.org>
libmowgli (0.7.0-2) experimental; urgency=low
* Upload to experimental because lenny is frozen
* Replace (C) with © because of its legal entitlement (in debian/copyright)

See Also

Package Description
libmowgli-dev_1.0.0-4_i386.deb high performance development framework for C (development)
libmowgli2_1.0.0-4_i386.deb high performance development framework for C
libmozilla-ldap-perl_1.5.3-2+b1_i386.deb LDAP Perl module for the OpenLDAP C SDK
libmozjs-24-0_24.2.0-2_i386.deb Spidermonkey JavaScript engine
libmozjs-24-bin_24.2.0-2_i386.deb Spidermonkey JavaScript shell
libmozjs-24-dev_24.2.0-2_i386.deb Spidermonkey JavaScript library - development headers
libmozjs185-1.0_1.8.5-1.0.0+dfsg-4.3_i386.deb Spidermonkey javascript engine
libmozjs185-dev_1.8.5-1.0.0+dfsg-4.3_i386.deb Spidermonkey javascript library - development headers
libmp3-info-perl_1.24-1_all.deb Perl MP3::Info - Manipulate / fetch info from MP3 audio files
libmp3-tag-perl_1.13-1_all.deb Module for reading tags of MP3 audio files
libmp3lame-dev_3.99.5+repack1-7+deb8u2_i386.deb MP3 encoding library (development)
libmp3lame-ocaml-dev_0.3.2-1+b1_i386.deb OCaml interface to the lame library -- developpement files
libmp3lame-ocaml_0.3.2-1+b1_i386.deb OCaml interface to the lame library -- runtime files
libmp3lame0_3.99.5+repack1-7+deb8u2_i386.deb MP3 encoding library
libmp3spi-java_1.9.5-1_all.deb interface to support MP3 (MPEG 1/2/2.5 Layer 1/2/3) audio format
Advertisement
Advertisement