libmoox-late-perl_0.015-1_all.deb


Advertisement

Description

libmoox-late-perl - easily translate Moose code to Moo

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmoox-late-perl
Package version: 0.015
Package release: 1
Package architecture: all
Package type: deb
Installed size: 21 B
Download size: 12.65 KB
Official Mirror: ftp.br.debian.org
Moo is a light-weight object oriented programming framework which aims to be partly compatible with Moose. However, the surface syntax of Moo differs somewhat from Moose. MooX::late provides some assistance by enabling a slightly more Moosey surface syntax. MooX::late makes it easier: - to port code that was initially written for Moose to Moo - to write Moo code that can later be converted to use the full Moose feature-set if needed.

Alternatives

    Download

    Source package: libmoox-late-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmoox-late-perl deb package:
      # sudo apt-get install libmoox-late-perl

    Files

    • /usr/share/doc/libmoox-late-perl/CONTRIBUTING
    • /usr/share/doc/libmoox-late-perl/changelog.Debian.gz
    • /usr/share/doc/libmoox-late-perl/changelog.gz
    • /usr/share/doc/libmoox-late-perl/copyright
    • /usr/share/doc/libmoox-late-perl/examples/simple.pl
    • /usr/share/man/man3/MooX::late.3pm.gz
    • /usr/share/perl5/MooX/late.pm

    Changelog

    2014-08-26 - intrigeri <intrigeri@debian.org> libmoox-late-perl (0.015-1) unstable; urgency=medium [ Salvatore Bonaccorso ] * Update Vcs-Browser URL to cgit web frontend [ intrigeri ] * New upstream release. * Bump {build,runtime}-dependencies: - libmoo-perl to >= 1.006000 - libtype-tiny-perl to >= 1.000001 * Add build-dep on libmoox-handlesvia-perl, to enable some additional tests.

    2014-08-14 - intrigeri <intrigeri@debian.org> libmoox-late-perl (0.014-2) unstable; urgency=medium [ intrigeri ] * Add versioned build-dependency on perl (>= 5.15.2): ExtUtils::MakeMaker >= 6.59 is in core since this version. Also, Test::More >= 0.96 is in core since 5.13.4. * Add debian/upstream/metadata * Drop Suggests on libmoox-perl, that is not part of Debian. * Declare compliance with Standards-Version 3.9.5, no change required. [ gregor herrmann ] * Install CONTRIBUTING file.

    2013-09-05 - intrigeri <intrigeri@debian.org> libmoox-late-perl (0.014-1) unstable; urgency=low * Initial Release (Closes: #728458).

    Advertisement
    Advertisement