libmoosex-undeftolerant-perl_0.19-1_all.deb


Advertisement

Description

libmoosex-undeftolerant-perl - makes Moose attribute(s) tolerant to undef initialization

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmoosex-undeftolerant-perl
Package version: 0.19
Package release: 1
Package architecture: all
Package type: deb
Installed size: 69 B
Download size: 16.44 KB
Official Mirror: ftp.br.debian.org
Loading MooseX::UndefTolerant in your Moose class makes initialization of your attributes tolerant of undef. If you specify the value of undef to any of the attributes they will not be initialized, effectively behaving as if you had not provided a value at all.

    Download

    Source package: libmoosex-undeftolerant-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmoosex-undeftolerant-perl deb package:
      # sudo apt-get install libmoosex-undeftolerant-perl

    Files

    • /usr/share/doc/libmoosex-undeftolerant-perl/README
    • /usr/share/doc/libmoosex-undeftolerant-perl/buildinfo_all.gz
    • /usr/share/doc/libmoosex-undeftolerant-perl/changelog.Debian.gz
    • /usr/share/doc/libmoosex-undeftolerant-perl/changelog.gz
    • /usr/share/doc/libmoosex-undeftolerant-perl/copyright
    • /usr/share/man/man3/MooseX::UndefTolerant.3pm.gz
    • /usr/share/man/man3/MooseX::UndefTolerant::Attribute.3pm.gz
    • /usr/share/perl5/MooseX/UndefTolerant.pm
    • /usr/share/perl5/MooseX/UndefTolerant/ApplicationToClass.pm
    • /usr/share/perl5/MooseX/UndefTolerant/ApplicationToRole.pm
    • /usr/share/perl5/MooseX/UndefTolerant/Attribute.pm
    • /usr/share/perl5/MooseX/UndefTolerant/Class.pm
    • /usr/share/perl5/MooseX/UndefTolerant/Composite.pm
    • /usr/share/perl5/MooseX/UndefTolerant/Constructor.pm
    • /usr/share/perl5/MooseX/UndefTolerant/Role.pm

    Changelog

    2012-11-02 - Jonas Smedegaard <dr@jones.dk> libmoosex-undeftolerant-perl (0.19-1) unstable; urgency=low * New upstream release. [ Jonas Smedegaard ] * Bump debhelper compatibility level to 8. * Update copyright file: + Fix use comment and license pseudo-sections to obey silly restrictions of copyright format 1.0. * Update package relations: + Build-depend on libtest-nowarnings-perl. + Relax to build-depend unversioned on cdbs: Needed version satisfied in stable, and oldstable no longer supported.

    2012-05-09 - Jonas Smedegaard <dr@jones.dk> libmoosex-undeftolerant-perl (0.17-1) unstable; urgency=low * Initial packaging release. * Closes: Bug#666191.

    Advertisement
    Advertisement