libmoosex-types-uri-perl_0.07-1_all.deb


Advertisement

Description

libmoosex-types-uri-perl - package provides URI related types and coercions for Moose

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmoosex-types-uri-perl
Package version: 0.07
Package release: 1
Package architecture: all
Package type: deb
Installed size: 57 B
Download size: 8.42 KB
Official Mirror: ftp.br.debian.org
MooseX::Types::URI provides Moose types for fun with URIs. It has slightly DWIMier types than the URI classes have due to implementation details, so the types should be more forgiving when ducktyping will work anyway (e.g. URI::WithBase does not inherit URI).

Alternatives

    Download

    Source package: libmoosex-types-uri-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmoosex-types-uri-perl deb package:
      # sudo apt-get install libmoosex-types-uri-perl

    Files

    • /usr/share/doc/libmoosex-types-uri-perl/CONTRIBUTING
    • /usr/share/doc/libmoosex-types-uri-perl/changelog.Debian.gz
    • /usr/share/doc/libmoosex-types-uri-perl/changelog.gz
    • /usr/share/doc/libmoosex-types-uri-perl/copyright
    • /usr/share/man/man3/MooseX::Types::URI.3pm.gz
    • /usr/share/perl5/MooseX/Types/URI.pm

    Changelog

    2014-07-04 - gregor herrmann <gregoa@debian.org> libmoosex-types-uri-perl (0.07-1) unstable; urgency=medium * Team upload. * New upstream release. * Update (build) dependencies.

    2014-06-29 - gregor herrmann <gregoa@debian.org> libmoosex-types-uri-perl (0.06-1) unstable; urgency=medium * Team upload. * Install CONTRIBUTING file. * debian/control: bump required debhelper version for Module::Build::Tiny to 9.20140227. * Strip trailing slash from metacpan URLs. * New upstream release. * Add build dependency on perl. * Make (build) dependency on libmoosex-types-perl versioned.

    2013-12-21 - gregor herrmann <gregoa@debian.org> libmoosex-types-uri-perl (0.05-1) unstable; urgency=medium * Team upload. * New upstream release. * Update build dependencies. * Declare compliance with Debian Policy 3.9.5.

    2013-05-12 - Oleg Gashev <oleg@gashev.net> libmoosex-types-uri-perl (0.3-1) unstable; urgency=low * Initial Release. (Closes: #708057)

    Advertisement
    Advertisement