libmoosex-types-perl_0.45-1_all.deb


Advertisement

Description

libmoosex-types-perl - Moose extension to organise types in libraries

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmoosex-types-perl
Package version: 0.45
Package release: 1
Package architecture: all
Package type: deb
Installed size: 146 B
Download size: 49.89 KB
Official Mirror: ftp.br.debian.org
MooseX::Types allows developers to organise and selectively import your own and the built-in types in libraries, rather than the default behaviour where types are global. As a nice side effect, it catches typographic errors at compile-time too. The main motivation for this module is to provide an easy way of preventing conflicts with your type names, since the internal fully qualified names of the types will be prefixed with the library's name. It also provides some convenient functions for working with Moose types.

Alternatives

    Download

    Source package: libmoosex-types-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmoosex-types-perl deb package:
      # sudo apt-get install libmoosex-types-perl

    Files

    • /usr/share/doc/libmoosex-types-perl/CONTRIBUTING
    • /usr/share/doc/libmoosex-types-perl/changelog.Debian.gz
    • /usr/share/doc/libmoosex-types-perl/changelog.gz
    • /usr/share/doc/libmoosex-types-perl/copyright
    • /usr/share/man/man3/MooseX::Types.3pm.gz
    • /usr/share/man/man3/MooseX::Types::Base.3pm.gz
    • /usr/share/man/man3/MooseX::Types::CheckedUtilExports.3pm.gz
    • /usr/share/man/man3/MooseX::Types::Combine.3pm.gz
    • /usr/share/man/man3/MooseX::Types::Moose.3pm.gz
    • /usr/share/man/man3/MooseX::Types::TypeDecorator.3pm.gz
    • /usr/share/man/man3/MooseX::Types::UndefinedType.3pm.gz
    • /usr/share/man/man3/MooseX::Types::Util.3pm.gz
    • /usr/share/man/man3/MooseX::Types::Wrapper.3pm.gz
    • /usr/share/perl5/MooseX/Types.pm
    • /usr/share/perl5/MooseX/Types/Base.pm
    • /usr/share/perl5/MooseX/Types/CheckedUtilExports.pm
    • /usr/share/perl5/MooseX/Types/Combine.pm
    • /usr/share/perl5/MooseX/Types/Moose.pm
    • /usr/share/perl5/MooseX/Types/TypeDecorator.pm
    • /usr/share/perl5/MooseX/Types/UndefinedType.pm
    • /usr/share/perl5/MooseX/Types/Util.pm
    • /usr/share/perl5/MooseX/Types/Wrapper.pm

    Changelog

    2014-10-20 - gregor herrmann <gregoa@debian.org> libmoosex-types-perl (0.45-1) unstable; urgency=medium [ Salvatore Bonaccorso ] * Update Vcs-Browser URL to cgit web frontend [ gregor herrmann ] * Add debian/upstream/metadata * Import upstream version 0.45 * debian/copyright: update Upstream-Contact. * Update (build) dependencies. * Mark package as autopkgtest-able. * Declare compliance with Debian Policy 3.9.6.

    2014-05-10 - gregor herrmann <gregoa@debian.org> libmoosex-types-perl (0.44-1) unstable; urgency=medium * New upstream release. * debian/control: bump required debhelper version for Module::Build::Tiny to 9.20140227. * Strip trailing slash from metacpan URLs. * Drop fix-bad-whatis-entry.patch, fixed upstream. * Update years of packaging copyright. * Add (build) dependency on libnamespace-clean-perl.

    2013-12-25 - gregor herrmann <gregoa@debian.org> libmoosex-types-perl (0.41-1) unstable; urgency=low [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * New upstream release. * Refresh fix-bad-whatis-entry.patch (offset). * Update years of copyright. * Update (build) dependencies. * Install new CONTRIBUTING file. * Declare compliance with Debian Policy 3.9.5.

    2012-05-19 - Salvatore Bonaccorso <carnil@debian.org> libmoosex-types-perl (0.35-1) unstable; urgency=low * Imported Upstream version 0.35

    2012-05-19 - Salvatore Bonaccorso <carnil@debian.org> libmoosex-types-perl (0.34-1) unstable; urgency=low [ Alessandro Ghedini ] * Email change: Alessandro Ghedini -> ghedo@debian.org [ Salvatore Bonaccorso ] * Imported Upstream version 0.34 * Update debian/copyright file information. Update format to copyright-format 1.0 as released together with Debian policy 3.9.3. Update copyright years for upstream files. Update copyright years for debian/* packaging. * Bump Standards-Version to 3.9.3 * Simplify (build)-dependencies satisfied in Squeeze. Change versioned (Build-)Depends(-Indep) on libmoose-perl to an unversioned dependency as the required version is already satisfied in Squeeze. Remove alternative Build-Depends-Indep on perl (>= 5.10.1) | libtest-simple-perl (>= 0.88) for Test::More 0.88.

    2011-12-23 - gregor herrmann <gregoa@debian.org> libmoosex-types-perl (0.31-1) unstable; urgency=low * New upstream release.

    2011-09-18 - Alessandro Ghedini <al3xbio@gmail.com> libmoosex-types-perl (0.30-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * debian/copyright: Replace DEP5 Format-Specification URL from svn.debian.org to anonscm.debian.org URL. [ Alessandro Ghedini ] * New upstream release * (Build-)Depends(-Indep) on libnamespace-clean-perl (>= 0.19)

    2011-06-07 - Alessandro Ghedini <al3xbio@gmail.com> libmoosex-types-perl (0.27-1) unstable; urgency=low * New upstream release * Update upstream copyright year * Remove inc/Module/* from copyright (no more used) * Add myself to Uploaders * Add fix-bad-whatis-entry patch * Remove versioned (B-)D(-I) for libsub-install-perl (version 0.924 is in oldstable)

    2011-04-21 - gregor herrmann <gregoa@debian.org> libmoosex-types-perl (0.25-2) unstable; urgency=low * debian/control: update (build) dependencies to prepare for Moose/Class::MOP changes. * Set Standards-Version to 3.9.2 (no changes). * Bump debhelper compatibility level to 8.

    2010-12-01 - Ansgar Burchardt <ansgar@debian.org> libmoosex-types-perl (0.25-1) unstable; urgency=low [ Salvatore Bonaccorso ] * Update my email address. [ Ansgar Burchardt ] * New upstream release. * Add build-dep on libtest-requires-perl. * Build-depend on libtest-fatal-perl instead of libtest-exception-perl. * Bump build-dep on libtest-simple-perl to >= 0.88. * Update my email address.

    Advertisement
    Advertisement