libmoosex-types-path-class-perl_0.05-2_all.deb


Advertisement

Description

libmoosex-types-path-class-perl - Path::Class type library for Moose

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmoosex-types-path-class-perl
Package version: 0.05
Package release: 2
Package architecture: all
Package type: deb
Installed size: 68 B
Download size: 7.22 KB
Official Mirror: ftp.br.debian.org
MooseX::Types::Path::Class creates common Moose types, coercions and option specifications useful for dealing with Path::Class objects as Moose attributes. Coercions (see Moose::Util::TypeConstraints) are made from both 'Str' and 'ArrayRef' to both Path::Class::Dir and Path::Class::File objects. If you have MooseX::Getopt installed, the Getopt option type ("=s") will be added for both Path::Class::Dir and Path::Class::File.

    Download

    Source package: libmoosex-types-path-class-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmoosex-types-path-class-perl deb package:
      # sudo apt-get install libmoosex-types-path-class-perl

    Files

    • /usr/share/doc/libmoosex-types-path-class-perl/changelog.Debian.gz
    • /usr/share/doc/libmoosex-types-path-class-perl/changelog.gz
    • /usr/share/doc/libmoosex-types-path-class-perl/copyright
    • /usr/share/man/man3/MooseX::Types::Path::Class.3pm.gz
    • /usr/share/perl5/MooseX/Types/Path/Class.pm

    Changelog

    2011-04-21 - gregor herrmann <gregoa@debian.org> libmoosex-types-path-class-perl (0.05-2) unstable; urgency=low [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ gregor herrmann ] * debian/control: update (build) dependencies to prepare for Moose/Class::MOP changes. * Switch to source format 3.0 (quilt). * debian/rules: use tiny dh file. * debian/copyright: update formatting * Set Standards-Version to 3.9.2 (no further changes). * Add /me to Uploaders. * Bump debhelper compatibility level to 8. * debian/control: remove version from (build) dependencies that are fulfilled at least in oldstable.

    2009-06-01 - franck cuny <franck@lumberjaph.net> libmoosex-types-path-class-perl (0.05-1) unstable; urgency=low * Initial Release (Closes: #531400).

    Advertisement
    Advertisement