libmoosex-types-netaddr-ip-perl_0.07-1_all.deb


Advertisement

Description

libmoosex-types-netaddr-ip-perl - Moose extension for NetAddr::IP type constraints

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmoosex-types-netaddr-ip-perl
Package version: 0.07
Package release: 1
Package architecture: all
Package type: deb
Installed size: 55 B
Download size: 5.80 KB
Official Mirror: ftp.br.debian.org
MooseX::Types::NetAddr::IP provides IP Address type constraints and coercions for Moose, based on NetAddr::IP (see libnet-addr-ip-perl). It provides three subtypes: NetAddrIPv4 and NetAddrIPv6 (which must be IPv4 and IPv6 addresses respectively) as well as NetAddrIP (which may be an IPv4 or IPv6 address).

    Download

    Source package: libmoosex-types-netaddr-ip-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmoosex-types-netaddr-ip-perl deb package:
      # sudo apt-get install libmoosex-types-netaddr-ip-perl

    Files

    • /usr/share/doc/libmoosex-types-netaddr-ip-perl/changelog.Debian.gz
    • /usr/share/doc/libmoosex-types-netaddr-ip-perl/changelog.gz
    • /usr/share/doc/libmoosex-types-netaddr-ip-perl/copyright
    • /usr/share/man/man3/MooseX::Types::NetAddr::IP.3pm.gz
    • /usr/share/perl5/MooseX/Types/NetAddr/IP.pm

    Changelog

    2014-07-26 - gregor herrmann <gregoa@debian.org> libmoosex-types-netaddr-ip-perl (0.07-1) unstable; urgency=medium * Team upload. * New upstream release. * Strip trailing slash from metacpan URLs. * Update (build) dependencies. * Declare compliance with Debian Policy 3.9.5.

    2013-10-03 - Florian Schlichting <fsfs@debian.org> libmoosex-types-netaddr-ip-perl (0.06-1) unstable; urgency=low * Team upload [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Axel Beckert ] * debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg- copyright" [ Florian Schlichting ] * Import Upstream version 0.06 * Add new (build-)dependency on Class::Load * Declare compliance with Debian Policy 3.9.4

    2011-03-13 - Jonathan Yu <jawnsy@cpan.org> libmoosex-types-netaddr-ip-perl (0.04-1) unstable; urgency=low * Initial Release (Closes: #613213)

    Advertisement
    Advertisement