libmoosex-params-validate-perl_0.18-1_all.deb


Advertisement

Description

libmoosex-params-validate-perl - Moose extension for validating method parameters

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmoosex-params-validate-perl
Package version: 0.18
Package release: 1
Package architecture: all
Package type: deb
Installed size: 66 B
Download size: 13.58 KB
Official Mirror: ftp.br.debian.org
MooseX::Params::Validate is a Perl module that enables Moose programs to validate method parameters, ensuring that incoming parameters are of the appropriate Moose types and roles. This module is one of many developing options to do this sort of thing; See MooseX::Method::Signatures (libmoosex-method-signatures-perl) and MooseX::Declare (libmoosex-declare-perl) for others.

    Download

    Source package: libmoosex-params-validate-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmoosex-params-validate-perl deb package:
      # sudo apt-get install libmoosex-params-validate-perl

    Files

    • /usr/share/doc/libmoosex-params-validate-perl/changelog.Debian.gz
    • /usr/share/doc/libmoosex-params-validate-perl/changelog.gz
    • /usr/share/doc/libmoosex-params-validate-perl/copyright
    • /usr/share/man/man3/MooseX::Params::Validate.3pm.gz
    • /usr/share/perl5/MooseX/Params/Validate.pm

    Changelog

    2013-06-08 - gregor herrmann <gregoa@debian.org> libmoosex-params-validate-perl (0.18-1) unstable; urgency=low * Team upload. [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Change search.cpan.org based URIs to metacpan.org based URIs [ gregor herrmann ] * New upstream release. Fixes "FTBFS with perl 5.18: test failures" (Closes: #711609) * debian/copyright: switch formatting to Copyright-Format 1.0. * Update years of upstream copyright. * Set Standards-Version to 3.9.4 (no further changes).

    2011-02-27 - Jonathan Yu <jawnsy@cpan.org> libmoosex-params-validate-perl (0.16-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Rewrite control description * Bump to debhelper 8 * Drop dependencies satisfied in oldstable [ gregor herrmann ] * debian/copyright: update years of upstream and packaging copyright.

    2010-12-01 - Ansgar Burchardt <ansgar@debian.org> libmoosex-params-validate-perl (0.15-1) unstable; urgency=low * New upstream release. * Build-depend on libtest-fatal-perl instead of libtest-exception-perl. * Add build-dep on perl (>= 5.10.1) | libtest-simple-perl (>= 0.88). * debian/copyright: Update for new release; refer to "Debian systems" instead of "Debian GNU/Linux systems"; refer to GPL-1. * Bump Standards-Version to 3.9.1. * Add myself to Uploaders.

    2010-03-18 - Jonathan Yu <jawnsy@cpan.org> libmoosex-params-validate-perl (0.14-1) unstable; urgency=low * New upstream release * Standards-Version 3.8.4 (no changes) * Drop Test::Pod{,::Coverage} -- now an xt/ test

    2009-11-29 - Jonathan Yu <jawnsy@cpan.org> libmoosex-params-validate-perl (0.13-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release * Standards-Version 3.8.3 (no changes) [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ Ryan Niebur ] * Update jawnsy's email address

    2009-07-08 - Jonathan Yu <frequency@cpan.org> libmoosex-params-validate-perl (0.12-1) unstable; urgency=low * New upstream release + Fixes bugs (RT#46730, RT#46344, RT#47647) + New dependency on Devel::Caller (libdevel-caller-perl)

    2009-06-30 - Jonathan Yu <frequency@cpan.org> libmoosex-params-validate-perl (0.10-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release + Fixes a warning about deprecated Moose call [ Nathan Handler ] * debian/watch: Update to ignore development releases. [ gregor herrmann ] * Set Standards-Version to 3.8.2 (no changes).

    2009-05-21 - Jonathan Yu <frequency@cpan.org> libmoosex-params-validate-perl (0.09-1) unstable; urgency=low * Initial Release. (Closes: #529812)

    Advertisement
    Advertisement