libmoosex-lazyrequire-perl_0.11-1_all.deb


Advertisement

Description

libmoosex-lazyrequire-perl - Moose extension to delay errors for attribute declarations

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmoosex-lazyrequire-perl
Package version: 0.11
Package release: 1
Package architecture: all
Package type: deb
Installed size: 13 B
Download size: 8.61 KB
Official Mirror: ftp.br.debian.org
MooseX::LazyRequire adds a lazy_require option to Moose attribute declarations. The reader methods for all attributes with that option will throw an exception unless a value for the attributes was provided earlier by a constructor parameter or through a writer method.

Alternatives

    Download

    Source package: libmoosex-lazyrequire-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmoosex-lazyrequire-perl deb package:
      # sudo apt-get install libmoosex-lazyrequire-perl

    Files

    • /usr/share/doc/libmoosex-lazyrequire-perl/changelog.Debian.gz
    • /usr/share/doc/libmoosex-lazyrequire-perl/changelog.gz
    • /usr/share/doc/libmoosex-lazyrequire-perl/copyright
    • /usr/share/man/man3/MooseX::LazyRequire.3pm.gz
    • /usr/share/perl5/MooseX/LazyRequire.pm
    • /usr/share/perl5/MooseX/LazyRequire/Meta/Attribute/Trait/LazyRequire.pm

    Changelog

    2014-08-27 - intrigeri <intrigeri@debian.org> libmoosex-lazyrequire-perl (0.11-1) unstable; urgency=medium * Team upload. [ gregor herrmann ] * Strip trailing slash from metacpan URLs. [ Salvatore Bonaccorso ] * Update Vcs-Browser URL to cgit web frontend [ intrigeri ] * Add debian/upstream/metadata * Imported Upstream version 0.11 * Add build-dep on libmodule-build-tiny-perl. * Declare compliance with Standards-Version 3.9.5 (no change required).

    2013-03-23 - gregor herrmann <gregoa@debian.org> libmoosex-lazyrequire-perl (0.10-1) unstable; urgency=low * New upstream release. * Update years of upstream and packaging copyright.

    2013-02-12 - Alessandro Ghedini <ghedo@debian.org> libmoosex-lazyrequire-perl (0.09-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Alessandro Ghedini ] * New upstream release * Email change: Alessandro Ghedini -> ghedo@debian.org * Remove (build) dep on libmoosex-types-perl * Replace build dep on libtext-exception-perl with libtest-fatal-perl * Bump Standards-Version to 3.9.4 (no changes needed) * Update copyright to Copyright-FOrmat 1.0 * Build depend on libtest-checkdeps-perl

    2011-04-21 - gregor herrmann <gregoa@debian.org> libmoosex-lazyrequire-perl (0.07-1) unstable; urgency=low [ Salvatore Bonaccorso ] * Email change: Salvatore Bonaccorso -> carnil@debian.org [ Ansgar Burchardt ] * Email change: Ansgar Burchardt -> ansgar@debian.org [ Alessandro Ghedini ] * New upstream release * Update upstream copyright year * Replace "Debian GNU/Linux" with just "Debian" in debian/copyright * Fix copyright-refers-to-symlink-license * Bump debhelper compat level to 8 * Bump Standards-Version (no changes needed) * Add myself to Uploaders

    2010-07-19 - Ansgar Burchardt <ansgar@43-1.org> libmoosex-lazyrequire-perl (0.06-1) unstable; urgency=low * New upstream release. * debian/copyright: Update years of copyright. * Bump (build-)dep on libmoose-perl to >= 0.94. * No longer run release tests. * Remove build-dep on libtest-pod-perl. * Use source format 3.0 (quilt). * Bump Standards-Version to 3.9.0 (no changes).

    2010-02-11 - Salvatore Bonaccorso <salvatore.bonaccorso@gmail.com> libmoosex-lazyrequire-perl (0.04-2) unstable; urgency=low [ Jonathan Yu ] * Update short description [ Salvatore Bonaccorso ] * Add Build-Depends-Indep on libtest-exception-perl. Fixes FTBFS (Closes: #569460). * Add myself to Uploaders. * Bump Standards-Version to 3.8.4 (no changes). * Refresh debian/copyright to machine readable format specification proposed in DEP5 revision 135. Update debian/* packaging stanza. * Add alternate Build-Depends on perl (>= 5.10.1) | libtest-simple-perl (>= 0.88).

    2009-10-04 - gregor herrmann <gregoa@debian.org> libmoosex-lazyrequire-perl (0.04-1) unstable; urgency=low [ Jonathan Yu ] * New upstream release [ gregor herrmann ] * Add /me to Uploaders.

    2009-08-18 - Ansgar Burchardt <ansgar@43-1.org> libmoosex-lazyrequire-perl (0.03-1) unstable; urgency=low [ Salvatore Bonaccorso ] * debian/control: Changed: Replace versioned (build-)dependency on perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as permitted by Debian Policy 3.8.3). [ Ansgar Burchardt ] * New upstream release * debian/control: bump Standards-Version to 3.8.3 * debian/control: build-dep on debhelper 7.0.50 for override_dh_*

    2009-08-14 - Ansgar Burchardt <ansgar@43-1.org> libmoosex-lazyrequire-perl (0.01-1) unstable; urgency=low * Initial Release (Closes: #541597).

    Advertisement
    Advertisement