libmodule-used-perl_1.3.0-1_all.deb


Advertisement

Description

libmodule-used-perl - library to detect modules loaded by Perl code without running it

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libmodule-used-perl
Package version 1.3.0
Package release 1
Package architecture all
Package type deb
Installed size 73 B
Download size 14.08 KB
Official Mirror ftp.br.debian.org
Module::Used is a Perl module that does static analysis of arbitrary Perl
code, looking for use and require statements to determine what modules are
required by the code. It also knows about Moose and Moose::Role, so it can
determine appropriate dependencies in that case too.

Alternatives

Package Version Architecture Repository
libmodule-used-perl_1.3.0-1_all.deb 1.3.0 all Debian Main
libmodule-used-perl - - -

Requires

Name Value
libconst-fast-perl -
libfile-next-perl -
libmodule-path-perl -
libppi-perl -
perl -

Download

Type URL
Binary Package libmodule-used-perl_1.3.0-1_all.deb
Source Package libmodule-used-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmodule-used-perl deb package:
    # sudo apt-get install libmodule-used-perl

Files

Path
/usr/bin/modules-used
/usr/share/doc/libmodule-used-perl/changelog.Debian.gz
/usr/share/doc/libmodule-used-perl/changelog.gz
/usr/share/doc/libmodule-used-perl/copyright
/usr/share/man/man1/modules-used.1p.gz
/usr/share/man/man3/Module::Used.3pm.gz
/usr/share/perl5/Module/Used.pm

Changelog

2013-08-17 - Florian Schlichting <fsfs@debian.org>
libmodule-used-perl (1.3.0-1) unstable; urgency=low
[ gregor herrmann ]
* Remove alternative (build) dependencies that are already satisfied
in oldstable.
* debian/control: update {versioned,alternative} (build) dependencies.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Florian Schlichting ]
* Import Upstream version 1.3.0.
* Update upstream copyright years.
* Update (build-)dependencies.
* Bump Standards-Version to 3.9.4 (update to copyright-format 1.0. directly
link GPL-1+).
* Bump dh compatibility to level 8 (no changes necessary).
* Switch to source format 3.0 (quilt).
* Add myself to Uploaders and copyright.
2010-01-01 - Jonathan Yu <jawnsy@cpan.org>
libmodule-used-perl (1.2.0-1) unstable; urgency=low
* Initial Release (Closes: #563333)

See Also

Package Description
libmodule-util-perl_1.09-1_all.deb Perl module to manipulate Perl module names
libmodule-versions-report-perl_1.06-1_all.deb Report versions of all modules in memory
libmodule-want-perl_0.6-1_all.deb module to check @INC only once for wanted modules
libmoe-dev_1.5.8-1_i386.deb library to handle multiple octets character encoding scheme (devel files)
libmoe1.5_1.5.8-1_i386.deb library to handle multiple octets character encoding scheme
libmojo-server-fastcgi-perl_0.41-1_all.deb Mojolicious FastCGI Server
libmojolicious-perl_5.54+dfsg-1_all.deb simple, yet powerful, Web Application Framework
libmojolicious-plugin-authentication-perl_1.26-1_all.deb module to make authentication a bit easier for Mojolicious
libmojolicious-plugin-authorization-perl_1.0302-1_all.deb module to make authorization a bit easier for Mojolicious
libmojolicious-plugin-basicauth-perl_0.08-1_all.deb basic HTTP auth helper for Mojolicious
libmojolicious-plugin-bcrypt-perl_0.14-1_all.deb module to bcrypt passwords for Mojolicious
libmojolicious-plugin-cgi-perl_0.12-1_all.deb Mojolicious plugin to run CGI scripts
libmojolicious-plugin-i18n-perl_1.30-1_all.deb internationalization plugin for Mojolicious 3.x and higher
libmojolicious-plugin-mailexception-perl_0.19-1_all.deb Mojolicious plugin to send crash information by email
libmojomojo-perl_1.10+dfsg1-4_all.deb wiki- and blog-inspired content management system
Advertisement
Advertisement