libmodule-pluggable-ordered-perl_1.5-2_all.deb


Advertisement

Description

libmodule-pluggable-ordered-perl - Perl module to load plugins in a specified order

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libmodule-pluggable-ordered-perl
Package version 1.5
Package release 2
Package architecture all
Package type deb
Installed size 12 B
Download size 9.16 KB
Official Mirror ftp.br.debian.org
Module::Pluggable::Ordered is a Perl module which extends the functionality
provided by Module::Pluggable, allowing hooks to determine an ordering for
modules to be loaded, producing an effect like the System V init process,
where files can specify where in the init sequence they'd like to be called.

Alternatives

Package Version Architecture Repository
libmodule-pluggable-ordered-perl_1.5-2_all.deb 1.5 all Debian Main
libmodule-pluggable-ordered-perl - - -

Requires

Name Value
libmodule-pluggable-perl -
libuniversal-require-perl -
perl << 5.17.0
perl -

Download

Type URL
Binary Package libmodule-pluggable-ordered-perl_1.5-2_all.deb
Source Package libmodule-pluggable-ordered-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmodule-pluggable-ordered-perl deb package:
    # sudo apt-get install libmodule-pluggable-ordered-perl

Files

Path
/usr/share/doc/libmodule-pluggable-ordered-perl/changelog.Debian.gz
/usr/share/doc/libmodule-pluggable-ordered-perl/changelog.gz
/usr/share/doc/libmodule-pluggable-ordered-perl/copyright
/usr/share/man/man3/Module::Pluggable::Ordered.3pm.gz
/usr/share/perl5/Module/Pluggable/Ordered.pm

Changelog

2014-06-10 - Damyan Ivanov <dmn@debian.org>
libmodule-pluggable-ordered-perl (1.5-2) unstable; urgency=low
* Team upload
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ Ryan Niebur ]
* Update jawnsy's email address
[ gregor herrmann ]
* debian/control: Changed: (build-)depend on perl instead of perl-
modules.
* Remove alternative (build) dependencies that are already satisfied
in oldstable.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* Explicitl (build)depend on Module::Pluggable. (Closes: #711667)
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Damyan Ivanov ]
* source format 3.0 (quilt)
* point to GPL-1 instead of the GPL symlink
2009-07-27 - Jonathan Yu <frequency@cpan.org>
libmodule-pluggable-ordered-perl (1.5-1) unstable; urgency=low
* Initial Release (Closes: #538939)

See Also

Package Description
libmodule-pluggable-perl_5.1-1_all.deb module for giving modules the ability to have plugins
libmodule-reader-perl_0.002003-1_all.deb module to read the source of a module like perl does
libmodule-refresh-perl_0.17-1_all.deb tool to refresh %INC files when updated on disk
libmodule-runtime-conflicts-perl_0.001-1_all.deb module to provide information on conflicts for Module::Runtime
libmodule-runtime-perl_0.014-1_all.deb Perl module for runtime module handling
libmodule-scandeps-perl_1.16-1_all.deb module to recursively scan Perl code for dependencies
libmodule-signature-perl_0.73-1+deb8u2_all.deb module to manipulate CPAN SIGNATURE files
libmodule-starter-pbp-perl_0.0.3-1_all.deb Perl module to create new perl modules following best practices
libmodule-starter-perl_1.620+dfsg-1_all.deb simple starter kit for Perl modules
libmodule-starter-plugin-cgiapp-perl_0.42-1_all.deb template based module starter for CGI apps
libmodule-starter-plugin-simplestore-perl_0.144-1_all.deb template storage methods for Module::Starter
libmodule-starter-plugin-tt2-perl_0.125-1_all.deb module providing Template toolkit support for Module::Starter
libmodule-starter-smart-perl_0.0.5-1_all.deb Module::Starter plugin to add new modules into existing distributions
libmodule-used-perl_1.3.0-1_all.deb library to detect modules loaded by Perl code without running it
libmodule-util-perl_1.09-1_all.deb Perl module to manipulate Perl module names
Advertisement
Advertisement