libmodule-package-perl_0.30-2_all.deb


Advertisement

Description

libmodule-package-perl - postmodern Perl module packaging

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmodule-package-perl
Package version: 0.30
Package release: 2
Package architecture: all
Package type: deb
Installed size: 126 B
Download size: 36.28 KB
Official Mirror: ftp.br.debian.org
Module::Package is a drop-in replacement for Module::Install. It does everything Module::Install does, but just a bit better. Actually this module is simply a wrapper around Module::Install. It attempts to drastically reduce what goes in a Makefile.PL, while at the same time, fixing many of the problems that people have had with Module::Install (and other module frameworks) over the years.

Alternatives

    Download

    Source package: libmodule-package-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmodule-package-perl deb package:
      # sudo apt-get install libmodule-package-perl

    Files

    • /usr/share/doc/libmodule-package-perl/README.gz
    • /usr/share/doc/libmodule-package-perl/buildinfo_all.gz
    • /usr/share/doc/libmodule-package-perl/changelog.Debian.gz
    • /usr/share/doc/libmodule-package-perl/changelog.gz
    • /usr/share/doc/libmodule-package-perl/copyright
    • /usr/share/man/man3/Module::Install::Package.3pm.gz
    • /usr/share/man/man3/Module::Package.3pm.gz
    • /usr/share/man/man3/Module::Package::Plugin.3pm.gz
    • /usr/share/man/man3/Module::Package::Tutorial.3pm.gz
    • /usr/share/man/man3/inc::Module::Package.3pm.gz
    • /usr/share/perl5/Module/Package.pm
    • /usr/share/perl5/Module/Package.pod
    • /usr/share/perl5/Module/Install/Package.pm
    • /usr/share/perl5/Module/Install/Package.pod
    • /usr/share/perl5/Module/Package/Plugin.pm
    • /usr/share/perl5/Module/Package/Plugin.pod
    • /usr/share/perl5/Module/Package/Tutorial.pod
    • /usr/share/perl5/inc/Module/Package.pm
    • /usr/share/perl5/inc/Module/Package.pod

    Changelog

    2013-06-03 - Jonas Smedegaard <dr@jones.dk> libmodule-package-perl (0.30-2) unstable; urgency=low [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org). [ Jonas Smedegaard ] * Fix recommend libmodule-signature-perl. * Update copyright file: Fix use pseudo-license and pseudo-comment sections to obey silly restrictions of copyright format 1.0. * Bump dephelper compatibility level to 8. * Bump standards-version to 3.9.4. * Add README.source emphasizing control.in file as *not* a show-stopper for contributions, referring to wiki page for details.

    2012-06-03 - Jonas Smedegaard <dr@jones.dk> libmodule-package-perl (0.30-1) unstable; urgency=low * Initial packaging release. Closes: bug#675733.

    Advertisement
    Advertisement