libmodule-find-perl_0.12-1_all.deb


Advertisement

Description

libmodule-find-perl - module to find and use installed Perl modules

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libmodule-find-perl
Package version 0.12
Package release 1
Package architecture all
Package type deb
Installed size 54 B
Download size 9.72 KB
Official Mirror ftp.br.debian.org
Module::Find is a Perl module that allows developers to find and use modules
in categories. This is useful for auto-detecting driver or plugin modules.
You can differentiate between looking in the category itself or in all
subcategories.
If you want Module::Find to search in a certain directory (like the plugins
directory of your software installation), make sure you modify @INC before
you call the Module::Find functions.

Alternatives

Package Version Architecture Repository
libmodule-find-perl_0.12-1_all.deb 0.12 all Debian Main
libmodule-find-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libmodule-find-perl_0.12-1_all.deb
Source Package libmodule-find-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmodule-find-perl deb package:
    # sudo apt-get install libmodule-find-perl

Files

Path
/usr/share/doc/libmodule-find-perl/changelog.Debian.gz
/usr/share/doc/libmodule-find-perl/changelog.gz
/usr/share/doc/libmodule-find-perl/copyright
/usr/share/man/man3/Module::Find.3pm.gz
/usr/share/perl5/Module/Find.pm

Changelog

2014-02-23 - gregor herrmann <gregoa@debian.org>
libmodule-find-perl (0.12-1) unstable; urgency=low
* Team upload.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* New upstream release.
* Update years of upstream copyright.
* Bump debhelper compatibility level to 8.
* Declare compliance with Debian Policy 3.9.5.
2012-05-27 - Salvatore Bonaccorso <carnil@debian.org>
libmodule-find-perl (0.11-1) unstable; urgency=low
* Team upload.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Imported Upstream version 0.11
* Update debian/copyright information.
Update format to copyright-format 1.0 as released together with Debian
policy 3.9.3.
Update copyright years for upstream files.
Explicitly refer to GPL-1 license text in common-licenses.
Refer to Debian systems in general instead of only Debian GNU/Linux
systems.
* Bump Standards-Version to 3.9.3
* Convert to '3.0 (quilt)' source package format
2010-03-03 - Jonathan Yu <jawnsy@cpan.org>
libmodule-find-perl (0.10-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
* Standards-Version 3.8.4 (no changes)
* Rewrite control description
[ gregor herrmann ]
* debian/copyright: update formatting and years of copyright.
2009-09-20 - Jonathan Yu <jawnsy@cpan.org>
libmodule-find-perl (0.08-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
+ New feature to follow symlinks
* Added myself to Uploaders and Copyright
* Standards-Version 3.8.3 (drop perl version dependency)
* Bump to debhelper 7 + short rules format
* Updated copyright information
* Small cleanups to control description
* Add Test-Pod{,-Coverage} to B-D-I
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
* debian/control: Added: ${misc:Depends} to Depends: field.
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
2008-02-07 - Gunnar Wolf <gwolf@debian.org>
libmodule-find-perl (0.06-2) unstable; urgency=low
* Fixed broken debian/watch (Cloeses: #450031)
* Added myself as an uploader
2008-01-31 - Krzysztof Krzyzaniak (eloy) <eloy@debian.org>
libmodule-find-perl (0.06-1) unstable; urgency=low
* New upstream release
+ Changed Maintainer from Catalyst Group to Debian Perl Group
+ Standards-Version upgraded to 3.7.3 without changes
+ added informational headers to control file
+ debian/compat increased to 6 without changes
2005-12-05 - Krzysztof Krzyzaniak (eloy) <eloy@debian.org>
libmodule-find-perl (0.05-1) unstable; urgency=low
* New upstream release
2005-08-09 - Krzysztof Krzyzaniak (eloy) <eloy@debian.org>
libmodule-find-perl (0.04-1) unstable; urgency=low
* Initial Release (closes: #322615)

See Also

Package Description
libmodule-implementation-perl_0.09-1_all.deb module for loading one of several alternate implementations of a module
libmodule-info-perl_0.35-1_all.deb Perl module providing information about Perl modules
libmodule-inspector-perl_1.05-2_all.deb integrated API for inspecting Perl distributions
libmodule-install-authorrequires-perl_0.02-1_all.deb declare author-only dependencies
libmodule-install-authortests-perl_0.002-1_all.deb designate tests only run by module authors
libmodule-install-autolicense-perl_0.08-1_all.deb automagically generate LICENSE files
libmodule-install-automanifest-perl_0.003-2_all.deb generate MANIFEST automatically
libmodule-install-contributors-perl_0.001-1_all.deb add an "x_contributors" section to your META.yml
libmodule-install-copyright-perl_0.009-1_all.deb package a COPYRIGHT file with a distribution
libmodule-install-doap-perl_0.006-1_all.deb generate META.yml data from DOAP
libmodule-install-doapchangesets-perl_0.206-1_all.deb write your distribution change log in RDF
libmodule-install-extratests-perl_0.008-1_all.deb contextual tests that the harness can ignore
libmodule-install-manifestskip-perl_0.24-1_all.deb generate a MANIFEST.SKIP file
libmodule-install-perl_1.14-1_all.deb framework for installing Perl modules
libmodule-install-rdf-perl_0.009-1_all.deb advanced metadata for your Perl packaging
Advertisement
Advertisement