libmodule-extract-use-perl_1.04-1_all.deb


Advertisement

Description

libmodule-extract-use-perl - Perl module to extract which modules some code uses

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libmodule-extract-use-perl
Package version 1.04
Package release 1
Package architecture all
Package type deb
Installed size 62 B
Download size 9.62 KB
Official Mirror ftp.br.debian.org
Module::Extract::Use extracts the names of the modules used in a file using a
static analysis. It uses PPI (Perl Parsing Interface) to tokenize and extract
the file data.
Since this module does not run code, it cannot find dynamic uses of modules,
such as eval "require $class".

Alternatives

Package Version Architecture Repository
libmodule-extract-use-perl_1.04-1_all.deb 1.04 all Debian Main
libmodule-extract-use-perl - - -

Requires

Name Value
libppi-perl -
perl -

Download

Type URL
Binary Package libmodule-extract-use-perl_1.04-1_all.deb
Source Package libmodule-extract-use-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmodule-extract-use-perl deb package:
    # sudo apt-get install libmodule-extract-use-perl

Files

Path
/usr/share/doc/libmodule-extract-use-perl/changelog.Debian.gz
/usr/share/doc/libmodule-extract-use-perl/changelog.gz
/usr/share/doc/libmodule-extract-use-perl/copyright
/usr/share/doc/libmodule-extract-use-perl/examples/extract_modules
/usr/share/man/man3/Module::Extract::Use.3pm.gz
/usr/share/perl5/Module/Extract/Use.pm

Changelog

2014-01-11 - gregor herrmann <gregoa@debian.org>
libmodule-extract-use-perl (1.04-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* New upstream release.
* Update years of copyright.
* Declare compliance with Debian Policy 3.9.5.
2012-08-04 - Nuno Carvalho <smash@cpan.org>
libmodule-extract-use-perl (1.03-1) unstable; urgency=low
* Team upload.
[ Florian Schlichting ]
* Imported Upstream version 1.02
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Nuno Carvalho ]
* d/control: Update Standards-Version to 3.9.3.
* d/copyright: Update format and field names.
* d/copyright: Update copyright years.
* New upstream release.
2011-04-19 - Jotam Jr. Trejo <jotamjr@debian.org.sv>
libmodule-extract-use-perl (1.01-1) unstable; urgency=low
[ Jotam Jr. Trejo ]
* New upstream release
* debian/control: Bump Standards Version to 3.9.2 (no changes)
* debian/compat: Bump to debhelper compat 8, the changelog of the
last version mention the upgrade but did not apply the compat level 
in the debian/compat file
* Add myself to Uploaders and Copyright
[ gregor herrmann ]
* debian/copyright: remove separate stanza for single file which is now
covered by the general copyright statement.
2011-03-23 - Jonathan Yu <jawnsy@cpan.org>
libmodule-extract-use-perl (0.18-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
* Use new 3.0 (quilt) source format
* Bump to debhelper compat 8
* Standards-Version 3.9.1 (no changes)
* Drop unnecessary versioned dependencies
[ Ryan Niebur ]
* Email change: Jonathan Yu -> jawnsy@cpan.org
* Email change: Ryan Niebur -> ryan@debian.org
[ gregor herrmann ]
* debian/control: remove versions from (build) dependencies that are already
satisfied in oldstable.
2009-08-22 - gregor herrmann <gregoa@debian.org>
libmodule-extract-use-perl (0.17-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
-> Cosmetic changes to META.yml (via META_MERGE magic)
* Updated copyright years
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ryan Niebur ]
* New upstream release, fixes failing test (closes: #543104)
* Debian Policy 3.8.3
[ Salvatore Bonaccorso ]
* debian/control: Changed: Replace versioned (build-)dependency on
perl (>= 5.6.0-{12,16}) with an unversioned dependency on perl (as
permitted by Debian Policy 3.8.3).
[ gregor herrmann ]
* Add /me to Uploaders.
2009-06-01 - Ryan Niebur <ryanryan52@gmail.com>
libmodule-extract-use-perl (0.15-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
-> Fix to detect 'use' AND compile-time 'require'
* Removed libtest-output-perl from Depends
* Added libtest-manifest-perl to B-D-I
* Removed quilt patch since Brian fixed this
* Added an example file
[ Ryan Niebur ]
* New upstream release
* Add myself to Uploaders
2009-04-29 - Jonathan Yu <frequency@cpan.org>
libmodule-extract-use-perl (0.13-1) unstable; urgency=low
* Initial Release. (Closes: #526196)

See Also

Package Description
libmodule-extractuse-perl_0.33-1_all.deb Perl module to find out modules used by the specified Perl source
libmodule-faker-perl_0.017-1_all.deb module to build fake dists for testing CPAN tools
libmodule-find-perl_0.12-1_all.deb module to find and use installed Perl modules
libmodule-implementation-perl_0.09-1_all.deb module for loading one of several alternate implementations of a module
libmodule-info-perl_0.35-1_all.deb Perl module providing information about Perl modules
libmodule-inspector-perl_1.05-2_all.deb integrated API for inspecting Perl distributions
libmodule-install-authorrequires-perl_0.02-1_all.deb declare author-only dependencies
libmodule-install-authortests-perl_0.002-1_all.deb designate tests only run by module authors
libmodule-install-autolicense-perl_0.08-1_all.deb automagically generate LICENSE files
libmodule-install-automanifest-perl_0.003-2_all.deb generate MANIFEST automatically
libmodule-install-contributors-perl_0.001-1_all.deb add an "x_contributors" section to your META.yml
libmodule-install-copyright-perl_0.009-1_all.deb package a COPYRIGHT file with a distribution
libmodule-install-doap-perl_0.006-1_all.deb generate META.yml data from DOAP
libmodule-install-doapchangesets-perl_0.206-1_all.deb write your distribution change log in RDF
libmodule-install-extratests-perl_0.008-1_all.deb contextual tests that the harness can ignore
Advertisement
Advertisement