libmodule-depends-perl_0.16-1_all.deb


Advertisement

Description

libmodule-depends-perl - Perl module to identify the dependencies of a distribution

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmodule-depends-perl
Package version: 0.16
Package release: 1
Package architecture: all
Package type: deb
Installed size: 18 B
Download size: 12.42 KB
Official Mirror: ftp.br.debian.org
Module::Depends extracts module dependencies from an unpacked distribution tree. Module::Depends only evaluates the {MY,}META.{json,yml} files shipped with a distribution. This won't be effective until all distributions ship such files, so you should look at Module::Depends::Intrusive.

Alternatives

    Download

    Source package: libmodule-depends-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmodule-depends-perl deb package:
      # sudo apt-get install libmodule-depends-perl

    Files

    • /usr/share/doc/libmodule-depends-perl/TODO.Debian
    • /usr/share/doc/libmodule-depends-perl/changelog.Debian.gz
    • /usr/share/doc/libmodule-depends-perl/changelog.gz
    • /usr/share/doc/libmodule-depends-perl/copyright
    • /usr/share/man/man3/Module::Depends.3pm.gz
    • /usr/share/man/man3/Module::Depends::Intrusive.3pm.gz
    • /usr/share/perl5/Module/Depends.pm
    • /usr/share/perl5/Module/Depends/Intrusive.pm

    Changelog

    2012-06-10 - intrigeri <intrigeri@debian.org> libmodule-depends-perl (0.16-1) unstable; urgency=low * Team upload. [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * debian/copyright: Replace DEP5 Format-Specification URL from svn.debian.org to anonscm.debian.org URL. [ intrigeri ] * Refresh set-environment-variables.patch. * Get refreshed cpan_meta.patch back. * Bump Standards-Version to 3.9.3 (no change required). * Update debian/copyright to nowadays standards, thanks to cme.

    2011-06-03 - gregor herrmann <gregoa@debian.org> libmodule-depends-perl (0.15-2) unstable; urgency=low [ gregor herrmann ] * Clean up the additional features added by our patches: - Combine patches yaml_xs.patch, meta_json.patch, and configure_test_requires.patch into new patch cpan_meta.patch. Update META.json test case. Use CPAN::META for parsing META.yml and META.json. - Drop support for test_requires for old META.yml syntax; test_requires never existed in the CPAN metadata specification. - Change (build) dependency from libyaml-libyaml-perl to libcpan-meta-perl. - Adjust long description (referred only to META.yml). - Closes: #609351. * Bump debhelper compatibility level to 8. [ Maximilian Gass ] * Bump Standards-Version to 3.9.2 (no changes necessary)

    2010-12-17 - gregor herrmann <gregoa@debian.org> libmodule-depends-perl (0.15-1) unstable; urgency=low [ Ryan Niebur ] * Take over for the Debian Perl Group * debian/control: Added: Vcs-Svn field (source stanza); Vcs-Browser field (source stanza); Homepage field (source stanza); ${misc:Depends} to Depends: field. Changed: Maintainer set to Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org> (was: James Bromberger <jeb@debian.org>). * debian/watch: use dist-based URL. * Switch to YAML::XS to support JSON META.ymls (Closes: #541159) * Look at META.json too (Closes: #541164) * look at configure_requires and test_requires as well (Closes: #541165) * use dh7 * set Standards-Version to 3.8.3 * fixup descriptions * machine readable copyright format * use Env::Sanctify to set some env variables in Intrusive [ gregor herrmann ] * debian/watch: remove call to uupdate. * New upstream release: fixes "Dies when Makefile.PL doesn't return a true value" (closes: #317061) * Switch to source format 3.0 (quilt). * debian/copyright: update years of upstream copyright and formatting. * Add /me to Uploaders. * Set Standards-Version to 3.9.1; remove ancient version from perl build dependency. * Refresh patches and add tests for two of them.

    2009-05-04 - James Bromberger <jeb@debian.org> libmodule-depends-perl (0.14-3) unstable; urgency=low * Fix watch file (again???!).

    2009-01-10 - James Bromberger <jeb@debian.org> libmodule-depends-perl (0.14-2) unstable; urgency=low * Remove dh-make-perl boilerplait (just the last lines). Closes: #507469.

    2008-07-26 - James Bromberger <jeb@debian.org> libmodule-depends-perl (0.14-1) unstable; urgency=low * New upstream release * Correct watch file to not get the wrong module (was matching Module::Tree) * Standards updated to 3.8.0; no changes required

    2005-07-26 - James Bromberger <jeb@debian.org> libmodule-depends-perl (0.10-1) unstable; urgency=low * New upstream release

    2005-02-25 - James Bromberger <jeb@debian.org> libmodule-depends-perl (0.07-1) unstable; urgency=low * New upstream release. * Moved ${misc:Depends} from control file.

    2004-07-13 - James Bromberger <jeb@debian.org> libmodule-depends-perl (0.05-2) unstable; urgency=low * Fixed dependency on libclass-accessor-chained-perl. Closes: #258743.

    2004-06-26 - James Bromberger <jeb@debian.org> libmodule-depends-perl (0.05-1) unstable; urgency=low * Initial Release. Closes: #256016.

    Advertisement
    Advertisement