libmodule-cpants-analyse-perl_0.95-1_all.deb


Advertisement

Description

libmodule-cpants-analyse-perl - Perl module to generate Kwalitee ratings for a distribution

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmodule-cpants-analyse-perl
Package version: 0.95
Package release: 1
Package architecture: all
Package type: deb
Installed size: 202 B
Download size: 72.00 KB
Official Mirror: ftp.br.debian.org
Module::CPANTS::Analyse is a utility module used by Test::Kwalitee and others to analyse CPAN distributions and determine their Kwalitee. Kwalitee is a set of software metrics useful for determine how good your software is; it's not true software quality, which your computer can't measure in a general sense. (If you can, you've solved a hard problem in computer science.) Kwalitee looks like quality, sounds like quality, but it's not quite quality. If you plan to release a distribution to the CPAN -- or even within your own organization -- testing its Kwalitee before creating a release can help you improve your quality as well.

    Download

    Source package: libmodule-cpants-analyse-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmodule-cpants-analyse-perl deb package:
      # sudo apt-get install libmodule-cpants-analyse-perl

    Files

    • /usr/share/doc/libmodule-cpants-analyse-perl/changelog.Debian.gz
    • /usr/share/doc/libmodule-cpants-analyse-perl/changelog.gz
    • /usr/share/doc/libmodule-cpants-analyse-perl/copyright
    • /usr/share/man/man3/Module::CPANTS::Analyse.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::BrokenInstaller.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::CpantsErrors.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::Distname.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::Distros.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::Files.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::FindModules.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::License.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::Manifest.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::MetaYML.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::NeedsCompiler.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::Pod.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::Prereq.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::Repackageable.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::Signature.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::Uses.3pm.gz
    • /usr/share/man/man3/Module::CPANTS::Kwalitee::Version.3pm.gz
    • /usr/share/perl5/Module/CPANTS/Analyse.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/BrokenInstaller.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/CpantsErrors.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/Distname.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/Distros.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/Files.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/FindModules.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/License.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/Manifest.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/MetaYML.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/NeedsCompiler.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/Pod.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/Prereq.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/Repackageable.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/Signature.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/Uses.pm
    • /usr/share/perl5/Module/CPANTS/Kwalitee/Version.pm

    Changelog

    2014-10-17 - gregor herrmann <gregoa@debian.org> libmodule-cpants-analyse-perl (0.95-1) unstable; urgency=medium [ gregor herrmann ] * Strip trailing slash from metacpan URLs. [ Salvatore Bonaccorso ] * Update Vcs-Browser URL to cgit web frontend [ gregor herrmann ] * Drop repacking framework, the files are gone in the new release. * Add debian/upstream/metadata * Import upstream version 0.95 * Drop 01-cpants-lint-rename.patch, patched file is gone. * debian/rules: back to 3 lines. Special casing for tests and (removed) script not needed anymore. * debian/copyright: add new upstream copyright holder. * Update years of packaging copyright. * Update (build) dependencies. * Declare compliance with Debian Policy 3.9.6.

    2013-09-23 - Salvatore Bonaccorso <carnil@debian.org> libmodule-cpants-analyse-perl (0.92+dfsg-1) unstable; urgency=low * Team upload. * Imported Upstream version 0.92+dfsg * Add alternative (build-)dependency for Module::Pluggable. Module::Pluggable will be removed from Perl core in 5.20 and emits now a warning with 5.18. This causes build failures in tests with 'no warning'. Also add the stricter dependency in Depends to avoid deprecation warnings at runtime. (Closes: #724237) * Switch alternatives for modules in core with version satisfied in perl 5.18

    2013-09-08 - Florian Schlichting <fsfs@debian.org> libmodule-cpants-analyse-perl (0.91+dfsg-1) unstable; urgency=low * Import Upstream version 0.91+dfsg

    2013-08-11 - Florian Schlichting <fsfs@debian.org> libmodule-cpants-analyse-perl (0.88+dfsg-1) unstable; urgency=low [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. * Update debian/repack.stub. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Florian Schlichting ] * Import Upstream version 0.88+dfsg (closes: #542401). * Bump Standards-Version to 3.9.4 (no change). * Update (build-)dependencies. * Drop 02-cpantserrors-pod.patch, applied upstream. * Drop 03-yaml.patch, YAML::Any is now available in libyaml-perl. * Do not run t/11_hash_random.t as it depends on removed example archive. * Add myself to uploaders and copyright.

    2012-06-08 - gregor herrmann <gregoa@debian.org> libmodule-cpants-analyse-perl (0.86+dfsg-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * New upstream release. * Drop patch 03-test-yaml-meta_test-cpan-meta.patch (applied upstream); refresh remaining patches. * Update build/runtime dependencies. * Add patch to use YAML::Syck again (no YAML::Any in Debian); adjust dependencies. * Skip more tests that would need the removed tarballs. * Remove unused lintian override. * debian/copyright: update maintainer, upstream & packaging copyright. * debian/copyright: update to Copyright-Format 1.0. * Bump Standards-Version to 3.9.3 (no changes).

    Advertisement
    Advertisement