libmodplug-dev_0.8.8.4-4.1_all.deb


Advertisement

Description

libmodplug-dev - development files for mod music based on ModPlug

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmodplug-dev
Package version: 0.8.8.4
Package release: 4.1
Package architecture: all
Package type: deb
Installed size: 95 B
Download size: 25.20 KB
Official Mirror: ftp.br.debian.org
Module files (MOD music, tracker music) are a family of music file formats originating from the MOD file format on Amiga systems used in late 1980s. This package contains the header files and .so symlinks required to compile code against libmodplug, a library based on the mod rendering code from ModPlug, a popular Windows mod player written by Olivier Lapicque, found at http://www.modplug.com.

Alternatives

Conflicts

  • xmms-modplug << 2.04-1

Replaces

  • xmms-modplug << 2.04-1

    Download

    Source package: libmodplug

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmodplug-dev deb package:
      # sudo apt-get install libmodplug-dev

    Files

    • /usr/include/libmodplug/it_defs.h
    • /usr/include/libmodplug/modplug.h
    • /usr/include/libmodplug/sndfile.h
    • /usr/include/libmodplug/stdafx.h
    • /usr/lib/libmodplug.so
    • /usr/lib/pkgconfig/libmodplug.pc
    • /usr/share/doc/libmodplug-dev/changelog.Debian.gz
    • /usr/share/doc/libmodplug-dev/changelog.gz
    • /usr/share/doc/libmodplug-dev/copyright

    Changelog

    2014-03-08 - Eric Dorland <eric@debian.org> libmodplug (1:0.8.8.4-4.1) unstable; urgency=medium * Non-maintainer upload. * debian/control: Switch to automake1.11. (Closes: #724407)

    2013-09-02 - Zed Pobre <zed@debian.org> libmodplug (1:0.8.8.4-4) unstable; urgency=high * Merge all changes from latest upstream Git repository (0.8.8.4 with additional patches), including the following security changes: * CVE-2013-4233: fix integer overflow in load_abc.cpp * CVE-2013-4234: fix heap overflows in abc_MIDI_drum and abc_MIDI_gchord * Closes: #719642 * Standards-Version: 3.9.4 * Added Vcs-Git and Vcs-Browser entries

    2012-04-09 - Zed Pobre <zed@debian.org> libmodplug (1:0.8.8.4-3) unstable; urgency=low * Fix missing backslash on dpkg-buildflags line (closes: #654817)

    2012-04-06 - Zed Pobre <zed@debian.org> libmodplug (1:0.8.8.4-2) unstable; urgency=low * Enable hardened build flags via dpkg-buildflags (closes: #654817) This requires dpkg-buildflags from the dpkg-dev package to be at least version 1.16.1 (when the --export=configure flag was defined)

    2011-09-05 - Zed Pobre <zed@debian.org> libmodplug (1:0.8.8.4-1) unstable; urgency=high * New upstream version * Fixes buffer overflow in load_abc (CVE-2011-1761, closes: #625966) * Fixes integer overflow in load_wav (SA45131.1) * Fixes stack overflow in load_s3m (SA45131.2) * Fixes off-by-one errors in load_ams and load_dms that can cause stack and memory corruption (SA45131.3-5) * Added a few lines to the package description describing what mod music is. (closes: #637854) * Allow CC and CXX to contain spaces in debian/rules (closes: #636863) * Standards-Version: 3.9.2

    2011-04-28 - Zed Pobre <zed@debian.org> libmodplug (1:0.8.8.2-3) unstable; urgency=medium * Remove redundant AM_SILENT_RULES macro outside of the ifdef to prevent breaking builds on many platforms (closes: #624403)

    2011-04-27 - Zed Pobre <zed@debian.org> libmodplug (1:0.8.8.2-2) unstable; urgency=low * Removed outdated references to xmms-modplug package (closes: #624300)

    2011-04-14 - Zed Pobre <zed@debian.org> libmodplug (1:0.8.8.2-1) unstable; urgency=high * New upstream version * Fixes buffer overflow in ReadS3M function (SEC Consult SA-20110407-0)

    2010-09-11 - Zed Pobre <zed@debian.org> libmodplug (1:0.8.8.1-2) unstable; urgency=low * libmodplug-dev no longer depends on libstdc++-dev (which should have been unnecessary since the move of -lstdc++ to Libs.private in 0.8.4-2). Closes: #596463 * Standards-Version: 3.9.1 (no changes needed)

    2010-07-18 - Zed Pobre <zed@debian.org> libmodplug (1:0.8.8.1-1) unstable; urgency=high * New upstream version * 0.8.8 introduced an ABI change without updating the major version. This was causing potential problems in clients linked against libmodplug0c2, including silence. This version changes the binary package from libmodplug0c2 to libmodplug1, so all related applications will have to be recompiled to use a version greater than is in Lenny (0.8.4). Closes: #588465 * debian/copyright updated with additional contributors and the license description properly set to public domain

    Advertisement
    Advertisement