libmlx4-1_1.0.6-1_i386.deb


Advertisement

Description

libmlx4-1 - Userspace driver for Mellanox ConnectX InfiniBand HCAs

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmlx4-1
Package version: 1.0.6
Package release: 1
Package architecture: i386
Package type: deb
Installed size: 71 B
Download size: 15.68 KB
Official Mirror: ftp.br.debian.org
libmlx4 is a device-specific driver for Mellanox ConnectX InfiniBand host channel adapters (HCAs) for the libibverbs library. This allows userspace processes to access Mellanox HCA hardware directly with low latency and low overhead. This package contains the loadable plug-in.

Alternatives

    Download

    Source package: libmlx4

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmlx4-1 deb package:
      # sudo apt-get install libmlx4-1

    Files

    • /etc/libibverbs.d/mlx4.driver
    • /usr/lib/libibverbs/libmlx4-rdmav2.so
    • /usr/share/doc/libmlx4-1/changelog.Debian.gz
    • /usr/share/doc/libmlx4-1/copyright

    Changelog

    2014-05-06 - Roland Dreier <rbd@debian.org> libmlx4 (1.0.6-1) unstable; urgency=low * New upstream release. - Depend on libibverbs 1.1.8 for new verbs extensions API. - Flow steering support. * Use dh-autoreconf to fix FTBFS on ppc64el (Closes: #733843). * Update to Standards-Version: 3.9.5.

    2013-05-30 - Roland Dreier <rbd@debian.org> libmlx4 (1.0.5-1) unstable; urgency=low * New upstream release. - Raw (ethernet) QP support. - 64-byte completion queue entry support.

    2012-03-28 - Roland Dreier <rbd@debian.org> libmlx4 (1.0.4-1) unstable; urgency=low * New upstream release. - IBoE multicast support. * Update maintainer and remove DM-Upload-Allowed now that I'm a DD.

    2011-07-06 - Roland Dreier <roland@digitalvampire.org> libmlx4 (1.0.3-1) unstable; urgency=low * New upstream release. - Add ConnectX-3 support. - Add IBoE support. * Since we have plugin in /usr/lib/libibverbs, we need to depend on libibverbs (>= 1.1.3).

    2011-07-06 - Roland Dreier <roland@digitalvampire.org> libmlx4 (1.0.2-1) unstable; urgency=low * New upstream release. - Fix potential problems running under Valgrind. - Add support for resize CQ operation. - Fix other minor bugs. * Update maintainer and set DM-Upload-Allowed to yes. (Closes: #632108) * Switch to dpkg-source 3.0 (quilt) format. * Acknowledge NMU (Closes: #621664). * Change build system from cdbs to debhelper 7. * Use libibverbs 1.1.3 feature to move plugin to /usr/lib/libibverbs to fix multiple problems with a not-exactly-shlib in /usr/lib. * Add debian/watch file. * Move -dbg package to section debug. * Update to Standards-Version: 3.9.2.

    2011-07-01 - Luk Claes <luk@debian.org> libmlx4 (1.0-1.1) unstable; urgency=low * Non-maintainer upload. * Don't ship .la files (Closes: #621664).

    2007-12-14 - Roland Dreier <rolandd@cisco.com> libmlx4 (1.0-1) unstable; urgency=low * Initial release. (Closes: #456355)

    Advertisement
    Advertisement