libmixin-linewise-perl_0.106-1_all.deb


Advertisement

Description

libmixin-linewise-perl - module to handle general file input/output operations

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmixin-linewise-perl
Package version: 0.106
Package release: 1
Package architecture: all
Package type: deb
Installed size: 69 B
Download size: 14.07 KB
Official Mirror: ftp.br.debian.org
Mixin::Linewise is a Perl module that provides a generalized framework for handling input/output operations. It can open files for I/O, convert strings to handle type objects, and more. With Reader and Writer classes, you can just write a method to manipulate normal handles, and let the modules do the rest, like providing string and filename handling methods.

Alternatives

    Download

    Source package: libmixin-linewise-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmixin-linewise-perl deb package:
      # sudo apt-get install libmixin-linewise-perl

    Files

    • /usr/share/doc/libmixin-linewise-perl/changelog.Debian.gz
    • /usr/share/doc/libmixin-linewise-perl/changelog.gz
    • /usr/share/doc/libmixin-linewise-perl/copyright
    • /usr/share/man/man3/Mixin::Linewise.3pm.gz
    • /usr/share/man/man3/Mixin::Linewise::Readers.3pm.gz
    • /usr/share/man/man3/Mixin::Linewise::Writers.3pm.gz
    • /usr/share/perl5/Mixin/Linewise.pm
    • /usr/share/perl5/Mixin/Linewise/Readers.pm
    • /usr/share/perl5/Mixin/Linewise/Writers.pm

    Changelog

    2014-03-15 - Florian Schlichting <fsfs@debian.org> libmixin-linewise-perl (0.106-1) unstable; urgency=medium [ Florian Schlichting ] * Import Upstream version 0.105, 0.106 * Add (build-)dependency on PerlIO::utf8_strict [ gregor herrmann ] * Strip trailing slash from metacpan URLs.

    2013-12-24 - Florian Schlichting <fsfs@debian.org> libmixin-linewise-perl (0.104-1) unstable; urgency=medium * Import Upstream version 0.104 * Drop (build-)dependency on IO::Scalar

    2013-11-23 - Florian Schlichting <fsfs@debian.org> libmixin-linewise-perl (0.102-1) unstable; urgency=low * Import Upstream version 0.102 * Fix dependency on Test::More * Declare compliance with Debian Policy 3.9.5

    2013-10-03 - Florian Schlichting <fsfs@debian.org> libmixin-linewise-perl (0.004-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ gregor herrmann ] * debian/control: update {versioned,alternative} (build) dependencies. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs [ Axel Beckert ] * debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg- copyright" [ Florian Schlichting ] * Import Upstream version 0.004 * Delete copyright paragraph for inc/*, upstream switched from M::I to dzil * Update stand-alone license paragraphs to commonly used version (not limiting Debian to GNU/Linux, directly linking to GPL-1) * Add a build-dependency on Test::More 0.96 * Bump dh compatibility to level 8 (no changes necessary) * Declare compliance with Debian Policy 3.9.4 * Switch to source format 3.0 (quilt) * Add myself to uploaders and copyright

    2010-02-15 - Jonathan Yu <jawnsy@cpan.org> libmixin-linewise-perl (0.003-1) unstable; urgency=low * New upstream release * Standards-Version 3.8.4 (no changes) * Rewrite control description * Now requires Test::Simple 0.88 for done_testing * Update copyright to new DEP5 format * Refresh years of copyright

    2009-10-24 - Jonathan Yu <jawnsy@cpan.org> libmixin-linewise-perl (0.002-1) unstable; urgency=low * Initial Release (Closes: #552241)

    Advertisement
    Advertisement