libmime-tools-perl_5.505-1_all.deb


Advertisement

Description

libmime-tools-perl - Perl5 modules for MIME-compliant messages

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmime-tools-perl
Package version: 5.505
Package release: 1
Package architecture: all
Package type: deb
Installed size: 517 B
Download size: 220.66 KB
Official Mirror: ftp.br.debian.org
This package provides the MIME-tools modules. MIME-tools is a collection of Perl5 MIME:: modules for parsing, decoding, and generating single- or multipart (even nested multipart) MIME messages.

Alternatives

Provides

  • libmime-perl

Replaces

  • libmime-perl << 5.425-2

    Download

    Source package: libmime-tools-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmime-tools-perl deb package:
      # sudo apt-get install libmime-tools-perl

    Files

    • /usr/share/doc/libmime-tools-perl/TODO.Debian
    • /usr/share/doc/libmime-tools-perl/changelog.Debian.gz
    • /usr/share/doc/libmime-tools-perl/changelog.gz
    • /usr/share/doc/libmime-tools-perl/copyright
    • /usr/share/doc/libmime-tools-perl/examples/README
    • /usr/share/doc/libmime-tools-perl/examples/mimeabuse
    • /usr/share/doc/libmime-tools-perl/examples/mimedump
    • /usr/share/doc/libmime-tools-perl/examples/mimeencode
    • /usr/share/doc/libmime-tools-perl/examples/mimeexplode
    • /usr/share/doc/libmime-tools-perl/examples/mimepostcard
    • /usr/share/doc/libmime-tools-perl/examples/mimeprint
    • /usr/share/doc/libmime-tools-perl/examples/mimeref
    • /usr/share/doc/libmime-tools-perl/examples/mimesend
    • /usr/share/doc/libmime-tools-perl/examples/mimesender
    • /usr/share/doc/libmime-tools-perl/examples/mimetour
    • /usr/share/man/man3/MIME::Body.3pm.gz
    • /usr/share/man/man3/MIME::Decoder.3pm.gz
    • /usr/share/man/man3/MIME::Decoder::Base64.3pm.gz
    • /usr/share/man/man3/MIME::Decoder::BinHex.3pm.gz
    • /usr/share/man/man3/MIME::Decoder::Binary.3pm.gz
    • /usr/share/man/man3/MIME::Decoder::Gzip64.3pm.gz
    • /usr/share/man/man3/MIME::Decoder::NBit.3pm.gz
    • /usr/share/man/man3/MIME::Decoder::QuotedPrint.3pm.gz
    • /usr/share/man/man3/MIME::Decoder::UU.3pm.gz
    • /usr/share/man/man3/MIME::Entity.3pm.gz
    • /usr/share/man/man3/MIME::Field::ConTraEnc.3pm.gz
    • /usr/share/man/man3/MIME::Field::ContDisp.3pm.gz
    • /usr/share/man/man3/MIME::Field::ContType.3pm.gz
    • /usr/share/man/man3/MIME::Field::ParamVal.3pm.gz
    • /usr/share/man/man3/MIME::Head.3pm.gz
    • /usr/share/man/man3/MIME::Parser.3pm.gz
    • /usr/share/man/man3/MIME::Parser::Filer.3pm.gz
    • /usr/share/man/man3/MIME::Parser::Reader.3pm.gz
    • /usr/share/man/man3/MIME::Parser::Results.3pm.gz
    • /usr/share/man/man3/MIME::Tools.3pm.gz
    • /usr/share/man/man3/MIME::WordDecoder.3pm.gz
    • /usr/share/man/man3/MIME::Words.3pm.gz
    • /usr/share/perl5/MIME/Body.pm
    • /usr/share/perl5/MIME/Decoder.pm
    • /usr/share/perl5/MIME/Entity.pm
    • /usr/share/perl5/MIME/Head.pm
    • /usr/share/perl5/MIME/Parser.pm
    • /usr/share/perl5/MIME/Tools.pm
    • /usr/share/perl5/MIME/WordDecoder.pm
    • /usr/share/perl5/MIME/Words.pm
    • /usr/share/perl5/MIME/Decoder/Base64.pm
    • /usr/share/perl5/MIME/Decoder/BinHex.pm
    • /usr/share/perl5/MIME/Decoder/Binary.pm
    • /usr/share/perl5/MIME/Decoder/Gzip64.pm
    • /usr/share/perl5/MIME/Decoder/NBit.pm
    • /usr/share/perl5/MIME/Decoder/QuotedPrint.pm
    • /usr/share/perl5/MIME/Decoder/UU.pm
    • /usr/share/perl5/MIME/Field/ConTraEnc.pm
    • /usr/share/perl5/MIME/Field/ContDisp.pm
    • /usr/share/perl5/MIME/Field/ContType.pm
    • /usr/share/perl5/MIME/Field/ParamVal.pm
    • /usr/share/perl5/MIME/Parser/Filer.pm
    • /usr/share/perl5/MIME/Parser/Reader.pm
    • /usr/share/perl5/MIME/Parser/Results.pm

    Changelog

    2013-12-02 - Salvatore Bonaccorso <carnil@debian.org> libmime-tools-perl (5.505-1) unstable; urgency=low * Imported Upstream version 5.505 - clarifies MIME PRIMER location in manpage (Closes: #460394) * Update copyright years for included Module::Install copy * Drop fix-spelling.patch patch (applied upstream) * Bump Standards-Version to 3.9.5 * Wrap and sort fields in debian/control file

    2013-10-17 - Salvatore Bonaccorso <carnil@debian.org> libmime-tools-perl (5.504-1) unstable; urgency=low * Imported Upstream version 5.504 - Addresses problem with otrs2: "-e: open body: Invalid argument at /usr/share/perl5/MIME/Entity.pm line 1878." (Closes: #726600). * Change Vcs-Git to canonical URI (git://anonscm.debian.org) * Change search.cpan.org based URIs to metacpan.org based URIs * Bump Standards-Version to 3.9.4 * Update copyright years for debian/* packaging files

    2012-06-08 - Salvatore Bonaccorso <carnil@debian.org> libmime-tools-perl (5.503-1) unstable; urgency=low [ Ansgar Burchardt ] * debian/control: Convert Vcs-* fields to Git. [ Salvatore Bonaccorso ] * Imported Upstream version 5.503 * Update debian/copyright file. Update format to copyright-format 1.0 as released together with Debian policy 3.9.3. Update copyright years for debian/* packaging files. * Refresh fix-spelling.patch patch (offset) * Bump Standards-Version to 3.9.3

    2011-03-12 - Salvatore Bonaccorso <carnil@debian.org> libmime-tools-perl (5.502-1) unstable; urgency=low * New upstream release * Drop fix-614545-MIME-Words-decode-newlines.patch as it was applied upstream. * Bump Debhelper compat level to 8. * debian/control: Bump versioned Build-Depends on debhelper to (>= 8).

    2011-02-23 - Salvatore Bonaccorso <carnil@debian.org> libmime-tools-perl (5.501-2) unstable; urgency=low * Add fix-614545-MIME-Words-decode-newlines.patch patch to fix decoding newlines in input of MIME::Words. (Closes: #614545).

    2011-02-18 - Salvatore Bonaccorso <carnil@debian.org> libmime-tools-perl (5.501-1) unstable; urgency=low * New upstream release - Fix inappropriate inclusion of CR characters in parsed headers (Closes: #613887) * Add myself to Uploaders * debian/copyright: Refresh debian/* stanza. * Refresh spelling.patch to fix-spelling.pach. Not all the fixes where applied upstream.

    2011-01-08 - Nicholas Bamber <nicholas@periapt.co.uk> libmime-tools-perl (5.500-1) unstable; urgency=low [ gregor herrmann ] * Set Standards-Version to 3.9.1; replace Conflicts with Breaks. [ Nicholas Bamber ] * Added myself to Uploaders * New upstream release * Updated dependencies * Refreshed copyright * Refreshed and forwarded patch [ Ansgar Burchardt ] * Make (build-)dep on perl unversioned.

    2010-06-12 - gregor herrmann <gregoa@debian.org> libmime-tools-perl (5.428-1) unstable; urgency=low [ Jonathan Yu ] * updated gregor's e-mail address * Removed Alexis Sukrieh from Uploaders (Closes: #536142) * Refresh to new debhelper 7 short rules format * Use a clean file instead of overriding dh_clean * Standards-Version 3.8.3 (no changes) * Add myself to Uploaders [ gregor herrmann ] * Drop transitional dummy package libmime-perl now that lenny is released. * Rename source package to libmime-tools-perl. * debian/control: Changed: (build-)depend on perl instead of perl- modules. * debian/control: Changed: Switched Vcs-Browser field to ViewSVN (source stanza). * debian/control: Added: ${misc:Depends} to Depends: field. * New upstream release. * Convert to source format 3.0 (quilt). * Update (build) dependencies. * Set Standards-Version to 3.8.4 (no changes). * Refresh formatting in debian/copyright. * Add a patch to fix spelling mistakes.

    2008-11-14 - Damyan Ivanov <dmn@debian.org> mime-tools (5.427-2) unstable; urgency=low * remove libfile-temp-perl alternative (build-)dependency. Closes: #505645: build-depends alternative on obsolete libfile-temp-perl

    Advertisement
    Advertisement