libmikmod-dev_3.3.7-1_i386.deb


Advertisement

Description

libmikmod-dev - Portable sound library - development files

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libmikmod-dev
Package version 3.3.7
Package release 1
Package architecture i386
Package type deb
Installed size 701 B
Download size 213.68 KB
Official Mirror ftp.br.debian.org
This library is capable of playing samples as well as module files
and was originally written by Jean-Paul Mikkers (MikMak) for DOS. It
has subsequently been hacked by many hands and now runs on many Unix
flavours.
It supports OSS, ALSA, SDL and PulseAudio outputs, and can also write
to disk in raw, WAV and AIFF formats.
Supported file formats include mod, stm, s3m, mtm, xm, and it.
This package contains the symlinks, headers, and object files needed
to compile and link programs which use libmikmod.

Alternatives

Package Version Architecture Repository
libmikmod-dev_3.3.7-1_amd64.deb 3.3.7 amd64 Debian Main
libmikmod-dev - - -

Requires

Name Value
libc6-dev -
libmikmod-config -
libmikmod3 = 3.3.7-1

Provides

Name Value
libmikmod2-dev -

Conflicts

Name Value
libmikmod2-dev -

Download

Type URL
Binary Package libmikmod-dev_3.3.7-1_i386.deb
Source Package libmikmod

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmikmod-dev deb package:
    # sudo apt-get install libmikmod-dev

Files

Path
/usr/include/mikmod.h
/usr/lib/i386-linux-gnu/libmikmod.a
/usr/lib/i386-linux-gnu/libmikmod.so
/usr/lib/i386-linux-gnu/pkgconfig/libmikmod.pc
/usr/share/aclocal/libmikmod.m4
/usr/share/doc-base/libmikmod
/usr/share/doc/libmikmod-dev/AUTHORS.gz
/usr/share/doc/libmikmod-dev/README.gz
/usr/share/doc/libmikmod-dev/TODO
/usr/share/doc/libmikmod-dev/changelog.Debian.gz
/usr/share/doc/libmikmod-dev/changelog.gz
/usr/share/doc/libmikmod-dev/copyright
/usr/share/doc/libmikmod-dev/mikmod.html
/usr/share/info/mikmod.info.gz

Changelog

2014-09-07 - Stephen Kitt <skitt@debian.org>
libmikmod (3.3.7-1) unstable; urgency=medium
* New upstream version.
2014-07-24 - Stephen Kitt <skitt@debian.org>
libmikmod (3.3.6-4) unstable; urgency=medium
* We no longer need to forcibly remove configure.ac.
* Break and replace libmikmod2-dev (closes: #755920). Thanks to Sylvain
Boilard for noticing!
2014-06-29 - Stephen Kitt <skitt@debian.org>
libmikmod (3.3.6-3) unstable; urgency=medium
* Use CMake correctly to install everything in the right place; thanks
to Gert Wollny and Daniel Lintott for the instructions!
* Drop EsounD support since it is now obsolete in Debian (closes:
#753123). Thanks to Adrian Bunk for the prodding!
2014-04-14 - Stephen Kitt <skitt@debian.org>
libmikmod (3.3.6-2) unstable; urgency=medium
* Add collab-maint repository URIs.
* Install libmikmod.pc.
2014-04-12 - Stephen Kitt <skitt@debian.org>
libmikmod (3.3.6-1) unstable; urgency=medium
* New upstream version.
* Update patches:
- drop 0002-dlopen-libesd.so.0-rather-than-libesd.so.patch, handled
upstream;
- refresh
0014-playercode-mdreg-Register-the-NULL-driver-before-the.patch.
* Move libmikmod-config to its own package (closes: #735206).
2014-03-18 - Stephen Kitt <skitt@debian.org>
libmikmod (3.3.5-3) unstable; urgency=medium
* Upload to unstable.
2014-03-17 - Stephen Kitt <skitt@debian.org>
libmikmod (3.3.5-2) experimental; urgency=medium
* Make libmikmod-dev provide libmikmod2-dev, to make the transition
easier.
2014-01-12 - Stephen Kitt <skitt@debian.org>
libmikmod (3.3.5-1) experimental; urgency=medium
* New upstream version.
* Update patches:
- refresh
0014-playercode-mdreg-Register-the-NULL-driver-before-the.patch;
- drop 0015-fix-texinfo-infox-after-info-error.patch, merged
upstream.
* Enable pulseaudio support.
* Only build-depend on libasound2-dev on Linux platforms.
* Update description and stop suggesting compatibility packages, now
that libmikmod supports modern sound output.
2013-12-16 - Stephen Kitt <skitt@debian.org>
libmikmod (3.3.4-2) experimental; urgency=medium
* Forcibly disable ALSA on non-Linux platforms.
2013-12-10 - Stephen Kitt <skitt@debian.org>
libmikmod (3.3.4-1) experimental; urgency=low
* New maintainer (closes: #728593).
* New upstream version (closes: #672697), with a new soname: libmikmod2
becomes libmikmod3.
* Upload to experimental to prepare the library transition.
* Ship the -dev package as libmikmod-dev.
* Update patches:
- drop 0001-Drop-LIBOBJS-from-configure.in.patch, obsolete
- drop 0003-Use-_LP64-to-detect-64bit-arches.patch, integrated
upstream
- drop 0004-CVE-2009-0179.patch, integrated upstream
- drop 0005-CVE-2007-6720.patch, integrated upstream
- drop 0006-CVE-2009-3995f.patch, fixed in another way upstream
- drop 0007-CVE-2010-2546.patch, integrated upstream
- drop 0008-Fix-libmikmod-Makefile.in.patch, obsolete
- drop 0009-libmikmod-Makefile.in-Respect-CPPFLAGS-and-LDFLAGS.patch,
obsolete
- drop 0010-libmikmod-config-manual-page-fix.patch, integrated
upstream
- drop 0011-Disable-ALSA-by-default.patch, obsolete
- drop 0012-fix-ESD.patch, integrated upstream
- drop 0013-fix-building-of-ESD.patch, obsolete
- update
0014-playercode-mdreg-Register-the-NULL-driver-before-the.patch
- add 0015-fix-texinfo-infox-after-info-error.patch to fix build
errors with texinfo 5.
* Add symbols file.
* Force cmake usage as recommended upstream:
- delete configure.ac;
- stop using dh-autoreconf;
- manually move the appropriate files to multi-arch locations;
- manually install the libmikmod-config manpage;
- forcibly disable RPATH.
* Enable ALSA, OpenAL and SDL audio outputs.
* Add watch file.
* Drop the VCS URIs for now.
* Standards-Version 3.9.5, no further change required.

See Also

Package Description
libmikmod3_3.3.7-1_i386.deb Portable sound library
libmilter-dev_8.14.4-8+deb8u2_i386.deb Sendmail Mail Filter API (Milter) (development files)
libmilter1.0.1_8.14.4-8+deb8u2_i386.deb Sendmail Mail Filter API (Milter)
libmime-base32-perl_1.02a-1_all.deb Base32 encoder/decoder
libmime-base64-urlsafe-perl_0.01-1_all.deb Perl version of Python's URL-safe base64 codec
libmime-charset-perl_1.011.1-1+deb8u2_all.deb module for MIME character set information
libmime-encwords-perl_1.014.3-1+deb8u1_all.deb Perl interface to deal with RFC 2047 encoded words
libmime-explode-perl_0.39-3+b1_i386.deb Perl extension to explode MIME messages
libmime-lite-html-perl_1.24-1_all.deb Transform HTML page into MIME email
libmime-lite-perl_3.030-2_all.deb module for convenient MIME message creation
libmime-tools-perl_5.505-1_all.deb Perl5 modules for MIME-compliant messages
libmime-types-perl_2.09-3_all.deb Perl extension for determining MIME types and Transfer Encoding
libmimedir-dev_0.5.1-4_i386.deb Developer files for libmimedir
libmimedir0_0.5.1-4_i386.deb Library to parse RFC 2425 Directory Information blocks
libmimelib1-dev_1.1.4-2_i386.deb mime library - development
Advertisement
Advertisement