libmiglayout-java_4.2-1_all.deb


Advertisement

Description

libmiglayout-java - Java Layout Manager

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libmiglayout-java
Package version 4.2
Package release 1
Package architecture all
Package type deb
Installed size 307 B
Download size 95.61 KB
Official Mirror ftp.br.debian.org
MiGLayout is a superbly versatile SWT/Swing layout manager that makes
layout problems trivial. It is using String or API type-checked
constraints to format the layout. MiGLayout can produce flowing, grid
based, absolute (with links), grouped and docking layouts. MiGLayout
is created to be to manually coded layouts what Matisse/GroupLayout
is to IDE supported visual layouts.

Alternatives

Package Version Architecture Repository
libmiglayout-java_4.2-1_all.deb 4.2 all Debian Main
libmiglayout-java - - -

Download

Type URL
Binary Package libmiglayout-java_4.2-1_all.deb
Source Package libmiglayout-java

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmiglayout-java deb package:
    # sudo apt-get install libmiglayout-java

Files

Path
/usr/share/doc/libmiglayout-java/changelog.Debian.gz
/usr/share/doc/libmiglayout-java/copyright
/usr/share/java/miglayout-4.2.jar
/usr/share/java/miglayout-core-4.2.jar
/usr/share/java/miglayout-core.jar
/usr/share/java/miglayout-ideutil-4.2.jar
/usr/share/java/miglayout-ideutil.jar
/usr/share/java/miglayout-swing-4.2.jar
/usr/share/java/miglayout-swing.jar
/usr/share/java/miglayout-swt-4.2.jar
/usr/share/java/miglayout-swt.jar
/usr/share/java/miglayout.jar
/usr/share/maven-repo/com/miglayout/miglayout-core/4.2/miglayout-core-4.2.jar
/usr/share/maven-repo/com/miglayout/miglayout-core/4.2/miglayout-core-4.2.pom
/usr/share/maven-repo/com/miglayout/miglayout-core/debian/miglayout-core-debian.jar
/usr/share/maven-repo/com/miglayout/miglayout-core/debian/miglayout-core-debian.pom
/usr/share/maven-repo/com/miglayout/miglayout-ideutil/4.2/miglayout-ideutil-4.2.jar
/usr/share/maven-repo/com/miglayout/miglayout-ideutil/4.2/miglayout-ideutil-4.2.pom
/usr/share/maven-repo/com/miglayout/miglayout-ideutil/debian/miglayout-ideutil-debian.jar
/usr/share/maven-repo/com/miglayout/miglayout-ideutil/debian/miglayout-ideutil-debian.pom
/usr/share/maven-repo/com/miglayout/miglayout-parent/4.2/miglayout-parent-4.2.pom
/usr/share/maven-repo/com/miglayout/miglayout-parent/debian/miglayout-parent-debian.pom
/usr/share/maven-repo/com/miglayout/miglayout-swing/4.2/miglayout-swing-4.2.jar
/usr/share/maven-repo/com/miglayout/miglayout-swing/4.2/miglayout-swing-4.2.pom
/usr/share/maven-repo/com/miglayout/miglayout-swing/debian/miglayout-swing-debian.jar
/usr/share/maven-repo/com/miglayout/miglayout-swing/debian/miglayout-swing-debian.pom
/usr/share/maven-repo/com/miglayout/miglayout-swt/4.2/miglayout-swt-4.2.jar
/usr/share/maven-repo/com/miglayout/miglayout-swt/4.2/miglayout-swt-4.2.pom
/usr/share/maven-repo/com/miglayout/miglayout-swt/debian/miglayout-swt-debian.jar
/usr/share/maven-repo/com/miglayout/miglayout-swt/debian/miglayout-swt-debian.pom

Changelog

2014-03-11 - Emmanuel Bourg <ebourg@apache.org>
libmiglayout-java (4.2-1) unstable; urgency=medium
* Team upload.
* New upstream release
* Build with maven-debian-helper and install the Maven artifacts
* Download the new releases from code.google.com
* debian/control:
- Added a suggested dependency on libswt-gtk-3-java
- Removed the build dependency on substance
- Standards-Version updated to 3.9.5 (no changes)
- Use canonical URLs for the Vcs-* fields
* Switch to debhelper level 9
* Use XZ compression for the upstream tarball
2011-07-27 - Andrew Ross <ubuntu@rossfamily.co.uk>
libmiglayout-java (3.7.4-2) unstable; urgency=low
* Replace libswt-gtk-3.6-java with libswt-gtk-3-java
2011-06-08 - Andrew Ross <ubuntu@rossfamily.co.uk>
libmiglayout-java (3.7.4-1) unstable; urgency=low
* New upstream release.
* Replace libswt-gtk-3.5-java with libswt-gtk-3.6-java (Closes: #629721)
* Bumped standards version to 3.9.2 (no changes)
* Drop dependency on jre.
* Added debian/source/format file
* Removed reference to /usr/share/common-licenses/BSD as it is no
longer included.
2010-01-24 - Varun Hiremath <varun@debian.org>
libmiglayout-java (3.7.2-1) unstable; urgency=low
* New upstream release
* debian/control: replace libswt-gtk-3.4-java with libswt-gtk-3.5-java,
fixes build (Closes: #564387)
2009-08-31 - Varun Hiremath <varun@debian.org>
libmiglayout-java (3.7.1-2) unstable; urgency=low
* debian/rules: DEB_JARS use swt.jar provided using alternatives in
/usr/share/java instead of the versioned jar in /usr/lib/java
2009-08-24 - Varun Hiremath <varun@debian.org>
libmiglayout-java (3.7.1-1) unstable; urgency=low
* New upstream release
* Build-Depends: Replace libswt3.2-gtk-java with libswt-gtk-3.4-java,
fixes FTBFS (Closes: #543129)
* Bump Standards-Version to 3.8.3
2009-05-25 - Varun Hiremath <varun@debian.org>
libmiglayout-java (3.7-1) unstable; urgency=low
* Initial release (Closes: #530490)

See Also

Package Description
libmikmatch-ocaml-dev_1.0.7-1_i386.deb camlp4 extension for pattern matching with regexps - development
libmikmatch-ocaml_1.0.7-1_i386.deb camlp4 extension for pattern matching with regexps - runtime
libmikmod-config_3.3.7-1_i386.deb Portable sound library - development binaries
libmikmod-dev_3.3.7-1_i386.deb Portable sound library - development files
libmikmod3_3.3.7-1_i386.deb Portable sound library
libmilter-dev_8.14.4-8+deb8u2_i386.deb Sendmail Mail Filter API (Milter) (development files)
libmilter1.0.1_8.14.4-8+deb8u2_i386.deb Sendmail Mail Filter API (Milter)
libmime-base32-perl_1.02a-1_all.deb Base32 encoder/decoder
libmime-base64-urlsafe-perl_0.01-1_all.deb Perl version of Python's URL-safe base64 codec
libmime-charset-perl_1.011.1-1+deb8u2_all.deb module for MIME character set information
libmime-encwords-perl_1.014.3-1+deb8u1_all.deb Perl interface to deal with RFC 2047 encoded words
libmime-explode-perl_0.39-3+b1_i386.deb Perl extension to explode MIME messages
libmime-lite-html-perl_1.24-1_all.deb Transform HTML page into MIME email
libmime-lite-perl_3.030-2_all.deb module for convenient MIME message creation
libmime-tools-perl_5.505-1_all.deb Perl5 modules for MIME-compliant messages
Advertisement
Advertisement