libmcrypt4_2.5.8-3.3_i386.deb


Advertisement

Description

libmcrypt4 - De-/Encryption Library

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmcrypt4
Package version: 2.5.8
Package release: 3.3
Package architecture: i386
Package type: deb
Installed size: 218 B
Download size: 70.17 KB
Official Mirror: ftp.br.debian.org
libmcrypt is the library which implements all the algorithms and modes found in mcrypt. libmcrypt supports the algorithms: BLOWFISH, TWOFISH, DES, TripleDES, 3-WAY, SAFER-sk64, SAFER-sk128, SAFER+, LOKI97, GOST, RC2, RC6, MARS, IDEA, RIJNDAEL-128, RIJNDAEL-192, SERPENT, RIJNDAEL-256, CAST-128 (known as CAST5), CAST-256, ARCFOUR, ENIGMA, PANAMA, XTEA and WAKE. Block algorithms can be used in: CBC, ECB, CFB and OFB (8 bit and n bit, where n is the size of the algorithm's block length). More information can be found at the libmcrypt homepage http://mcrypt.sourceforge.net/ .

Alternatives

Requires

    Download

    Source package: libmcrypt

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmcrypt4 deb package:
      # sudo apt-get install libmcrypt4

    Files

    • /usr/lib/libmcrypt.so.4
    • /usr/lib/libmcrypt.so.4.4.8
    • /usr/share/doc/libmcrypt4/changelog.Debian.gz
    • /usr/share/doc/libmcrypt4/changelog.gz
    • /usr/share/doc/libmcrypt4/copyright

    Changelog

    2014-09-15 - Wookey <wookey@debian.org> libmcrypt (2.5.8-3.3) unstable; urgency=low * Non-maintainer upload. * Really fix #754132

    2014-08-25 - Andreas Barth <aba@ayous.org> libmcrypt (2.5.8-3.2) unstable; urgency=low * Non-maintainer upload. * Fix FTBFS by using dh --with autoreconf. Closes: #754132

    2009-08-14 - Steve Langasek <vorlon@debian.org> libmcrypt (2.5.8-3.1) unstable; urgency=high * Non-maintainer upload. * High-urgency upload for RC bugfix. * Add missing Replaces: from libmcrypt-dev to libmcrypt4 (<< 2.5.8-1). Closes: #523310.

    2009-03-30 - RISKO Gergely <risko@debian.org> libmcrypt (2.5.8-3) unstable; urgency=low * Applied the following patches from sourceforge.net's bugtracker: - libmcrypt-2.5.8-prototypes.diff http://sourceforge.net/tracker/?func=detail&aid=1872799&group_id=87941&atid=584895 - libmcrypt-rotate-mask.patch (this should fix build on 64bit archs) http://sourceforge.net/tracker/?func=detail&aid=2424445&group_id=87941&atid=584895

    2009-03-29 - RISKO Gergely <risko@debian.org> libmcrypt (2.5.8-2) unstable; urgency=low * debian/rules: fix the clean target, which wasn't runnable after extracting the source package * remove unneeded libltdl-dev build dependency

    2009-03-28 - RISKO Gergely <risko@debian.org> libmcrypt (2.5.8-1) unstable; urgency=low * Imported Upstream version 2.5.8 (closes: #427437) - fixes lib/libmcrypt.m4 quoting bug (closes: #305288) * debian/rules: simplified packaging by using dh * new control fields (homepage, vcs-*), watch file, debian/compat = 7 * include the mcrypt.3 manpage as libmcrypt.3 in the dev package * enable static library in the dev package * put .so and .la into the dev instead of the lib package (closes: #501680) * debian/copyright cleanups * ${Source-Versions} -> ${binary:Version} in debian/control * Depends: ${misc:Depends} in debian/control * lintian source package overrides: debian/source.lintian-overrides * config.sub, config.guess patch to use the versions from /usr/share/misc * support 40 and 80 bits long keys in cast5 patch sent to upstream (closes: #299509)

    2008-12-13 - Vincent Bernat <bernat@debian.org> libmcrypt (2.5.7-5.1) unstable; urgency=low * NMU upload. * Fix spurious aclocal warning thanks to a patch from Alban Browaeys. Closes: #305288.

    2005-03-21 - RISKO Gergely <risko@debian.org> libmcrypt (2.5.7-5) unstable; urgency=low * updated the description about the new algorithms * new sourceforge project url added to the copyright file

    2004-09-26 - RISKO Gergely <risko@debian.org> libmcrypt (2.5.7-4) unstable; urgency=low * relibtoolize for GNU/k*BSD (closes: #266323)

    2004-08-14 - RISKO Gergely <risko@debian.org> libmcrypt (2.5.7-3) unstable; urgency=low * adding Replaces: libmcrypt4 (<< 2.5.7-2) to libmcrypt-dev, thanks to Ray (closes: #265586)

    Advertisement
    Advertisement