libmath-complex-perl_1.59-1_all.deb


Advertisement

Description

libmath-complex-perl - complex numbers and associated mathematical functions

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmath-complex-perl
Package version: 1.59
Package release: 1
Package architecture: all
Package type: deb
Installed size: 137 B
Download size: 50.56 KB
Official Mirror: ftp.br.debian.org
Math::Complex is a Perl library letting you create and manipulate complex numbers. By default, Perl limits itself to real numbers, but an extra "use" statement brings full complex support, along with a full set of mathematical functions typically associated with and/or extended to complex numbers. Also included is Math::Trig providing trigonometric functions beyond what is provided by Perl itself.

Alternatives

Requires

    Download

    Source package: libmath-complex-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmath-complex-perl deb package:
      # sudo apt-get install libmath-complex-perl

    Files

    • /usr/share/doc/libmath-complex-perl/TODO
    • /usr/share/doc/libmath-complex-perl/buildinfo.gz
    • /usr/share/doc/libmath-complex-perl/changelog.Debian.gz
    • /usr/share/doc/libmath-complex-perl/changelog.gz
    • /usr/share/doc/libmath-complex-perl/copyright
    • /usr/share/man/man3/Math::Complex.3pm.gz
    • /usr/share/man/man3/Math::Trig.3pm.gz
    • /usr/share/perl5/Math/Complex.pm
    • /usr/share/perl5/Math/Trig.pm

    Changelog

    2012-03-19 - Jonas Smedegaard <dr@jones.dk> libmath-complex-perl (1.59-1) unstable; urgency=low * New upstream release. [ gregor herrmann ] * Remove debian/source/local-options; abort-on-upstream-changes and unapply-patches are default in dpkg-source since 1.16.1. [ Jonas Smedegaard ] * Bump standards-version to 3.9.3. * Update copyright file: + Bump format to 1.0. + Fix double-indent in Copyright fields as per Policy §5.6.13. * Update package relations: + Relax build-dependency on cdbs: Needlessly tight. + Relax build-depend unversioned on debhelper and devscripts: Needed versions satisfied even in oldstable.

    2011-06-25 - Jonas Smedegaard <dr@jones.dk> libmath-complex-perl (1.58-1) unstable; urgency=low * New upstream release. * Update copyright file: + Quote licenses in License comments.

    2011-05-08 - Jonas Smedegaard <dr@jones.dk> libmath-complex-perl (1.57-1) unstable; urgency=low * New upstream release. * Improve package relations: + Stop declaring packages part of core Perl even in oldstable: - libtest-simple-perl - libscalar-list-utils-perl * Update copyright file: + Rewrite using draft 174 of DEP-5 format. + Rewrap license fields at 72 chars, and shorten comments. * Bump policy compliance to standards-version 3.9.2. * Tidy long description: + Add missing space.

    2011-03-05 - Jonas Smedegaard <dr@jones.dk> libmath-complex-perl (1.56-1) unstable; urgency=low * Initial packaging release. Closes: bug#616526.

    Advertisement
    Advertisement