libmath++0c2a_0.0.4-5_i386.deb


Advertisement

Description

libmath++0c2a - C++ Math Type Library

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: libmath++0c2a
Package version: 0.0.4
Package release: 5
Package architecture: i386
Package type: deb
Installed size: 53 B
Download size: 9.59 KB
Official Mirror: ftp.br.debian.org
Libmath++ is a template based math library, written in C++ for symbolic and numeric calculus applications. Currently implemented features include conversion between string and tree representations, symbolic differentiation, and expression simplification.

Alternatives

    Download

    Source package: libmath++

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install libmath++0c2a deb package:
      # sudo apt-get install libmath++0c2a

    Files

    • /usr/lib/i386-linux-gnu/libmath++.so.0
    • /usr/lib/i386-linux-gnu/libmath++.so.0.0.3
    • /usr/share/doc/libmath++0c2a/changelog.Debian.gz
    • /usr/share/doc/libmath++0c2a/changelog.gz
    • /usr/share/doc/libmath++0c2a/copyright

    Changelog

    2013-12-17 - Markus Koschany <apo@gambaru.de> libmath++ (0.0.4-5) unstable; urgency=medium * New maintainer Debian Games Team. (Closes: #634497) * Add myself to Uploaders. * Do not install NEWS file. It contains nothing noteworthy. * Add libmath++-doc.install to install the doxygen documentation. * Add watch file and a comment why there is nothing to watch. * debian/control: - Add rdfind and symlinks to Build-Depends-Indep. Remove duplicate files in doc package. - Bump Standards-Version to 3.9.5, no changes. - Add VCS-fields. - Add homepage field. - Drop automake, cdbs and libtool. Use dh-autoreconf instead. - Use Pre-Depends: ${misc:Pre-Depends}. - Drop Conflicts and Replaces fields. They are obsolete. * Switch to dh-sequencer. * Enable all hardening build flags. * Update debian/copyright to copyright format 1.0. The license of libmath++ is LGPL-2+. * debian/patches: - Add DEP-3 header to enable_dot.patch. - Rename patch filename extension from diff to patch. * Add libmath++0c2a.symbols file.

    2011-07-18 - Daniel Schepler <schepler@debian.org> libmath++ (0.0.4-4) unstable; urgency=low * Orphaning package. (See #634497). * Build against latest automake, now that libtool is incompatible with automake1.7. (Closes: #628307). * Remove .la file from -dev package. * Multiarchify. * Bump Standards-Version to 3.9.2. * Update to 3.0 (quilt) source format.

    2005-11-21 - Daniel Schepler <schepler@debian.org> libmath++ (0.0.4-3) unstable; urgency=low * Recompile with new g++ due to allocator changes; rename libmath++0c2 -> libmath++0c2a. (Closes: #339210). * Add graphviz and gsfonts-x11 to Build-Depends-Indep to get improved doxygen docs.

    2005-07-08 - Daniel Schepler <schepler@debian.org> libmath++ (0.0.4-2) unstable; urgency=low * g++-4.0 transition: libmath++0 -> libmath++0c2. * Update Standards-Version to 3.6.2 (no changes needed).

    2004-09-30 - Daniel Schepler <schepler@debian.org> libmath++ (0.0.4-1) unstable; urgency=low * New upstream release. + Compiles fine with g++-3.4. (Closes: #260597). * Update to using automake1.7.

    2003-08-04 - Daniel Schepler <schepler@debian.org> libmath++ (0.0.3-3) unstable; urgency=low * Use binary-install/libmath++-doc instead of install/libmath++-doc; the former isn't run by binary-arch, but for some reason the latter is. (Closes: #203997). * Update section of libmath++-dev to libdevel, to match overrides.

    2003-08-03 - Daniel Schepler <schepler@debian.org> libmath++ (0.0.3-2) unstable; urgency=low * Update to Standards-Version 3.6.0. + Use libtool 1.5 to get library with proper binary dependencies. * Switch to cdbs. * Add examples to libmath++-doc.

    2003-02-22 - Daniel Schepler <schepler@debian.org> libmath++ (0.0.3-1) unstable; urgency=low * Initial Release.

    Advertisement
    Advertisement