libmaa3_1.3.2-3_i386.deb


Advertisement

Description

libmaa3 - maa programming library

Property Value
Distribution Debian 8 (Jessie)
Repository Debian Main i386
Package name libmaa3
Package version 1.3.2
Package release 3
Package architecture i386
Package type deb
Installed size 155 B
Download size 60.87 KB
Official Mirror ftp.br.debian.org
The libmaa library provides many low-level data structures which are
helpful for writing compilers, including hash tables, sets, lists,
debugging support, and memory management.  Although libmaa was designed
and implemented as a foundation for the kheperalong, the data structures
are generally applicable to a wide range of programming problems.
The memory management routines are especially helpful for improving the
performance of memory-intensive applications.

Alternatives

Package Version Architecture Repository
libmaa3_1.3.2-3_amd64.deb 1.3.2 amd64 Debian Main
libmaa3 - - -

Requires

Name Value
libc6 >= 2.15
multiarch-support -

Download

Type URL
Binary Package libmaa3_1.3.2-3_i386.deb
Source Package libmaa

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libmaa3 deb package:
    # sudo apt-get install libmaa3

Files

Path
/usr/lib/i386-linux-gnu/libmaa.so.3
/usr/lib/i386-linux-gnu/libmaa.so.3.0.0
/usr/share/doc/libmaa3/NEWS.gz
/usr/share/doc/libmaa3/README
/usr/share/doc/libmaa3/changelog.Debian.gz
/usr/share/doc/libmaa3/changelog.gz
/usr/share/doc/libmaa3/copyright

Changelog

2014-09-20 - Robert Luberda <robert@debian.org>
libmaa (1.3.2-3) unstable; urgency=medium
* Build-Depends on libtool-bin instead of libtool (closes: #761765).
* Compile library with LFS support (lintian).
* Standards-Version: 3.9.6 (no-changes).
2013-05-09 - Robert Luberda <robert@debian.org>
libmaa (1.3.2-2) unstable; urgency=low
* Upload to unstable.
* Mark both binary packages as `Multi-Arch: same'.
2013-03-26 - Robert Luberda <robert@debian.org>
libmaa (1.3.2-1) experimental; urgency=low
* New upstream version.
* Bump debhelper compat version to 9 and make changes needed for the
multi-arch support introduced in debhelper 9.
* Fix typos found by lintian in debian/copyright file.
* Update 01-Makefile.patch not to link with -lm to fix dpkg-shlibdeps warning.
* Standards-Version: 3.9.3.
2011-10-29 - Robert Luberda <robert@debian.org>
libmaa (1.3.1-1) unstable; urgency=low
* New upstream version.
* Drop 03-gcc-4.6-warnings.patch, is no longer needed. 
2011-05-05 - Robert Luberda <robert@debian.org>
libmaa (1.3.0-1) unstable; urgency=low
[ Jonathan Nieder ]
* Retrieve compiler flags at build time using dpkg-buildflags,
so settings like DEB_CFLAGS_APPEND=-Werror from the environment
can be respected.
* Pass CFLAGS to configure at build time.  Previously it was
set but not exported, so DEB_BUILD_OPTIONS=noopt did not work.
* Build-Depends: dpkg-dev (>= 1.15.7) for dpkg-buildflags.
[ Robert Luberda ]
* New upstream version:
+ rename libmaa2 to libmaa3 as soname has changed.
* Change source format to `3.0 (quilt)':
+ remove quilt from build dependencies;
+ remove debian/README.source file.
* Standards-Version: 3.9.2 (no changes).
* debian/copyright:
+ drop leading article from synopsis lines (lintian);
+ reorder dependencies with wrap-and-sort command;
+ add VCS fields.
* Change format of debian/copyright to DEP-5.
* New patches:
+ 02-Spelling-typos.patch: fix spelling typos found by lintian;
+ 03-gcc-4.6-warnings.patch: fix warnings given by gcc-4.6
(closes: #624523, #625366).
* Switch to tiny rules format and use debhelper v8.
2010-01-01 - Robert Luberda <robert@debian.org>
libmaa (1.2.0-1) unstable; urgency=low
* New upstream release.
* Rename binary package to libmaa2 due to soname change.
* Standards-Version: 3.8.3 (no changes).
* Add README.source file (lintian).
2009-03-07 - Robert Luberda <robert@debian.org>
libmaa (1.1.1-1) unstable; urgency=low
* New upstream release.
2009-01-19 - Robert Luberda <robert@debian.org>
libmaa (1.1.0-2) unstable; urgency=low
* Fixed debian/copyright.
* debian/watch: use the sf redirector (lintian).
* debian/control: fix the following lintian infos:
+ `binary-control-field-duplicates-source field "section"';
+ `duplicate-long-description'.
2008-12-29 - Robert Luberda <robert@debian.org>
libmaa (1.1.0-1) unstable; urgency=low
* Initial release (closes: #510035).
* 01-Makefile.patch: distclean shouldn't remove config.h.in.

See Also

Package Description
libmac-widgets-doc_0.10.0+svn416-dfsg1-1_all.deb documentation for libmac-widgets-java
libmac-widgets-java_0.10.0+svn416-dfsg1-1_all.deb collection of Mac style widgets written in Java
libmad-ocaml-dev_0.4.4-1+b2_i386.deb OCaml bindings for the MAD library (Development package)
libmad-ocaml_0.4.4-1+b2_i386.deb OCaml bindings for the MAD library (Runtime library)
libmad0-dev_0.15.1b-8+deb8u1_i386.deb MPEG audio decoder development library
libmad0_0.15.1b-8+deb8u1_i386.deb MPEG audio decoder library
libmadlib-dev_1.3.0-2.1_i386.deb mesh adaptation library
libmadlib_1.3.0-2.1_i386.deb mesh adaptation library
libmagic-dev_5.22+15-2+deb8u4_i386.deb File type determination library using "magic" numbers (development)
libmagic-ocaml-dev_0.7.3-5+b4_i386.deb OCaml bindings for the File type determination library
libmagic-ocaml_0.7.3-5+b4_i386.deb OCaml bindings for the File type determination library
libmagic1_5.22+15-2+deb8u4_i386.deb File type determination library using "magic" numbers
libmagick++-6-headers_6.8.9.9-5+deb8u12_all.deb object-oriented C++ interface to ImageMagick - header files
libmagick++-6.q16-5_6.8.9.9-5+deb8u12_i386.deb object-oriented C++ interface to ImageMagick
libmagick++-6.q16-dev_6.8.9.9-5+deb8u12_i386.deb object-oriented C++ interface to ImageMagick - development files
Advertisement
Advertisement