liblwpx-paranoidagent-perl_1.10-5_all.deb


Advertisement

Description

liblwpx-paranoidagent-perl - a "paranoid" subclass of LWP::UserAgent

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: liblwpx-paranoidagent-perl
Package version: 1.10
Package release: 5
Package architecture: all
Package type: deb
Installed size: 84 B
Download size: 17.84 KB
Official Mirror: ftp.br.debian.org
The LWPx::ParanoidAgent is a class subclassing LWP::UserAgent, but paranoid against attackers. It's to be used when a remote resource is fetched on behalf of a possibly malicious user. This class can do whatever LWP::UserAgent can (callbacks, uploads from files, etc). Proxy support has been removed, because in that case you should do your paranoia at your proxy. The URI scheme are limited to http and https.

Alternatives

    Download

    Source package: liblwpx-paranoidagent-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install liblwpx-paranoidagent-perl deb package:
      # sudo apt-get install liblwpx-paranoidagent-perl

    Files

    • /usr/share/doc/liblwpx-paranoidagent-perl/changelog.Debian.gz
    • /usr/share/doc/liblwpx-paranoidagent-perl/changelog.gz
    • /usr/share/doc/liblwpx-paranoidagent-perl/copyright
    • /usr/share/man/man3/LWPx::ParanoidAgent.3pm.gz
    • /usr/share/perl5/LWPx/ParanoidAgent.pm
    • /usr/share/perl5/LWPx/Protocol/http_paranoid.pm
    • /usr/share/perl5/LWPx/Protocol/https_paranoid.pm

    Changelog

    2014-11-18 - Hilko Bengen <bengen@debian.org> liblwpx-paranoidagent-perl (1.10-5) unstable; urgency=medium * Added patch for passing the right parameters through IO::Socket::SSL (Closes: #761635)

    2014-09-09 - Hilko Bengen <bengen@debian.org> liblwpx-paranoidagent-perl (1.10-4) unstable; urgency=medium * Switched debian/watch to metacpan * Use Debian's ca-certificates package instead of relying on Mozilla::CA (Closes: #744404)

    2014-06-19 - Hilko Bengen <bengen@debian.org> liblwpx-paranoidagent-perl (1.10-3) unstable; urgency=medium * Updated HTTPS patch (Closes: #738493)

    2014-06-11 - Hilko Bengen <bengen@debian.org> liblwpx-paranoidagent-perl (1.10-2) unstable; urgency=medium * Added patch to fix HTTPS (Closes: #738493)

    2014-01-05 - Hilko Bengen <bengen@debian.org> liblwpx-paranoidagent-perl (1.10-1) unstable; urgency=low * New upstream version * Tests that require internet access are only run if the ONLINE_TESTS environment variable is set (Closes: #734105) * Bumped Standards-Version * Added libcrypt-ssleay-perl dependency

    2013-07-28 - Hilko Bengen <bengen@debian.org> liblwpx-paranoidagent-perl (1.09-1) unstable; urgency=low * New upstream version * Added watch file * Switched to Debhelper compat level 9, cleaned up debian/rules * Bumped Standards-Version * Added build-dependencies for running tests

    2009-12-13 - Hilko Bengen <bengen@debian.org> liblwpx-paranoidagent-perl (1.07-1) unstable; urgency=low * New Upstream Version - explicitly loading of LWP::Debug made it to upstream. * Bumped Standards-Version

    2009-03-08 - Hilko Bengen <bengen@debian.org> liblwpx-paranoidagent-perl (1.04-1) unstable; urgency=low * New Upstream Version * Bumped Standards-Version * Explicitly require LWP::Debug so LWP::Debug::debug is available. Closes: #518685

    2008-04-05 - Mark Hymers <mhy@debian.org> liblwpx-paranoidagent-perl (1.03-1.1) unstable; urgency=low * Non-maintainer upload. * Fix FTBFS with Perl 5.10. Closes: #467890

    2007-01-06 - Hilko Bengen <bengen@debian.org> liblwpx-paranoidagent-perl (1.03-1) unstable; urgency=low * Initial Release. (Closes: #399458)

    Advertisement
    Advertisement