liblwp-protocol-psgi-perl_0.07-1_all.deb


Advertisement

Description

liblwp-protocol-psgi-perl - override LWP's HTTP/HTTPS backend with your own PSGI application

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: liblwp-protocol-psgi-perl
Package version: 0.07
Package release: 1
Package architecture: all
Package type: deb
Installed size: 31 B
Download size: 15.88 KB
Official Mirror: ftp.br.debian.org
PSGI is a specification to decouple web server environments from web application framework code. LWP::Protocol::PSGI is a module to hijack *any* code that uses LWP::UserAgent underneath such that any HTTP or HTTPS requests can be routed to your own PSGI application. Because it works with any code that uses LWP, you can override various WWW::*, Net::* or WebService::* modules such as WWW::Mechanize, without modifying the calling code or its internals.

Alternatives

    Download

    Source package: liblwp-protocol-psgi-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install liblwp-protocol-psgi-perl deb package:
      # sudo apt-get install liblwp-protocol-psgi-perl

    Files

    • /usr/share/doc/liblwp-protocol-psgi-perl/README.gz
    • /usr/share/doc/liblwp-protocol-psgi-perl/buildinfo_all.gz
    • /usr/share/doc/liblwp-protocol-psgi-perl/changelog.Debian.gz
    • /usr/share/doc/liblwp-protocol-psgi-perl/changelog.gz
    • /usr/share/doc/liblwp-protocol-psgi-perl/copyright
    • /usr/share/man/man3/LWP::Protocol::PSGI.3pm.gz
    • /usr/share/perl5/LWP/Protocol/PSGI.pm

    Changelog

    2014-05-31 - Jonas Smedegaard <dr@jones.dk> liblwp-protocol-psgi-perl (0.07-1) unstable; urgency=medium [ upstream ] * New release. + Update documentation. + Remove some dependencies. [ Jonas Smedegaard ] * Bump to standards-version 3.9.5. * Fix use canonical Vcs-Git URL. * Update watch file to use metacpan.org URL, and ignore prereleases. * Update copyright info: + Extend coverage of packaging.

    2013-08-30 - Jonas Smedegaard <dr@jones.dk> liblwp-protocol-psgi-perl (0.06-2) unstable; urgency=low * List upstream issue tracker as preferred contact. * Update Homepage to match upstream hint. * Fix stop (build-)depending on libparent-perl or libtest-simple-perl: Provided by perl(-modules).

    2013-07-16 - Jonas Smedegaard <dr@jones.dk> liblwp-protocol-psgi-perl (0.06-1) unstable; urgency=low [ upstream ] * New release. + Support mounting multiple apps with different hosts. + Fix unnecessary dependency. [ Jonas Smedegaard ] * Add README.source emphasizing control.in file as *not* a show-stopper for contributions, referring to wiki page for details. * Add git URL as alternate source. * Stop tracking md5sum of upstream tarball. * Use canonical hostname (anonscm.debian.org) in Vcs-Browser URI. * Bump packaging license to GPL-3+, and extend copyrigt coverage for myself to include recent years. * Drop copyright file Files section for no longer shipped convenience code copy. * Include CDBS snippet perl-build.mk (not perl-makemaker.mk). Build-depend on libmodule-build-tiny-perl. Tighten build-dependency on cdbs to versions supporting Module::Build::Tiny.

    2013-03-03 - Jonas Smedegaard <dr@jones.dk> liblwp-protocol-psgi-perl (0.04-1) unstable; urgency=low [ upstream ] * New release. + Added options to allow limiting overrides, so that PSGI apps that uses LWP can safely use them without being affected. [ Salvatore Bonaccorso ] * Change Vcs-Git to canonical URI (git://anonscm.debian.org) [ Jonas Smedegaard ] * Have git-import-orig suppress upstream .gitignore file. * Bump dephelper compatibility level to 8. * Bump standards-version to 3.9.4.

    2012-09-23 - Jonas Smedegaard <dr@jones.dk> liblwp-protocol-psgi-perl (0.03-1) unstable; urgency=low * New upstream release. [ gregor herrmann ] * Remove debian/source/local-options: abort-on-upstream-changes and unapply-patches are default in dpkg-source since 1.16.1. [ Jonas Smedegaard ] * Update copyright file: + Extend coverage for convenience copy of Module::Install. + Reformat using file format 1.0. * Update package relations: + Relax to build-depend unversioned on cdbs, debhelper and devscripts: Needed versions satisfied in stable, and oldstable no longer supported.

    2011-05-22 - Jonas Smedegaard <dr@jones.dk> liblwp-protocol-psgi-perl (0.02-1) unstable; urgency=low * Initial packaging release. Closes: bug#627583.

    Advertisement
    Advertisement