liblocal-lib-perl_2.000014-1_all.deb


Advertisement

Description

liblocal-lib-perl - module to use a local path for Perl modules

Distribution: Debian 8 (Jessie)
Repository: Debian Main i386
Package name: liblocal-lib-perl
Package version: 2.000014
Package release: 1
Package architecture: all
Package type: deb
Installed size: 149 B
Download size: 53.26 KB
Official Mirror: ftp.br.debian.org
local::lib is a Perl module that provides a quick, convenient way of setting up a user-local library located within the user's home directory. It also constructs and prints out for the user the list of environment variables using the syntax appropriate for the user's current shell (as specified by the SHELL environment variable), suitable for directly adding to one's shell configuration file. More generally, this module enables bootstrapping and usage of a directory containing Perl modules outside of Perl's @INC. This makes it easier to ship an application with an app-specific copy of a Perl module, or collection of modules. It is also useful for the case where an upstream maintainer hasn't applied a patch to a module of theirs that you need for your application.

Alternatives

    Download

    Source package: liblocal-lib-perl

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install liblocal-lib-perl deb package:
      # sudo apt-get install liblocal-lib-perl

    Files

    • /usr/share/doc/liblocal-lib-perl/changelog.Debian.gz
    • /usr/share/doc/liblocal-lib-perl/changelog.gz
    • /usr/share/doc/liblocal-lib-perl/copyright
    • /usr/share/doc/liblocal-lib-perl/examples/scripted_install.pl
    • /usr/share/man/de/man3/local::lib.3pm.gz
    • /usr/share/man/man3/lib::core::only.3pm.gz
    • /usr/share/man/man3/local::lib.3pm.gz
    • /usr/share/man/pt_BR/man3/local::lib.3pm.gz
    • /usr/share/perl5/lib/core/only.pm
    • /usr/share/perl5/local/lib.pm

    Changelog

    2014-09-05 - Salvatore Bonaccorso <carnil@debian.org> liblocal-lib-perl (2.000014-1) unstable; urgency=medium * Update Vcs-Browser URL to cgit web frontend * Add debian/upstream/metadata * Imported upstream version 2.000014

    2014-08-16 - Salvatore Bonaccorso <carnil@debian.org> liblocal-lib-perl (2.000013-1) unstable; urgency=medium * Imported Upstream version 2.000013 * Add Build-Depends-Indep on libtest-minimumversion-perl * Add versioned Build-Depends-Indep on libperl-minimumversion-perl. Testsuite requires at least Perl::MinimumVersion 1.35; Add a versioned Build-Depends-Indep on libperl-minimumversion-perl (>= 1.35). * (Build-)Depends on libmodule-build-perl. Remove the alternative dependency for Module::Build, as Module::Build is in Perl core since 5.9.4, but is deprecated and will be CPAN-only and removed from 5.21.0. * Wrap and sort fields in debian/control file

    2014-05-13 - gregor herrmann <gregoa@debian.org> liblocal-lib-perl (2.000012-1) unstable; urgency=medium * New upstream release.

    2014-04-02 - Salvatore Bonaccorso <carnil@debian.org> liblocal-lib-perl (2.000011-1) unstable; urgency=medium * Imported Upstream version 2.000011

    2014-03-29 - Salvatore Bonaccorso <carnil@debian.org> liblocal-lib-perl (2.000010-1) unstable; urgency=medium * Imported Upstream version 2.000010

    2014-03-08 - Salvatore Bonaccorso <carnil@debian.org> liblocal-lib-perl (2.000008-1) unstable; urgency=low [ gregor herrmann ] * New upstream releases 1.008026, 2.000003. + Documents PREFIX and INSTALL_BASE conflicts and workaround (Closes: #586795) * debian/rules: make (re)movals --verbose. * Update copyright years and list of copyright holders. * Declare compliance with Debian Policy 3.9.5. [ gregor herrmann ] * Strip trailing slash from metacpan URLs. [ Salvatore Bonaccorso ] * Imported Upstream version 2.000004, 2.000006, 2.000007 and 2.000008. * Update copyright years for debian/* packaging

    2013-10-22 - gregor herrmann <gregoa@debian.org> liblocal-lib-perl (1.008023-1) unstable; urgency=low * New upstream release. * Update years of packaging copyright.

    2013-09-18 - Nuno Carvalho <smash@cpan.org> liblocal-lib-perl (1.008018-1) unstable; urgency=low * Team upload * New upstream release * Install 'eg/*' as examples * d/control: move required libmodule-build-perl from D-B-I to Build-Depends, and update versions per cme suggestion

    2013-08-07 - Salvatore Bonaccorso <carnil@debian.org> liblocal-lib-perl (1.008011-1) unstable; urgency=low * Imported Upstream version 1.008011

    2013-05-28 - Salvatore Bonaccorso <carnil@debian.org> liblocal-lib-perl (1.008010-1) unstable; urgency=low * Imported Upstream version 1.008010

    Advertisement
    Advertisement